Jump to content
Poweramp
admin

PowerAMP v2.0 Beta 1

Recommended Posts

Ww were promised search function will be improved in version 2, but in my opinion, this is not the case. First, there should be a dedicated button (not combination of button tappings) for that on the main screen and this should allow me to directly browse by artist, genre, title, year... Instead, there are several buttons, which are not that often used.

Is the dedicated search key most android phones have not dedicated enough (or usually hold menu button on others)? I do notice it seems to be a bit buggy though - the button doesn't always work for me. I do wonder if the equalizer and tone controls are needed at the top though (and could be replaced by a search button I guess - though it is already accessible from the menu as well). You can also get to the library to browse by tapping the current playing song (and search also returns albums/artists/composers etc.). I also wonder if filter and search should be better integrated.

I do agree with your idea that it would be nice to show genre etc. particularly instead of sample rate (and current playlist - can be hard to know what next list button will do). Bit rate can be occasionally useful (but not really necessary) but I can't think of a time I have ever needed the sample rate.

There is a huge list of features that have been implemented for version 2 and we can't have everything at once. There are some things I would rather weren't pushed back to 2.x (like rating tags) over ones that have been implemented that I don't need (like lyric download) but a lot of different people use the app for different things.

Share this post


Link to post
Share on other sites

Hi Max,

I love v2.0, no issues in general, sound is fantastic! My only gripe is Auto Advance using the Library function (so not the Folder option). In v1.4 I normally don't bother making playlists, I just select Play for a song via Artist>Album>Song and it then plays the song, the rest of that album and then the album next in line. When all of the Albums of that particular artist have played it automatically switches to the next Artist in line. Briljant, because that ensures there's always something to play. In V2.0 that works only for the next songs in the applicable album, but then PA stops playing, stating the the list is finished. I do have Auto Advance for library selected in the menu options. So is this a new ' feature' or a bug? Anyway, I would love to have Auto Advance working the way it was in V1.4

Kind Regards,

Speedstra

Share this post


Link to post
Share on other sites

Some feedback on the β1, not sure if reported already:

1. Library->Albums->List Options: when "Reverse" is checked, the albums are sorted in reverse by name , regardless of the sorting option selected (Year or Date Added).

2. Library->Artists->Add to Playlist: when there are several albums by the artist, the songs in the created playlist are seemingly randomly sorted. In v1.4, the songs are sorted in the order of the albums. One would hope that in v2.0 the order of the albums in the playlist would honor the order configured for Library->Artists->Artists.

3. On my phone changing Buffer Size and DVC on/ff during music playback has killed audio and made PA unable to load. Only after reboot, audio came back. You may want to pause playback before changing those settings.

4. "Unknown Artist" in a simple an small library , trying to delete it gives "No files in the selection"

5. Settings->Look&Feel: uncheck "Always show repeat/shuffle" and "Always show rating". Tap on album art, both are still there.

Share this post


Link to post
Share on other sites

I noticed something today:

When I was listening to music with headphones and opened the voice search, instead of stopping the music, it was played through the speakers and not the headphones for the time the voice search was active. When I then closed the voice search, the music started playing correctly through the headphones again.

After some testing, I've also noticed that playing music through the speakers and opening the voice search did not stop the player and the music continued playing.

I'm using a Desire Z running CyanogenMod 7

Share this post


Link to post
Share on other sites

small albumart bug.

seems that Poweramp is using the last tracks embedded art to display in the albums list instead of the albumart.jpg that i place in each albums folder.

Share this post


Link to post
Share on other sites

2. Library->Artists->Add to Playlist: when there are several albums by the artist, the songs in the created playlist are seemingly randomly sorted. In v1.4, the songs are sorted in the order of the albums. One would hope that in v2.0 the order of the albums in the playlist would honor the order configured for Library->Artists->Artists.

I agree and I was going to post this earlier; indeed, I used to select song sorted by artist and in alphabetical order, so that all artist X song will listed followed by those of artist Y. Since I always search song by artist, this was very convenient for me, now, songs sorted by artist and there is no continuity. Please restore the old option or if still there, please advise accordingly.

Share this post


Link to post
Share on other sites
In V2.0 that works only for the next songs in the applicable album, but then PA stops playing, stating the the list is finished. I do have Auto Advance for library selected in the menu options. So is this a new ' feature' or a bug? Anyway, I would love to have Auto Advance working the way it was in V1.4

True. It's obviously a bug. Auto-advance scheme "Library->Artist->Artist Albums" is not working in this beta. After last song it says "! List finished" instead of playing further. Please Max, fix it.

Something else: Equalizer Assign preset for "Current album" is missing now. Why? :cry: Every song from same album, now has to be assigned particulary through "current song". It's a waste of time and nerves. All songs from same ripped CD (Album) sounds equal, all of them require same EQ preset, don't they? This is very important and this was a very useful feature in v1.4. IMHO EQ Assigning for "All songs" makes no sense.

Cosmetic issue: -->Settings, under "audio engine" is word "Crossafe". Crossfade? ;)

Best Regards.

Share this post


Link to post
Share on other sites

Something "cosmetic": Not only are the lyrics displayed but the path of them as well. It would look nicer if that wasn´t the case.

Again, some of the album arts look grainy, especially the darker colours. This was not in previous versions.

Share this post


Link to post
Share on other sites

Just to report

When I try to use some other applications (viber for sms), the sound begins to chopping and to breaking, I don't have this problem with older version. I am using desire HD

Share this post


Link to post
Share on other sites

True. It's obviously a bug. Auto-advance scheme "Library->Artist->Artist Albums" is not working in this beta. After last song it says "! List finished" instead of playing further. Please Max, fix it.

Something else: Equalizer Assign preset for "Current album" is missing now. Why? :cry: Every song from same album, now has to be assigned particulary through "current song". It's a waste of time and nerves. All songs from same ripped CD (Album) sounds equal, all of them require same EQ preset, don't they? This is very important and this was a very useful feature in v1.4. IMHO EQ Assigning for "All songs" makes no sense.

Cosmetic issue: -->Settings, under "audio engine" is word "Crossafe". Crossfade? ;)

Best Regards.

OK,

selecting advanced list under 'repeat off' after tapping the album art portion of the screen solved the Auto-Advance issue. I'm happy now.

Cheers,

Speedstra

Share this post


Link to post
Share on other sites

Quick feedback on using the Beta 1.

What I like

1. The sound is much better. The equaliser pre-set is the best I've used on a music app. I get a richer bass and can turn down the volume.

2. The new interface is great, but I feel that there will be a steep learning curve for newbies in working out what happens.

What doesn't work

1. Don't know what "Tone on" means, needs to be in the help file.

2. Album art doesn't work with Cover Art Download as it use to. Is this deliberate?

3. Album art set in player doesn't show up in Album / Library mode. Can't pursuade the app to accept album art in library mode where its missing.

Wish list

1. Really wish that the app had an exit option in the menu

2. When I scroll through songs the A-Z helper has disappeared. I hope that it comes back. Its reallly helpful in locating songs, artists and albums

3. Really wish that folder / Artist mode had visual pointers / Album covers

Overall very happy with the Beta so far.

Share this post


Link to post
Share on other sites

Been using it all week now and following my earlier comments about DVC I have since changed to a different DesireHD ROM on my HD2 and now enabling DVC definitely improves the sound.

One thing I really like and I can't rememberif it was on the previous version is being able to sneak a look at what song is next by slowly half swiping the album art across the screen.

My main issue with this beta is that it feels like a finished product, i've never seen a beta version with so few issues. :)

The widget can't come soon enough though...

Share this post


Link to post
Share on other sites

Hi Max,

great app and am loving the beta so far but I do have one possible bug for you.... "splitting of MP3 genre tags"

I've got custom genres on most of my albums and with the previous version of the app these were not read at all now they are mostly getting read correctly... examples of ones that are not are;

"Alt. Rock (Oz/NZ)" is resulting in 2 genres -> "Alt. Rock Oz" and "Nz)" both containing all of the same albums and with exact same song counts

So I thought that it might be the "/" character... However I've also got the following;

"Alt. Rock (US)" resulting in "Alt. Rock (US)" (correct) with 1104 songs (also correct) and a "US" genre with only 11 songs -> a subset

So then I though that it might be the "(", ")" characters... but I've also got a genre;

"Alt. Rock (Irish)" which is 100% correct, not split in any way and contains correct song count of 516

I've also got an "Unknown genre" genre that contains zero songs....

hope this info helps for testing/debugging...

keep up the great work,

spm

Share this post


Link to post
Share on other sites

OK,

selecting advanced list under 'repeat off' after tapping the album art portion of the screen solved the Auto-Advance issue. I'm happy now.

Cheers,

Speedstra

I can't confirm that. For me this is still a serious bug, which immediately made me return to 1.4.

If I have an artist with only one album it says list finished, when it should usually proceed to the next artist.

For an artist with more than one album the 2.0 beta only switches (or you can only switch manually) between the artist albums and never proceeds to the next artist, regardless if advance list is activated or not.

Especially when you drive with the car it's difficult/almost impossible and not very secure to select the continue with the next artist, by going into the library again -> going up to artist albums -> going up to artists -> select the next artist -> select the album - > select the (first) song.

So instead of waiting for the player to auto proceed to the next artist, or clicking one button, you have to tap the screen SIX times!

There's also another similar feature missing in 2.0 which is very important for me!

In 1.4 it was not only possible to use the gestures for next/previous song by sliding the screen horizontally.

It was also possible to go through the albums by sliding the screen vertically. I hope these gestures to scroll through albums will return, and combined with my first complaint it's generally possible again to auto-proceed within artists, without creating playlists for each album.

Otherwise I will have to stay on 1.4, which would make me sad, since especially the GUI has made some nice progress!

Everything else was working surprisingly perfect(stable) for a beta, but these features need to return.

Share this post


Link to post
Share on other sites

Love the improvements in this beta, especially the redesign for landscape view on tablets!

Only problems encountered so far:

- Lots of force closes (although music keeps playing which is good!). One way I have found to replicate an FC is if I press Next on my Bluetooth headset 5 times in a row fairly quickly, doesn't seem to happen if I do the same using the icon or by swiping

- Most of the time I usually just want to use 'Shuffle All', at present this requires five clicks from the player screen:

Menu > Folders/Lib > Menu > More > Shuffle All

Would it be possible to have a Shuffle All icon in the top right of the Folders/Lib screen at all?

- The new Grid view is awesome! Is there a way to use higher res thumbnails (maybe as an option for high-end devices only?)

Great work!

Share this post


Link to post
Share on other sites

Hello!

Poweramp is awesome!! but there is a big bug in the beta:

I wanted to delete a file, it stuck on deleting (without skipping the track you're deleting) for about half a minute, then it crashed. I reopened and saw that it deleted all my music! That's pretty annoying since i don't know what i had exactly on the phone...

Share this post


Link to post
Share on other sites

Discovered Poweramp yesterday was suitably impressed - easily the best media player on Android I've found so far - THEN I found the 2.0 beta 1 release - EVEN BETTER!

I was reading somewhere earlier in the forums that "smart playlists" were to be included in 2.0 but can't seem to find it anywhere - has this feature been dropped/skipped from beta1? ( my iTunes life is ruled by smart playlists, and have yet to find a suitable alternative ).

Another side question - should songs be removed from the queue once played? I see that they're not, but are coloured differently to indicate that they've been played,

Share this post


Link to post
Share on other sites

Amazing product, I love the old and new Poweramp. Great job!

tl:dr: queue not removing recently played songs...

A problem Ive found is related to the queue and adding songs to the queue as well as advancing from the queue.

In example: While listening to music I decide to add three or four songs to the queue by searching and then long pressing and selecting "Add to queue". Once the current song finishes the queue begins. After a few songs I add three or more songs to the queue, and this is where the problem begins. The songs on the queue Ive already played replay as if adding new songs to the queue has messed up the order of songs somehow. Either that, or its not removing from the queue, songs that have been played already. I believe the shuffle setting was set to "songs".

Share this post


Link to post
Share on other sites

...an update to my previous post ( I can't reply and make a thread as it still being moderated ). I just realized I found the smart playlists earlier, but these are Poweramp -defined- smart playlists - and not end-user editable ( they are to a degree tho ).

Customized smart playlist that I often use:

- Played 0 times ( great for tracking music you've added, but not yet heard )

- Least Recently Played ( similar to recenly played, only it takes from the bottom of the stack rather the top - great for revisitig music you've not played in a while ).

- Least Played ( again, similar to Most Played, but from the bottom ).

A lot of these "least" style rules I've often used to track new music I get, and after collecting music for 20+ years my collection is LARGE, so having a rules that pull in a good "revisit old music - and surprise my ears" is great ( random/shuffle works, but I see theres no shuffle options for album/artist ).

Share this post


Link to post
Share on other sites

Rolled back to the previous version....the mids are better in 1.4 version and the bass is cleaner,not overwhelmed like in 2.b.

I would like to have the bass and mids of the 1.4 version along with the treble of the 2.0 version.

But since it aint gonna happen,it seems that I'll stick with 1.4 forever.

Share this post


Link to post
Share on other sites

Is it possible to get the lyrics over top of the Album Art on the player screen again?

This feature was awesome in the earlier version, but I cant for the life of me find out how to lay the lyrics over the album art on the player screen on the beta again

Share this post


Link to post
Share on other sites

Rolled back to the previous version....the mids are better in 1.4 version and the bass is cleaner,not overwhelmed like in 2.b.

I would like to have the bass and mids of the 1.4 version along with the treble of the 2.0 version.

But since it aint gonna happen,it seems that I'll stick with 1.4 forever.

That might be my stance too (sticking with 1.4) lol. But only temporarily. 1.4 is polished and perfected, 2.0 will get there too. This app will be legendary in the Android Market, more than it is now.

Share this post


Link to post
Share on other sites

×