Jump to content
Poweramp
maxmp

Poweramp alpha build-705 - Updates for high-res & notifications within old (feature-complete) user interface

Recommended Posts

Good day.

It seems that hi-res is partially not working in my Xperia XZ1 Compact :( (It only shows 48khz/16-bit)

In Xperia X Compact Oreo is working OK
 

Screenshot_20180512-143105.jpg

Screenshot_20180512-150626.jpg

Share this post


Link to post
Share on other sites

 

4 minutes ago, Mehrshad Shafaghi said:

Xiaomi Redmi Note 3

Oreo 8.1 custom rom

I'm missing the OpenSL ES HD output. I was so happy I could finally check to see if the new output actually works on this device or not since I could barely feel any difference.

I have hires experimental output instead, but not the snapdragon 24-bit pcm one. And again, I can't feel any difference compared to default OpenSL output 🤐

Direct Experimental Hi-Res is no less or no more VS OpenSL ES HD. It's just a different way of doing the same thing - providing audio beyond 48khz/16bit. 

I can't confirm if any custom ROM actually produces Hi-Res output, as for the stock ROMs - I test each build on each Hi-Res capable device in my test lab by capturing audio and analyzing spectrum - and most devices do produce real ultrasound up to 96khz (and above e.g. for Snapdragon 835 with 384khz sampling rate).

Only few devices are known to advertise Hi-Res, but have no real Hi-Res output from stock or any other player, including Poweramp, on Hi-Res files (Asus I'm looking at you), despite in fact running all the audio/drivers/etc. on 192khz.

Share this post


Link to post
Share on other sites
2 minutes ago, maxmp said:

 

Direct Experimental Hi-Res is no less or no more VS OpenSL ES HD. It's just a different way of doing the same thing - providing audio beyond 48khz/16bit. 

I can't confirm if any custom ROM actually produces Hi-Res output, as for the stock ROMs - I test each build on each Hi-Res capable device in my test lab by capturing audio and analyzing spectrum - and most devices do produce real ultrasound up to 96khz (and above e.g. for Snapdragon 835 with 384khz sampling rate).

Only few devices are known to advertise Hi-Res, but have no real Hi-Res output from stock or any other player, including Poweramp, on Hi-Res files (Asus I'm looking at you), despite in fact running all the audio/drivers/etc. on 192khz.

Thanks for your response

I had asked this question earlier: How do you check the audio output? (The spectrum analysis and stuff)

I can remember there was a way to check this with some code in the terminal, do you do the same thing?

Share this post


Link to post
Share on other sites
12 minutes ago, Mehrshad Shafaghi said:

I can remember there was a way to check this with some code in the terminal, do you do the same thing?

Provided you have USB debugging enabled on the device and adb installed and Powermap (or other player) active and playing or wired headset:

adb shell dumpsys media.audio_flinger

dumps a lot of info regarding current audio. Dump format differs across devices and ROMs, for Snapdragon look for:

Output thread 0xf095e000, name AudioOut_87D, tid 8788, type 1 (DIRECT):
  I/O handle: 2173
  Standby: no
  Sample rate: 192000 Hz
  HAL frame count: 7680
  HAL format: 0x6 (AUDIO_FORMAT_PCM_24_BIT_PACKED)
  ...

Various 0x... can be anything, but Standby should be no, Sample rate, obviously, 192000 (or the other selected in Poweramp audio output settings), format should be something with 24 bit, FLOAT or 32 bit.

NOTE: for Samsungs, this is completely different (they have non-standard audio pipeline even on Qualcomm SOCs), also few other devices have different dump format.

Share this post


Link to post
Share on other sites
7 hours ago, chirantantab said:

Akhirnya Mi A1 Mendapat Dukungan Hi-Rec o / p .. Android 8.0 .. Terima kasih banyak untuk @maxmp  @andrewilley 

 

 

Screenshot_20180512-161432.png

Screenshot_20180512-161343.png

(Corrects) working after the restart 👌 

Edited by Helmi

Share this post


Link to post
Share on other sites
13 hours ago, maxmp said:

updated and added OpenSL HD output from Poweramp beta-preview (enabled for Android 8+). Includes support for LDAC/UHQ BT (up to 96khz)

Why do not support Android 7 ?

Build 790 works well with HD Output on my device which system is based on Android 7.1.1.

 

Share this post


Link to post
Share on other sites
32 minutes ago, Braamcamp said:

It seems that hi-res is partially not working in my Xperia XZ1 Compact

It does work on (non Compact) XZ @ 8.0.0 - via OpenSL ES HD. What is your Android version? I will try to get XZ1 variant and will check what's happening there. Thanks for the report.

6 minutes ago, sqliuchang said:

Build 790 works well with HD Output on my device which system is based on Android 7.1.1.

Build 790 has no device filters, thus it does play hi-res even if device doesn't actually support that. This is not a desired way of playing audio, as there is double sample rate and format conversion: first upsampling e.g. to 192khz/24bit, then downsampling by Android (so-so) resampler back to 48khz/16bit. The upsampling to Hi-Res is not a bad thing, but that following Android downsampling is. (There are additional possible resampling steps in hardware, as usually they are 1-bit DACs running on very high sampling rate).

Share this post


Link to post
Share on other sites
15 hours ago, maxmp said:

It does work on (non Compact) XZ @ 8.0.0 - via OpenSL ES HD. What is your Android version? I will try to get XZ1 variant and will check what's happening there. Thanks for the report.

Build 790 has no device filters, thus it does play hi-res even if device doesn't actually support that. This is not a desired way of playing audio, as there is double sample rate and format conversion: first upsampling e.g. to 192khz/24bit, then downsampling by Android (so-so) resampler back to 48khz/16bit. The upsampling to Hi-Res is not a bad thing, but that following Android downsampling is. (There are additional possible resampling steps in hardware, as usually they are 1-bit DACs running on very high sampling rate).

Emmm, I know that process and I have used adb command to see the audio output information.

adb shell dumpsys media.audio_flinger

On my PC screen, the audio output information shows my device work well with HD output. Besides, the player also show that it processes audio properly.

ps:

I have upload the audio information and you can also see the differences from the picture(you can download the picture if not clear). The first column is vivo music player which is the default player. The second is poweramp_build_790 under HD Output mode and the third is build_705 under Hi-Res mode. They all play the same song which is 64bit 192khz 24576kbps PCM_F64LE.

My phone has a mode called HI-FI and it seems that the HI-FI mode can be actived only when "Output thread 0xf1783000 type 0 (MIXER)" is used.

 

5af7f793de654.png

audio_output_info.rar

Share this post


Link to post
Share on other sites

Hey. About Hi-res support.

These guys are already sawing for two years audio mode for most devices.

I think they will help and prompt.

 

Привет. Насчёт Hi-res поддержки.

Эти ребята пилят уже в течении двух лет аудио мод для большинства устройств.

Думаю они и помогут и подскажут.

Telegram https://t.me/ainuraudio

xda https://forum.xda-developers.com/android/software/soundmod-ainur-audio-t3450516

Site https://ainuraudio.ru

@maxmp

Share this post


Link to post
Share on other sites

Hi, my phone is Nokia 7 plus (8.1 Oreo). Thanks for the update. Nice to see fixed notification. I had never heard about my phone at this forum, so I will add it to this "base". So I installed new build and try to use the hi res feature. Like the guy with Mi A1 it is not working with headphones and sound comes from internal speaker, also, I doesn't have Open SL HD at output list, but on 790 build it was available (first shot). Right now it doesn't bothering me, because my headphones coast for about 10$, but notification fix is great. Also, old bug is still reproducing (I don't know, did someone report it): when FLAC was parsed from .cue, and the track is finished, it is not moved to next track on my playlist, it was moved to next track at FLAC file (second shot). Thanks for great work. Waiting for 3.0 release )

Screenshot_20180512-204833.png

Screenshot_20180512-205210.png

Share this post


Link to post
Share on other sites
15 hours ago, maxmp said:

It does work on (non Compact) XZ @ 8.0.0 - via OpenSL ES HD. What is your Android version? I will try to get XZ1 variant and will check what's happening there. Thanks for the report.

Build 790 has no device filters, thus it does play hi-res even if device doesn't actually support that. This is not a desired way of playing audio, as there is double sample rate and format conversion: first upsampling e.g. to 192khz/24bit, then downsampling by Android (so-so) resampler back to 48khz/16bit. The upsampling to Hi-Res is not a bad thing, but that following Android downsampling is. (There are additional possible resampling steps in hardware, as usually they are 1-bit DACs running on very high sampling rate).

And it's weird that build 790 works properly under HD Output mode but not Hi-Res. Now, build 705 seems to work properly under Hi-Res mode(it just seems because no HI-FI sign on the status bar and I haven't seen the audio output information through adb command) and it has no HD Output option.

87c01ec7ly1fr93bvyilyj21401z4gu9.jpg

By the way, how are the device filters designed? You can see my device information here:

 

Thank you very much.

My English is poor and I'm sorry for that.

Share this post


Link to post
Share on other sites
1 hour ago, PeterFalk said:

What prevented to release this last May?

But what would you have had to talk about in the meantime if it had? :)

Andre

Share this post


Link to post
Share on other sites
3 hours ago, maxmp said:

It does work on (non Compact) XZ @ 8.0.0 - via OpenSL ES HD. What is your Android version? I will try to get XZ1 variant and will check what's happening there. Thanks for the report.

Build 790 has no device filters, thus it does play hi-res even if device doesn't actually support that. This is not a desired way of playing audio, as there is double sample rate and format conversion: first upsampling e.g. to 192khz/24bit, then downsampling by Android (so-so) resampler back to 48khz/16bit. The upsampling to Hi-Res is not a bad thing, but that following Android downsampling is. (There are additional possible resampling steps in hardware, as usually they are 1-bit DACs running on very high sampling rate).

Good day Max
Thank you for your reply. I'm on version 47.1.A.12.179 (oreo) of Xperia XZ1 Compact (G8441)
I attached an text file with the output of the adb command (adb shell dumpsys media.audio_flinger) like the user sqliuchang posted. Hope it helps

Poweramp 705.txt

Share this post


Link to post
Share on other sites

Hey, @maxmp, Hi-Res output doesn't seem to be enabled on my device.

 

Axon 7 A2017G, AEX 5.5 (Oreo 8.1) with the latest Ainur Sauron installed. I can't use OpenSL HD either since it's only limited to Bluetooth and an external DAC. 

 

Also, a lot of music won't play at all or at least won't have any sound when playing. The seek bar progresses, but there's no audio and the visualizer just maxes out and fills my screen.

Screenshot_Poweramp_20180513-054624.png

Share this post


Link to post
Share on other sites
17 hours ago, Martin Medrano said:

How do you save playlists so the songs don't go away when I import my playlists

Go-to Settings>Folders and library>Export Poweramp Playlists

Share this post


Link to post
Share on other sites
8 hours ago, tmz said:

Do you have "Volume Levels (Experimental)" set to something other than "System Default" (under Audio -> Advanced Tweaks) ?  That option will do this.

Yeah, it's same.. all the time. Still showing casting. But nevermind, Will wait for V3 

Share this post


Link to post
Share on other sites

@maxmp, THANKS for the update (705)! Seems to work great so far for me (LG v20). Can you confirm if the quad-DAC in this device is indeed utilized with the Experimental Hi-Res output? 

Share this post


Link to post
Share on other sites

@maxmp As had been discussed by other users I'm missing Hi-Res audio on my Redmi note 3 running custom Oreo 8.1. It used to work on stock Android 6.0.

I'm currently rooted right now so can you tell what all files I need to check to make sure my ROM supports it?

Share this post


Link to post
Share on other sites

@maxmp,

HTC10. When I enable the Hi-res output, the sounds comes out of the speakers only, not from the headphones. Where is the problem?

Also, isn't it possible to make the output to always match the source's sample frequency? This would be a great addition which would prevent us to manually change it every time we play a different source.

Share this post


Link to post
Share on other sites
1 hour ago, mahalata said:

@maxmp,

HTC10. When I enable the Hi-res output, the sounds comes out of the speakers only, not from the headphones. Where is the problem?

Also, isn't it possible to make the output to always match the source's sample frequency? This would be a great addition which would prevent us to manually change it every time we play a different source.

In me case the sound doesn't come out from speakers... Only with earphones. 

Share this post


Link to post
Share on other sites

Max can you look into android 5 dap's that can output hi res? Like the fiio x5 3rd gen and the x7 mark 2.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×