Jump to content

YAPS goes where no other skin has gone before


Recommended Posts

  • Replies 645
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

On 5/13/2023 at 1:24 PM, slizzap said:

Hey guys,

I've got one issue to report and one feature request. One thing to note is that my usage of PA and YAPS is limited to my car's Android head unit, and I often switch between landscape (full screen) and portrait (split screen, when sharing PA with navigation) views.

  1. After one of the last few updates I noticed that the Track/Album text would randomly get cut off when in portrait view. The odd thing is that if I pressed Play/Pause it would fix the issue and display the full text...until the next song came on and the text changed, then it would happen again. Today I was motivated to play around with the settings and I found that a value of "92" for the Up/Down setting in Portrait view was the sweet spot that solved this problem and fully displayed the text without being cut off. If I set this at 93 the lowercase "Y"s, "P"s, "J"s etc would start cutting off, and any lower just cuts off even more text. But again, pressing Play/Pause would temporarily solve this problem. Moving the Waveseek bar/Play buttons down lower did not allow me to move lower than 92. So while initially I thought it might just be settings and overlapping of elements, this appears to be more of a bug.
  2. Feature request: Can you please allow for the sizing of the Play, Previous/Next Track, Category buttons independently between landscape and portrait views. The buttons were sized perfectly for me in landscape view, but the buttons in portrait view were extremely tiny and almost unusable while driving. Since I was playing around today I tried changing these settings, and now whatever setting I use, even if I revert back to my original settings of 30 dpi (all the way left), the buttons are the exact same size regardless of whether I'm in landscape or portrait view...so now it's too small in landscape view. Having one setting for both views makes it impossible for me to find a happy medium where the buttons are properly sized for both views. I really don't know why they were sized differently before I changed the setting today and now it's the same between both views, and I can't get back.

@slizzap resizing play buttons in landscpe is now available

Link to comment
Share on other sites

Hello.

 

Since the most recent update I am having an issue when I switch to landscape it shows a "skin failed" error message and reverts to the built in skin.  I haven't changed any of my settings.

 

Thanks for any help you can give.

Screenshot_20230520_103502_Poweramp.jpg

Screenshot_20230520_103524_Poweramp.jpg

Link to comment
Share on other sites

Same issue. I downloaded the new skin and it immediately threw that error message. I went into the screen that has these new options and I did the "Restore Defaults" at the bottom of the screen, and this allowed the skin to work again. I started toying around with the Play button size for the Portrait view and got everything dialed in the way I like. Then I went in and made the same change to Landscape view and immediately started crashing. It seems that any changes to the Landscape view for these new settings is crashing the skin.

Link to comment
Share on other sites

On 5/22/2023 at 4:26 AM, flyingdutchman said:

@slizzap  small bug which i have now fixed. 

I saw the update was posted to the Play Store today. Updated it and all settings seem to be working great. Got everything dialed in for both Portrait and Landscape views.

Thanks!

Link to comment
Share on other sites

  • 4 weeks later...

Did you even get anywhere with the bugs I reported a while ago? Specifically:

  • The Chromecast Player Screen icon is still not being hidden when that option set in PA's Settings, it is always visible.
     
  • The Metadata Info's surrounding lozenge panel (which is the only tappable portion) is still getting cropped, presumably by the parent object's bounding area? Ideally I'd like to display it one line lower than this, but it then becomes unusable as the tappable area gets so small that you can't select it:
    image.png
     
  • There is an unexpected horizontal line shown between the MiniPlayer and NavBar Seekbar in library views (which has actually got a lot bigger, as it used to just be a pixel-wide line). I'm guessing it's some kind of background bleed-through?:
    image.png


Andre

Link to comment
Share on other sites

@andrewilley can you email me your skin YAPS settings please

I cannot reproduce the thin line between the miniplayer and navbar. I remember fixing this in a previous release though.

Just released an updated version

        - fix for moving Metadata down
        - added show/hide option for Chromecast button on main UI.

Link to comment
Share on other sites

8 hours ago, flyingdutchman said:

@andrewilley can you email me your skin YAPS settings please

Emailed.

8 hours ago, flyingdutchman said:

        - added show/hide option for Chromecast button on main UI.

Thanks. Presumably follows the main PA setting by default now, I just have mine set to show in the menu:

image.png

Andre

Link to comment
Share on other sites

Thanks for the update. Chromecast button is now able to be hidden, thank you.

The metadata info bounding box issue is partly resolved, but there seem to be two separate boxes in use, one for the main text zone and a second one for the symbol/icon. I'd often wondered why the small symbol background colour sometimes looked strangely different to the rest of the line; now zooming in, I understand why - it's because the two opacities are being superimposed additively creating two different background colours when they should all be the same:

image.png

Andre

Link to comment
Share on other sites

14 minutes ago, flyingdutchman said:

I have added a small margin at the top of the navbar seekbar. Below the result. 

Excellent, thank you. I quite like the colours of the two areas in your example, what values did you set? But still leaving the navbar on the Player Screen fully transparent.

Andre

Link to comment
Share on other sites

2 hours ago, flyingdutchman said:

Transparent does what it says on the tin I believe

For the PA NavBar, transparent works fine on the Player Screen, but it comes out at a solid dark grey on the Library pages. Ideally I'd like it to be transparent on the Player Screen, and allow Blue 700 Opaque on the Library view. Not sure if that's possible though.

Andre

Link to comment
Share on other sites

@andrewilley

 

New option added . You can now select any of the usual colours for the navbar showing in Library and Eq screen. I have found however that when using an opaque colour, the colour in bottom part does not match up with the top part. The reason for this is that the underlying UI navbar is set to transparent It works fine with solid colours though

image.png.8fcd501a4e78641a63e96a95f922a8a4.png

image.png.a1779c9dbdc2f966791b09c25b3237cb.png

Set to Blue700

image.png.72686e74a2889d403e38eabbfb8ff6f8.png

 

Link to comment
Share on other sites

  • 3 weeks later...

Ever since getting v.229, I am no longer able to increase the play button size beyond 50 in landscape mode, or move the elapsed and duration bar without the image being clipped or disappearing all together. Any idea what is causing this? I haven't altered any other settings since v.228.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...