Jump to content
Poweramp
tdas777

v3 build 823 - High Battery Consumption

maxmp

Before posting here, please try the following:

Settings / Look and Feel / Player UI / Chromecast Button - Disable (Poweramp will restart)
This helps with some un-updated/failing Play services libraries being loaded into Poweramp and increasing battery usage.

Settings / Library / Scanner / Auto-scan - Disable
This helps with some apps constantly/frequently sending file system change event causing Poweramp to rescan frequently and increasing battery usage.

Message added by maxmp

Recommended Posts

Ok thanks for the info on Always on screen - testing with it now.

Share this post


Link to post
Share on other sites

I will have to add my battery issue as well.

While out for a run, my phone drained from 100% charged to fully drained and powering off in ... about 90 minutes.

This happened a couple of weeks ago as well, but I assumed it was some sort of random issue. 

Poweramp and Endomondo sports tracker were running, screen off. Bluetooth headset attached.

I've been using this setup with no issues in the past. 

Device Maintenance flagged Poweramp as the highest battery usage in both instances.

I've been seeing Poweramp getting flagged for high battery usage for the last few weeks, but have been close to a charger to plug my phone in before it drained the battery. 

I'm using:

Samsung Galaxy S7, Android 8.0.

Files are all on SD card

I have started using FLAC files recently. 

I use Always On Display with music info. I'm going to try disabling that to see if there's a difference. 

Share this post


Link to post
Share on other sites

Note that ATM I can't reproduce any issues with the Always On Display as well, so this is some isolated (to some users/phones) issue. Tested S7/S8/S9/S10 @ 8.0 and Pie.

1D9BE6DA-D35B-4D69-BC3D-9950FBD90485.jpeg B8AF89EA-A97B-4D5E-81B7-8A345F00888B.jpeg

Share this post


Link to post
Share on other sites

It was always an intermittent problem though. You could often go a few hours without it showing up, then some combination of pause/resume and it appears

Share this post


Link to post
Share on other sites

I've been noticing this issue on my phone in recent weeks too. Even after uninstalling and reinstalling.

Galaxy S9+, Android 8.0, using most current Full version, files on 128GB Micro SD, and I use both bluetooth and wired connections. It doesn't seem to happen every time I use it, but I do notice it happening more when I have a wired headset plugged in.

I have never used the Always On Display with my Galaxy, so I know that is not the cause here. I double checked and made sure it was showing up as off this time as well.

I noticed some similarities with what NicoleS was experiencing too. Android has often been closing Poweramp on its own due to the power usage. And when I went on a walk this afternoon, the battery went from 95% to 55% in just under two hours, and a new Android notification I never saw before came up saying that Poweramp had "overloaded" the system - then recommended it be turned off.

Share this post


Link to post
Share on other sites

Also, can you elaborate a bit: do you use any of these:

- notification options in Poweramp look and feel (e.g. Keep Notification and other)
- Keep Service option
- LDAC + Hi-Res output, or hi-res output on sample frequencies > 48khz

Thanks!

Share this post


Link to post
Share on other sites

Can I suggest that if anyone can reliably reproduce this battery drain issue, could they try clearing all PA data or doing a clean install and then see if it happens again? (remember to back up your settings and/or playlists before doing this, as you will lose them to do such a test). That would eliminate it being a setting change in PA that is causing this. 

Andre

Share this post


Link to post
Share on other sites

 I haven't got my headphones today, so can't test.. I use Poweramp mainly to get "in the zone" when working. But I'm confident that everytime I get the issue I have been in an office environment where I run Poweramp with the screen off, pausing and resuming songs using inline controls when interrupted. Occasionally, when grabbing a coffee, I'll pause by yanking the cable and resume by plugging it back in.

I'm fairly certain that it always takes a few interruptions before the problem starts 

 

Hi, 

My experience matches this above. I notice the issue when the phone gets really hot, then I see that the battery has lost a big chunk and the battery graph has taken a big nose dive.

I have to re-start the phone to return to normal battery consumption. I'd say 50% of the time it is fine, 50% it starts draining for no apparent reason. I cannot determine any common factor so far.

This is on an LG V30 using the hi-fi DAC. Android 8.0.0. Music on SD card using a fixed playlist.

Definitely Poweramp (or Poweramp combined with something else) causing it as I only recently came back to it from a different player and this battery drain started then and only occurs when listening to music.

(This is always with screen off using earphones).

This is from a very recent install of Poweramp. I did try clearing and reinstalling it and the problem remains.

Regards

Mark

 

Share this post


Link to post
Share on other sites
22 hours ago, maxmp said:

Also, can you elaborate a bit: do you use any of these:

- notification options in Poweramp look and feel (e.g. Keep Notification and other)
- Keep Service option
- LDAC + Hi-Res output, or hi-res output on sample frequencies > 48khz

Thanks!

Sure!

- Yes. There's usually an icon on the top bar.

- I don't believe so.

- Not to my knowledge. Most of the tracks I have are 320 mp3 with a handful of WAV ones, but it's rare that I use anything different settings-wise to play the later.

Share this post


Link to post
Share on other sites

@Larry 609 Play (>) icon is required and is always there. By notification option I mean Always Keep Notification option (and related) in Look and feel / Notifications.

Share this post


Link to post
Share on other sites

Ah, gotcha. Always Keep Notification is off. "Colorize Notification" is the only one that is on. Otherwise, the other options are off and the main setting is "Auto."

Here is a screencap of when the Galaxy S9+ kills Poweramp midplay as well.

Screenshot_20190508-122451_Poweramp(1).jpg

Share this post


Link to post
Share on other sites

@Larry 609 ok, thanks for the details. Another question - do you use by chance some smartwatch with this phone? If yes, do you use any media controlling app on the watch?

Share this post


Link to post
Share on other sites

I should be receiving my new Galaxy A70 today, so I'll be joining the Samsung Pie community and will see if I get the same sort of issues (my poor old trusty 6.0.1 Note 3 died a little while ago, and I've being using an even older Galaxy S4 with Lollipop as my daily device in the meantime). 

Andre

Share this post


Link to post
Share on other sites
14 hours ago, Larry 609 said:

Ah, gotcha. Always Keep Notification is off. "Colorize Notification" is the only one that is on. Otherwise, the other options are off and the main setting is "Auto."

Here is a screencap of when the Galaxy S9+ kills Poweramp midplay as well.

Screenshot_20190508-122451_Poweramp(1).jpg

 

I had the same problem with my Galaxy Note 9 a week or so ago as well, Poweramp was killed midplay with that error-message, happened several times.

I went into the app settings for Poweramp on my phone and changed 'change system settings' from 'off' (which was default) to 'on' (give permission).

I haven't had the error-message since. I don't know if this is a fix or not but it worked for me so I thought I'd mention it since my phone is similar to yours.

 

Let me add that I too experience the 'high battery consumption-hot phone' issue that many other Samsung owners here have mentioned. I don't use my phone

as heavily as many others so it isn't a big issue for me but thought I could mention it. My phone also warns me that 'Poweramp is using much battery in the

background' and says to put it into hibernation/sleep mode. I have tried doing a clean install but it hasn't helped. I never have 'Always On Display' on. I have no

battery stats screenshots, others with heavier use of the phone (=more affected) will probably better be able to document the issues, but thought I'd pitch in.

 

Share this post


Link to post
Share on other sites
6 hours ago, maxmp said:

@Larry 609 ok, thanks for the details. Another question - do you use by chance some smartwatch with this phone? If yes, do you use any media controlling app on the watch?

Glad to help. And no, there is no smartwatch or similar equipment that's used in that respect. The only devices I connect to are my Bluetooth headphones and car stereo. Like I said though, if anything, the wired connection is the one where I notice the most drain.

 

@Malagant Appreciate the heads up. I'm assuming it didn't help much with the battery issue though? The error message isn't too common for me, so I might hold off on changing anything until something's resolved on the battery end. Assuming that's sooner than later.

Share this post


Link to post
Share on other sites
1 hour ago, Larry 609 said:

 

@Malagant Appreciate the heads up. I'm assuming it didn't help much with the battery issue though? The error message isn't too common for me, so I might hold off on changing anything until something's resolved on the battery end. Assuming that's sooner than later.

Glad to help. No, it did not help with the battery issue, but it did 'solve' the 'kill Poweramp' issue for me at least and that was more imperative on my phone while it lasted. The battery issue (drainage and hot phone) seems more complex, as these threads and multiple posts show, hopefully it will be resolved in due course.

Share this post


Link to post
Share on other sites

Hey again,

So the battery drain and hot phone thing happened again, twice in the last 2 days.

I had the problem before but stopping the folder rescanning helped a lot.

Now my battery started to dive as u see in the screenshot, and the only strange thing I noticed is that the stats show much much shorter usage time for Poweramp that I actually used it for. Seems like it only shows the time when it was actually draining.. maybe that's normal, I don't have a lot of knowledge about these things. 

The other thing I noticed was using the app with bluetooth headsets then using it with the wired stereo at the gym is fine but then reconnecting to the bluetooth headset after 2 hours usage with the stereo starts to heat the phone and drain the battery.

Not sure if this helps at all, but maybe. 

Im using

Samsung galaxy S7

Android 8.0.0

Poweramp v3-build-826-play.

Screenshot of battery drain is too big in size, so i cannot attach 😅 I'll try to get rid of my other attachments..

Notification settings - all off, except Colorize notifications 

Hi res output only on for bluetooth headset.

For the rest OpenSL ES output is active.

Let me know if I can share anything else that might help.

Many thanks!

Klara 

 

20190509_215141.jpg

Share this post


Link to post
Share on other sites
12 hours ago, Malagant said:

My phone also warns me that 'Poweramp is using much battery in the

background' and says to put it into hibernation/sleep mode. I have tried doing a clean install but it hasn't helped.

This message is OK, as Samsung firmware detects any background process which lives long, and Poweramp process does indeed live long to play in background as much as needed.

Actual battery usage can be seen in battery stats.

 

@Klara Did you use Poweramp in background or it was active / visible / in foreground during usage? Thanks!

Share this post


Link to post
Share on other sites

@Larry 609 as for car connection, do you use Android Auto? Or is it just usual BT connection w/o Auto app involved? Thanks!

Share this post


Link to post
Share on other sites
20 minutes ago, maxmp said:

@Larry 609 as for car connection, do you use Android Auto? Or is it just usual BT connection w/o Auto app involved? Thanks!

The usual BT connection between the phone and the car (and yes, primarily Poweramp if I"m playing music that way).

I occasionally use Android Auto, but I'm unable to play Poweramp tracks through the BT connection if it's on. There might be a USB option there to bypass that somehow, but I never use it with Android Auto.

Share this post


Link to post
Share on other sites
22 hours ago, andrewilley said:

I should be receiving my new Galaxy A70 today, so I'll be joining the Samsung Pie community and will see if I get the same sort of issues

Well so far so good on Samsung Galaxy A70 Pie, no particular battery issues with PA as far as I can tell. I haven't connected either of my Chromecast devices yet, nor my Android Auto in the car, but will keep an eye on both when I do.

Andre

Share this post


Link to post
Share on other sites
6 hours ago, maxmp said:

This message is OK, as Samsung firmware detects any background process which lives long, and Poweramp process does indeed live long to play in background as much as needed.

Actual battery usage can be seen in battery stats.

 

 

Thanks for the feedback, Max.

I will keep an eye on battery usage when I have heavier use of Poweramp (f.ex. very long listening session many hours one day).

Share this post


Link to post
Share on other sites

I've observed that PA has made a number of updates over the past few weeks. Hopefully, some of the "bug fixes and stability improvements" involve this rapid battery drainage. Only time & testing will tell the cumulative effect of these changes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...