• Announcements

    • andrewilley

      Poweramp v3 Project Update   03/22/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code. It's not quite ready for open testing yet, and although he would like to be able to get it out by the end of the March it may just drop over into April. See forum thread for more details and to discuss.    
maxmp

Poweramp alpha-build-703/704

510 posts in this topic

As far as I know, this beta V3 can't run on Intel devices, but it works perfectly on Zenfone 4, which is I believe to be an Intel device

Share this post


Link to post
Share on other sites

My issue is a smallish one. I've noticed in the alpha version settings for gapless have been removed. Better integration is great, but on my end I've noticed that all my Musepack encoded albums have gaps now :( and i have quite a few musepack albums between my devices because in the official versions work flawlessly.

Share this post


Link to post
Share on other sites

Bug:  Sleep timer does not respect "Play Last Song To End", music is cut off abruptly at set time. This was mentioned previously by nereis (http://forum.powerampapp.com/index.php?/topic/8656-Poweramp-alpha-build-702/&page=9), just wanted to make sure it isn't forgotten. 

 

Since D3Seeker brought up gapless, just thought I'd mention a feature request. I would like to see an option for the opposite of gapless, that is an option to insert gaps (silent periods) between songs.

 

Share this post


Link to post
Share on other sites

Bug(?): Beep sound on volume change when using built in speaker.

Share this post


Link to post
Share on other sites

Try changing Settings > Headset/Bluetooth > Beep and see if that helps.

Andre

Share this post


Link to post
Share on other sites

Hello friends. I have a problem with my phone Xiaomi Redmi Note 3 Pro, MIUI 8.0 (Android 5.1.1).

Sometimes, i pressed "PLAY", and music no playing from 5 to 20 seconds.

And the same thing happens when the music plays. I press "PAUSE" or "NEXT TRACK" or something else, then nothing happens from 5 to 20 seconds, playing current music. Later (from 5 to 20 second), music is stopped or playing next track.

I record the video of screen.

https://drive.google.com/open?id=0B4EwY2neskdITXNMYUd6MXJ4dW

Share this post


Link to post
Share on other sites

Small update on UI progress:

Tthe UI redesign development is finishing, but a chunk is too big to swallow, thus the delays. Basically, the animations, transitions, lists, grids, seekbar, etc. were built from zero, as Android platform just doesn't give what's needed.

Share this post


Link to post
Share on other sites

Thanks for the update Max, there have been a few people asking how it was going recently.

Hopefully as this was a ground-up rebuild you may have been able to incorporate many of the design details that people have been requesting in these forums (especially some of @brainscollector's ideas in http://forum.powerampapp.com/index.php?/topic/8560-proposed-material-design-style-interface-discussion/). Can't wait to see it!

Andre

Share this post


Link to post
Share on other sites
On Wednesday, August 24, 2016 at 4:21 AM, Ryou said:

As far as I know, this beta V3 can't run on Intel devices, but it works perfectly on Zenfone 4, which is I believe to be an Intel device

It works perfectly on my Zenfone 2

Share this post


Link to post
Share on other sites
On 9/1/2016 at 4:48 PM, andrewilley said:

Try changing Settings > Headset/Bluetooth > Beep and see if that helps.

Andre

Made no difference, still beeps on volume change even when listening through built-in speakers. Only happens when Poweramp is in the foreground. Not a big deal for me personally. Anybody else seeing this?

Share this post


Link to post
Share on other sites
1 hour ago, Ron999 said:

Made no difference, still beeps on volume change even when listening through built-in speakers. Only happens when Poweramp is in the foreground. Not a big deal for me personally. Anybody else seeing this?

Strange, are you sure this is not coming from your OS?

Andre

Share this post


Link to post
Share on other sites
9 hours ago, maxmp said:

Small update on UI progress:

Tthe UI redesign development is finishing, but a chunk is too big to swallow, thus the delays. Basically, the animations, transitions, lists, grids, seekbar, etc. were built from zero, as Android platform just doesn't give what's needed.

When does the new beta version ? today ? tomorrow? this week ? It's been over 4 months since the last alpha version released

Share this post


Link to post
Share on other sites
4 hours ago, andrewilley said:

Strange, are you sure this is not coming from your OS?

Andre

Like I said, only happens when PA is in the foreground. Oh well, not worth worrying about if nobody else is seeing it.

Share this post


Link to post
Share on other sites
3 hours ago, MMG said:

When does the new beta version ? today ? tomorrow? this week ? It's been over 4 months since the last alpha version released

It will come when its ready! Let the developer do his work.

Share this post


Link to post
Share on other sites
7 hours ago, MMG said:

When does the new beta version ? today ? tomorrow? this week ? It's been over 4 months since the last alpha version released

Thank you for your patience and for your ever-helpful input to these forums.

Of course, if you think you can do better or faster, please feel free to go ahead - I'm sure we look forward to seeing your work soon in the app store, perhaps you could have it ready by tomorrow or next week ?

Andre

Share this post


Link to post
Share on other sites

Max you staying silent for months kinda defeat the purpose of having a forum

Share this post


Link to post
Share on other sites

I use this app mostly in my car with bluetooth. I am using a Nexus 5X with Android Marshmallow, though I had the same problems on Android Lollipop.

It does not always work well. When I switch to bluetooth, my phone stops playing and when I switch my car back to radio the app starts in the background (I see a notification icon).

Also the app automatically starts and stops very quick sometimes, when I am not in the car.

Share this post


Link to post
Share on other sites
4 hours ago, Bijoya said:

Also the app automatically starts and stops very quick sometimes, when I am not in the car.

I get that sometimes too, I think there are issues with command queuing in the bluetooth stack. Sometimes it won't respond to play/pause or fwd/back commands immediately, and then executes them in a rush about a minute later. I also see this issue occasionally after pressing pause on the device and then disconnecting the BT (or headset) and a little while later the external command triggers and playback starts. (I've removed your duplicate post by the way)

Andre

Share this post


Link to post
Share on other sites

Thanks for the update max. I can wait for months because the current version has no issue whatsoever. I am interested to see how the new Poweramp looks like. Take your time man. Keep up the good work.

 

Cheers.

Share this post


Link to post
Share on other sites
On 9/3/2016 at 7:17 PM, maxmp said:

Basically, the animations, transitions, lists, grids, seekbar, etc. were built from zero, as Android platform just doesn't give what's needed.

Oooo so looking forward to seeing what delights you're bringing us. I can see why it's taking time!

Share this post


Link to post
Share on other sites
On 6/9/2016 at 10:24 AM, sonulohani said:

Thanks for the update max. I can wait for months because the current version has no issue whatsoever. I am interested to see how the new Poweramp looks like. Take your time man. Keep up the good work.

Cheers.

While I wouldn't say no issue whatsoever (I listen to music through my bluetooth) I do agree that it has been rock solid for an Alpha release. Comes to show that proper prioritizing took place when making this build.

Only reason I even remembered it was Alpha was after I started wondering whether it'd work with the newly released Nougat.

Share this post


Link to post
Share on other sites
35 minutes ago, Feilakas said:

While I wouldn't say no issue whatsoever (I listen to music through my bluetooth) I do agree that it has been rock solid for an Alpha release. Comes to show that proper prioritizing took place when making this build.

Only reason I even remembered it was Alpha was after I started wondering whether it'd work with the newly released Nougat.

Agreed! I already applied to betas that weren't as reliable as this alpha.

Only thing that bothers me, are all the issues with Hi-Res Audio, probably exclusive, to the HTC 10. But the amazing sound makes me stay with Hi-Res enabled. As long as I'm just listening to the music, it works. 

Share this post


Link to post
Share on other sites

Awesome max. So thrilled to see how it looks. Any word when we can expect to see the new UI changes? Beta?

Share this post


Link to post
Share on other sites

Hello, I've been having issues with the buttons on the notification bar, it only works once then after the album art animation (after pressing a button) everything disappears, it goes all white except the album art. I have to open the app to just to change tracks.

This is also the case with the official player. I'm guessing it has something to do with the album art animation.

I'm using this player on my LG K10 running on marshmallow... but it works fine with my Xperia z1 on lollipop.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now