Jump to content

Poweramp builds 926-933


maxmp

Recommended Posts

Hello! 

Thanks for adding the shuffle-header setting. Always appreciate a quick response from a dev :)

[Other content is duplicated in Feature Requests --- Admin]

Link to comment
Share on other sites

  • 2 weeks later...
  • Replies 118
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

@djdarko Poweramp uses HARDWARE type of textures on relatively recent devices/Androids (8+). The good thing is that memory pressure from such textures is reduced x2. The bad thing is that image is always handled directly by your device GPU/GPU-drivers, and those may be tuned for lower quality/higher performance and all that may vary between devices/Androids/firmwares/some developer settings, etc.

Still you can try "Increase Resolution" option which will force even higher res images and should resolve your blurry covers issue. Thanks!

Link to comment
Share on other sites

  • maxmp changed the title to Poweramp builds 926-932
  • maxmp changed the title to Poweramp builds 926-933
2 hours ago, Hagman said:

Hello I exported all my settings including all my album artwork while on build 933. Is it possible to import the same backup file while on build 925?

Yes, it is. Probably better to re-import to latest version if you can though - presumably installing on a new device?

Andre

Link to comment
Share on other sites

17 minutes ago, andrewilley said:

Yes, it is. Probably better to re-import to latest version if you can though - presumably installing on a new device?

Andre

Thanks. I just find build 925 more stable on my Samsung device.. In particular, playlist pictures tend to randomly disappear on 933. You know those images you manually apply to playlists.

Should probably have reported this as a bug lol

Edited by Hagman
Link to comment
Share on other sites

I have a question that I don't think is a bug or a new release issues i have an S22 and phone always wakes up instantly after i press the power button when Poweramp is the active application. Is this related to the app or my phone? i've turned off gestures and wake on lift, etc. does anyone have this issue with Poweramp ? 

Thanks, 

Link to comment
Share on other sites

@Andrew Evenstar Your android phone is programed to turn on whenever you press the power button, but if you are saying that the phone screen always stays on whenever Poweramp is playing, then go to Poweramp settings, Look and Feel, Disable Keep Screen On. 

Edited by Bencherished
Link to comment
Share on other sites

On 3/17/2022 at 1:30 AM, andrewilley said:

@Andrew Evenstar Are you saying that when you wake your phone while PA is playing, it goes straight to the PA player interface rather than to a lockscreen first? If so, that's one of the options in PA Settings > Lockscreen. Turn off 'Show on Lockscreen'.

Andre

This was it, thank you! i restored my old settings from my phone and went in and manually turned it on thinking it was something else.

Thanks so much. 

Link to comment
Share on other sites

9 minutes ago, KOB said:

Poweramp start to play when I connect Bluetooth device.

Bluetooth  resumed set to off

What sort of BT device, car radio maybe?

If you have the auto-resume feature turned off in both Poweramp's Settings => Headset/Bluetooth menu, and also in the output device's own setup menus, then probably a command is getting issued from the remote device which PA is obeying. Check PA Settings => Headset/Bluetooth => Last Processed Commands for details.

One other thing to check - do you perhaps also have the Poweramp Equalizer app installed? That has separate resume options in its Settings > Utils menu, which will continue to operate even if you have the actual audio equalization mode currently disabled.

Andre

Link to comment
Share on other sites

Hi good people. Started using this amazing app again. When I click on show Albums, I get a list of Albums but for some Albums where I have few different artists, the album is shown that much time (how much artists there are). I've checked the mp3 files and they all have the same Album, just it keep showing like they are not the same ones. How do I solve this?

Link to comment
Share on other sites

8 minutes ago, LaMpiR said:

Hi good people. Started using this amazing app again. When I click on show Albums, I get a list of Albums but for some Albums where I have few different artists, the album is shown that much time (how much artists there are). I've checked the mp3 files and they all have the same Album, just it keep showing like they are not the same ones. How do I solve this?

Make sure you are using the AlbumArtist tag field and it is the same - for a mixed album like this, it is common to use "Various Artists" or "Various" or "Compilation" as that field. The Artist field for each individual file can still be different. 

Link to comment
Share on other sites

15 minutes ago, LaMpiR said:

When I click on show Albums, I get a list of Albums but for some Albums where I have few different artists, the album is shown that much time (how much artists there are).

In addition to @MotleyG 's response about making sure you use the Album Artist tag to group tracks by different artists into one Album, please also see 'What Constitutes an Album' in: 

 

Andre

Link to comment
Share on other sites

Just noticed: Poweramp can't read nor write tags from .oga files (flac streams inside ogg containers), it also doesn't show the length of the file on the song list, only on the player screen once it starts playing the file. They do play and seek fine though.

Not a big issue since these files aren't very common, just an observation.

Link to comment
Share on other sites

Quote

- new options to change Bass and Treble tone frequency and Q

I understand that "Tone" string must be short in EQ screen, but same string is use in settings and it's not necessary.

I request a new string to translate.

2022-03-27_090052.png

Link to comment
Share on other sites

On 3/23/2022 at 7:41 PM, MotleyG said:

Make sure you are using the AlbumArtist tag field and it is the same - for a mixed album like this, it is common to use "Various Artists" or "Various" or "Compilation" as that field. The Artist field for each individual file can still be different. 

Thank you. This has solved the problem and is showing album properly now.

Link to comment
Share on other sites

On 2/28/2022 at 12:42 AM, andrewilley said:

@Bencherished I think I found what was causing the Pause function to trigger just before the volume setting got down to fully zero. There is a similar control within the Poweramp Equalizer App - which does not get disabled by turning the EQ off - and obviously the two features are clashing.

Go into the Poweramp Equalizer app and in its Settings > Utils you need to turn OFF the third item so it is only activated in the main Poweramp app:

Andre

I hope that the problem will be solved by unchecking these options in EQ but no.

So I uninstalled EQ but still the same.

If PA run in background, plug/unplug my headset start/pause music.
 

12:45:33.577 PlayerService onRoutingChanged
newDevice=headset oldDevice=speaker
==================
12:45:33.581 HeadsetPlugReceiver headset event
connection BT=false am mode=0
==================
12:45:33.588 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
12:45:39.457 HeadsetPlugReceiver headset event
disconnection BT=false am mode=0 no_keep_notif_on_dscn=false
==================
12:45:39.457 HeadsetPlugReceiver cmd_player_pause_playing
==================
12:45:40.023 HeadsetPlugReceiver headset event
disconnection BT=false am mode=0 no_keep_notif_on_dscn=false
==================
12:45:40.045 PlayerService onRoutingChanged
newDevice=speaker oldDevice=headset
==================
12:45:40.045 PlayerService reloadPipeline
 allowPlaying=false forceResume=false state after reload=2

 

Link to comment
Share on other sites

@AlbatorV Assuming you are talking about pause/resume on volume being reduced to zero and raised again, it should be working fine now on the most recent builds of PA.

However it is not possible to resume when raising the volume again if the screen is off. That is a limitation of Android, which does not pass such info to non-playing apps, so PA never gets the volume info for it to restart.

Andre

Link to comment
Share on other sites

2 hours ago, AlbatorV said:

@andrewilley no, i speak about pause/resume when plug/unplug headset or connect/deconnect bluetooth device.

So are you saying it is doing as intended (i.e. play starts when headset is plugged in, and stops when headset removed) but you don't want it to, or that it is not starting when you do want it to? Whichever, the controls are in PA Settings => Headset/Bluetooth.

I have mine set so playback does not start automatically on connection (I prefer to press the Play button manually when I'm ready) but it stops whenever I disconnect the wired headset or BT connection:

 image.png

The PA EQ has similar controls, so make sure they don't clash.

Andre

Link to comment
Share on other sites

  • maxmp unpinned and unfeatured this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...