Jump to content
Poweramp
JSY

Why does Poweramp need to verify license through Google Play when Poweramp Unlocker is installed?

Recommended Posts

I confirm that Poweramp does a license check not only after it is reinstalled, after a system reset (whatever that means), or after a ROM update.

My wife and I are both Poweramp users. I convinced her to purchase the app because I was very satisfied with Poweramp. However, it appears that she was never able to use the app for an entire flight. After some time with the phone in airplane mode, the music player walks out on her saying that the license verification failed. This is not reasonable at all and makes Poweramp look like a scam.

The strange thing is that the failing license checks happen to my wife, but not to me! And our phones are identical: each of us has a stock Galaxy S7. In both phones, Poweramp shows the information "Purchase Verified" and "Store: Play" in Settings->About.

A difference that may or may not be relevant is the app usage pattern. I use Poweramp most of the time. My wife is more like a casual user, who sometimes spends several days without opening Poweramp. But she wants to use it when traveling by plane or by car. And the app in her phone refuses to work in the absence of an internet connection... Yesterday we traveled together, side by side in a plane. I used Poweramp during all flight, but she got a failed license check after half an hour or so.

If the intention is for the license to be "checked once/twice (website/play) and stored forever", then Poweramp has a bug. The problem may not be easy to understand and reproduce, but it exists and shows up in a stock Galaxy S7. If the developer cannot fix the bug, he should at least provide some workaround for the unlucky paying customers that are being bitten by it.

poweramp_about_screen.png

Share this post


Link to post
Share on other sites

After seeing a number of posts from people who are seeing this behavior, I decided to test for it on my phone.  I rebooted my phone and immediately enabled airplane mode.  I then attached some earphones, set Poweramp to shuffle play and set the phone aside.  That was almost 6 hours ago.  It's still playing music with no messages about missing licenses.

For what it's worth, I'm running a Nexus 6P with stock 7.1.2.  Poweramp 2.0.10-build 588-play (Full version)

 

Share this post


Link to post
Share on other sites

Hi all,

I've signed up especially because of this thread. Sorry to say I've had the same problem happening several times, always on a flight, with the phone in airplane mode, most recently twice in a week and a half, on the way out, and on the way back - very frustrating. Running Poweramp 2.0.10-build 588-play, with version 2-build-26 of the unlocker, on a Samsung S5 with Android 6.0.1.

I like Poweramp for the most, and music, with my Bose noise-cancellation headphones, is a life saver on a flight (or train ride, actually), but I'm actually getting to the point of looking for an alternative. Having to realise that it's not working - again - due to not being able to check the licence, and having to switch to the stock player - again - is not what I got this for. I realise it wasn't much money, but still...

Cheers,

Olaf

Share this post


Link to post
Share on other sites
On 8/30/2017 at 7:24 PM, utahman1971 said:

That is not true at all. Just the last few weeks it has been nagging and nagging over and over again. The app says verified after connecting to internet then few days later a nag again.

Most likely your device is not saving the status correctly, Max did mention that some devices/ROMs seem to lose the registered status during a reboot and they need to re-validate.

Andre

Share this post


Link to post
Share on other sites

I am very disappointed.  I purchased Poweramp for my dedicated Android music player, which is normally not connected to the internet, and has no associated cell plan. Having to constantly find a way to connect it, and often being out of range of any signal, means it's just a useless product for me.  This app directly promotes the idea of having "a dedicated music player", which goes against the need for constant connectivity.

The excuse that the "device is not saving the status correctly" is unacceptable, when so many people are experiencing the issue.  This is the type of situation wherein programmers like us are expected to create workarounds.  At least the unlocker purchase screen should have a disclaimer: "Depending on your device, this app may not function without a persistent internet connection."

 

Share this post


Link to post
Share on other sites

2017 and it's still happening to me regularly. I'm on a Galaxy S7 edge. Stock, never fiddled with anything in it. Especially annoying since I bought the app specifically so I could listen to music when I'm NOT online. On long drives, flights etc. I'm in a country with poor wifi infrastructure and I only use data rarely, which means I only connect through my home wifi exactly when I DON'T need Poweramp to listen to music.

So... why?!

It stops playing around an hour or two after losing connection. Then insists I don't have a license. I've been forced to install other (free) music players as backups because I never know when Poweramp decides to eff my day up. Sure it starts up fine once I get home and connect or find a connection, but the main point why I bought the app is so I could USE IT WHEN I'M OFFLINE. Jeez.

Is there seriously still no action taken on this issue? That page where it says "no internet connection is needed" is pretty much a lie at this point. It doesn't help at all when the solution to fix the issue is to "find a connection." How exactly does that translate to "no internet" when you need internet to fix an issue that happens ONLY when there's no internet? An issue that renders the app just a pretty wallpaper.

Share this post


Link to post
Share on other sites

I wish I could help you, as a small number of people do appear to still have this issue (although it's far from widespread). At the moment I know Max is still buried deep in coding the long-overdue v3 user interface. He has said previously that sometimes this issue is caused by devices not saving their licence data correctly, but while that could be understandable on esoteric devices I can't understand it still happening on unmodified brand-leading mass-market models like an S7 edge (and event then only for a tiny number of users).

You could report the problem again to Max via poweramp.maxmpz@gmail.com , maybe he can look into it again for v3?

Andre

Share this post


Link to post
Share on other sites

Thanks for caring Andre.  I'm pretty sure the developer just isn't going to be able to reproduce this problem if it's so rare.  He'd have to get his hands on the various devices on which it's appearing, and I can't spare my main S3 media player.  I just hope he considers a different licensing method in the future, based on this current unreliable one.  At this point I'm just going to give up on Poweramp, as it's not worth the headaches.

Share this post


Link to post
Share on other sites

I have this problem constantly. I have several devices that are properly licensed, I use it for months at a time, then not for a while. I have a couple of old Galaxy players that run android 2 versions. Right now I have two devices that won't play, even though I've used it for years, all of a sudden it trys to validate again? The unlocker is fully installed, what more does it need? My experience has been much the same as others, when flying, in the middle of a flight in airplane mode, boom, no more music. I have a Samsung galaxy player 5.0 that I have used all summer at least once a week, used as recently as yesterday, today will not validate no matter what. There is something amiss that is causing many people grief, and needs fixing pronto! None of my players will function now, just my phone, but it had limited memory. Not a happy customer!! 

Share this post


Link to post
Share on other sites

Report it as an issue with your phone/account via the Get Support facility in the app, or email poweramp.maxmpz@gmail.com. Make sure you state clearly that you have read the FAQ on the subject (http://support.powerampapp.com/knowledgebase/articles/323557-is-internet-connection-required) and that you are sure none of those conditions apply to you.

Andre

Share this post


Link to post
Share on other sites

Well usually when the Internet Connection is required, there is something else that is usually not noted is that it may not just be that, from what I Understand, it might something to do with Google Play, because if it is to have a Connection to Verify and it has that, then does the whole Verification need "Google Play Running" in order to verify, that is the thing, as I understand Google Play is usually the one that has data that must send and receive with the App RUNNING, it Can't be Terminated or Disable otherwise it can't Verified, Google Play Service does not do that, only Google Play's APP is usually what Runs the Verification from what I know.

Share this post


Link to post
Share on other sites

I just had this happen to me for the first time. I've been using this app professionally for over 5 years on a Motorola Xoom tablet with Android 4.1.2 and PA 2.0.10 build 588. My tablet stays in airplane mode 99% of the time, except when I need to upload songs, and I have't had to do that or be online with it in 6 months. I completely power the tablet down after each use and it's been powered down 200 times or more without issue.  It's been rock solid, which is what I need.  Again this is the first time I've ever seen this pop up error.

Can I move forward thinking this was an anomaly and that it's very to happen again? I guess that's what we all would like to know.  

Is there anyone here who has had this happen just once? Is my situation unique?

Has anyone been using PA for years before this happened, like me?  Once it starts, does it keep happening??

Thank you, all.

Share this post


Link to post
Share on other sites

Even though this is an old thread, this stupid problem remains.  I tried reporting it through the android app at least a year ago with no response.  Now I will post on this forum, and also expect no help.

I have a Samsung Galaxy S7 Edge.  All of my music is stored on a micro SDXC card.  I purchased Poweramp a long time ago.  EVERY TIME I try to use Poweramp while flying it will work for perhaps half an album.  Then it stops and I get the unable to verify purchase through Google Play message.  At this point I can no longer use Poweramp until I have landed and get to a place with a strong wifi signal.  This "bug" is real.  It should be fixed.  I like Poweramp, but my most important use for the program is when I don't have an internet connection.  Please somebody with Poweramp, fix this long standing issue!

Share this post


Link to post
Share on other sites

@XrayDoc88, Since my last post, I have had three new phones, a Pixel XL (with same mid-air activation verification bug), with a OnePlus 5T with same problem and about a month ago I got a Samsung S9+ and surprisingly I have not had the issue... Since then I flew to Brazil, Peru and Chile and I did not have that mid-air verification issue. Same google account on phone, etc... I do not appear to have done anything different on my side, but the issue seems to be gone. I still keep 2 other players (Player Pro and Black player) just to be on the safe side.

Share this post


Link to post
Share on other sites

The problem does seem to be related to specific devices or accounts, for some reason the licence validation does not 'stick' like it should. Please contact poweramp.maxmpz@gmail.com with your account details to discuss this. (I'm assuming you have already read http://support.powerampapp.com/knowledgebase/articles/323557-is-internet-connection-required )

Andre

Share this post


Link to post
Share on other sites

I often face Can't verify Poweramp License issue and it is frustrating. Before I had samsung phone now I have Huawei phone but issue is same.

Screenshot_20180426-092010.png

Share this post


Link to post
Share on other sites

I had two galaxy players that used PA successfully for years, then all of a sudden it would not register no matter what I did. Complete uninstall, system reset, all sorts of things, no luck. I ended up recycling them. There is a serious flaw in the registration process. I even tried a beta build. 

Share this post


Link to post
Share on other sites

As I've said before, individual user account / registration issues need to be raised by email to poweramp.maxmpz@gmail.com if the FAQ does not help. They can't be resolved in public forums.

Andre

Share this post


Link to post
Share on other sites

Just so everyone knows, emailing the developer contact address just gets you an auto-response that provides a subset of the step-by-step information that's already at http://support.powerampapp.com/knowledgebase/articles/323551-google-play-response-error-contacting-server.  I emailed five days ago, and I never receive a follow-up personalized response.

It's still probably a good idea to email your information there, in case the volume of emails eventually gets the developer to change their approach to license validation.  I have plenty of apps that require unlocking, and can use them offline for long periods of time.

I've just updated my S3 media player from CyanogenMod 11 to LineageOS 14.1, so I'm hoping the problem goes away. I'll always be nervous, as the stories here indicate that the failure might always randomly return.

Share this post


Link to post
Share on other sites

If you just get an auto-response, email again until you get a personal reply. I would suggest saying in your first email that you have already read the FAQs, and asked in the forums, but nothing so far has helped.

Andre

Share this post


Link to post
Share on other sites

Welp. Interestingly this is just about the ONLY issue I've ever had with Poweramp. That counts for something.

On the other hand, to have me appear here to say it means the issue raised its head again (Had it on Ace 3, J5 and J5 2017). It's not all that frequent... but as painful as ever to sort out. So yeah, it works again, but... it's a repetitive issue.

Just adding myself to this thread. No point in starting another one, right?

Share this post


Link to post
Share on other sites

Poweramp just have huge "grace period" i.e. time it continues to work despite license check failed by Play. Other apps will fail immediately, but Poweramp allows app usage even if license can't be checked at the moment.

Exept for this and permanent license storage there is no difference vs standard Play license checking, and this can be only changed in the way of tightening/reducing the grace period. (By default Play asks to recheck license every few days.)

All the cases with "license failed in airplane mode" that was investigated shown that given customers had no valid license at all (refunded, cancelled by google, or card declined, etc.) Poweramp still continues to work in this case, but fails to do the second check (within 24 hours from purchase), and license checking is continued until grace period ends (can be weeks for infrequent player usage). No connection means checking can't happen and error is shown earlier.

This approach works well for users with the valid license, but unfortunatelly, is less friendly to users without valid license, and I'll try to change that by reducing the grace timeouts and showing the error earlier in next Poweramp releases. 

Share this post


Link to post
Share on other sites

@maxmp Quite a lot of users report that they see an issue of PA working normally for a long time but suddenly not working on flights/etc (a number in this thread even, for example http://forum.powerampapp.com/topic/9335-why-does-poweramp-need-to-verify-license-through-google-play-when-poweramp-unlocker-is-installed/?do=findComment&comment=47594 ).

In the FAQ, you state that once a licence has been validated it is never checked again - apart from if the app is reinstalled, the ROM is updated, or the system is reset (by which the assumption is that you mean a full factory reset, not just a regular power-cycle reboot such as would be done routinely during take-off of a flight for example). That's what I've been telling users anyway, but it doesn't always seem to be the way it works out there in the real world. There would appear to be too many reports of this happening inexplicably for everyone to be wrong. Could you perhaps clarify what you mean by never checked again?

Andre

Share this post


Link to post
Share on other sites
12 hours ago, maxmp said:

Poweramp just have huge "grace period" i.e. time it continues to work despite license check failed by Play. Other apps will fail immediately, but Poweramp allows app usage even if license can't be checked at the moment.

Exept for this and permanent license storage there is no difference vs standard Play license checking, and this can be only changed in the way of tightening/reducing the grace period. (By default Play asks to recheck license every few days.)

All the cases with "license failed in airplane mode" that was investigated shown that given customers had no valid license at all (refunded, cancelled by google, or card declined, etc.) Poweramp still continues to work in this case, but fails to do the second check (within 24 hours from purchase), and license checking is continued until grace period ends (can be weeks for infrequent player usage). No connection means checking can't happen and error is shown earlier.

This approach works well for users with the valid license, but unfortunatelly, is less friendly to users without valid license, and I'll try to change that by reducing the grace timeouts and showing the error earlier in next Poweramp releases. 

Excuse me, but not all of the cases with "license failed in airplane mode" happen because of invalid licenses!  I paid for a license and have this problem every time I fly.  Why not just accept or believe that your program has an issue and try to fix it, instead of blaming the customers that have purchased your product?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×