Jump to content

File Access Component is missing


Go to solution Solved by maxmp,

Recommended Posts

Build: Poweramp build-933-bundle-play full verified cached
Store: Play
Unlocker: build-303
Arch: 64
Skin: ActivityTheme_Black
Device: asus ASUS_I01WD msmnile ASUS_I01WD EU_I01WD [arm64-v8a, armeabi-v7a, armeabi]
Installer: com.android.vending (30.2.18-21 [0] [PR] 442071458)
Android: 11 asus/EU_I01WD/ASUS_I01WD:11/RKQ1.200710.002/18.0610.2106.156-0:user/release-keys en_US

 

After the last update to version 933, Poweramp cannot access files on my android 11 phone correctly

I cannot enable the permission (see screenshot attached).
I tried enabling/disabling the Legacy File Access Mode, I went through every forum post, nothing helps.
I cannot select folders, cannot edit tags on my songs, cannot delete songs, half of the album art are not showing anymore.
I did not upgrade android, I did not disabled any android component, I did not freeze or uninstalled any app. I just upgraded Poweramp to the latest version 933 and something has changed with the file access method in this version.
I tried to install 50 different versions of 'Google Files'/DocumentsUI/alternatives as suggested on the forum, non of them restores the file access correctly (see screenshot of what is built-in in my phone).
I tried my old phone with Android 8 and Poweramp 933, no problems there. It uses the Legacy File Access method anyway and has built in Files app, so it was expected. No luck with my Android 11 phone.

I got older apk versions (925,921) from the site, but I cannot install them over 933. I need to uninstall the latest version first.
The problem is- I cannot export the app settings anymore (see screenshot attached).
I need to take screenshots of every screen, equalizer and setting, It will take days of work to restore everything on 925 manually.

Please Help.

Screenshot_20220427-104058304.jpg

 

Screenshot_20220427-120506625.jpg

Screenshot_20220427-120201539.jpg

Link to comment
Share on other sites

  • Alex Ne changed the title to File Access Component / Permissions Problem in the latest 933 build
  • Solution

Please check here for details: 

I would add that Asus stock roms, obviously, have no such issue by default as any Android compatible firmware should support system file picker. Some custom ROMs may have this "optimized' out, also some package disablers and "optimizers" or manual adb commands may disable/remove that package, but this always require user intervention.

Disabling this package is like removing "Open File" system dialog from Windows.

If nothing helps, you can always use Legacy File Access option. Though more and more updated apps will fail to work for you as they depend on system file picker now and Google requires new and updated apps to use the system file picker.

Link to comment
Share on other sites

But this problem started since Poweramp auto updated to the latest 933 version. Every version of Poweramp worked fine in the last 2 years on this phone, until the last one.

I'm using the stock rom, never touched it. I did not do any changes to my phone since the problem started, No system updates, No uninstall/freeze of any app (system or not).

The problem started last week when Poweramp and a few other (non system apps) auto updated through the play store when I connected to wifi.

I'm sure if rollback to version 925 (by uninstalling 933 and installing fresh 925 version, and manually configure all the settings, which will take days/weeks), the problem will go away.

I prefer not to do that. Please tell me what version of Google Files can I install so it will solve the new 'missing file picker' problem that exists only in version 933. I already tried more than 50 different options with no luck getting working 'file picker' that version 933 will accept without different bug messages.

Thank you.

Link to comment
Share on other sites

Tried it, Interesting app.

No problem there.

I see all my song on the phone in the "Library", and I can browse "Local Folders" with any file explorer installed on the phone (It let me choose one every time I enter "Local Folders").

I did not do any changes to my phon's rom, it's not rooted and I did not do any system update in the last months (I think my phone getting old for that). The permissions/file picker problem started only after the latest apps auto update and the problem is only in the latest version of Poweramp. I noticed it immediately because I did a lot of tag editing and song delete on the go, which I cannot do now. I can browse my internal folders with the legacy mode (choosing music folders for the library), but half of the app functionality is broken now and it unusable for me anymore. I think I will have to install manually the latest version before 933 (925?) and never update it again on my android 11 phone, because I spent days trying to solve the problem from my end without any luck.

 

Link to comment
Share on other sites

@Alex Ne previous Poweramp builds could work by default in Legacy File Access mode on your device, esp. if you upgraded from older Androids while Poweramp was installed. You still can re-enable this option to allow same behavior. Nevertheless, your OS is modified and is not compatible with Android OS in this regard ("Windows with Open file dialog removed"). The "new" file access functionality (it exists from Android 4.x) via this picker is required by Google for the app updates on Play. Fortunately, File Legacy Access still works, as Google constantly changes the deadline date for it, and it will continue to work on Android 10/11/12.

Apps targeted for older Androids still continue to work in "Legacy File Access" mode. Poweramp targets new Androids as it's regularly updated on Play and must follow all Google requirements.

Google has roadmap to further remove features (e.g. direct file access, record calling, and other features - there are many) and unfortunately it's not always possible to workaround these issues (esp. if you have the features/APIs disabled by package disabler) for Play distributed apps due to the strict requirements, but workaround for direct file access still exists.

Link to comment
Share on other sites

  • maxmp changed the title to File Access Component is missing

Rolling back to a previous PA build might not help, as Android could still treat it as a 'new installed' app rather than something that was installed a long time ago on an older version of Android and which is thus still permitted to use pre-existing access features. However enabling PA's File Access Legacy Mode (and then possibly re-selecting your Music Folders locations if needed) ought to still work until Google finally decides to enforce its new rules with a future Android release - which won't happen to you if you stick with Android 11 of course.

What SDK target level is PA 933 using compared to @flyingdutchman's app?

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...