Jump to content

"Poweramp is being used by another device" Android Auto display issue


Recommended Posts

Dashboard message


Hi all 

I get Poweramp is being used by another device when it's being played in my Kia which runs on Android auto.

Poweramp is only installed on my phone so I'm not sure if I should be concerned 

Is it something that I need to worry about as it's playing perfectly.


Attached pic of dashboard message above



Link to comment
Share on other sites

4 minutes ago, andrewilley said:

Are you using the standard release of Android Auto, or the beta channel?


Android Auto was pre installed in the car Andre and I've not joined any beta programs for it 

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...
  • 6 months later...

I have had the same issue since last month after AA released the coolwalk to me. 

Full version Poweramp ver. 945004-2d535bbf, from Google Play. 

AA beta user, with AA version 8.7.130204-release.daily

Using S22Ultra Android 13 with Genesis GV80


Link to comment
Share on other sites

  • 4 weeks later...

Still seeing this display error message, even with the most recent public Android Auto release and the new Coolwalk interface enabled. PA build 953.


It's quite annoying not being able to see the duration and elapsed time information that is meant to be shown on that line.

Any progress on this @maxmp , can you replicate it on your test devices?


Link to comment
Share on other sites

  • andrewilley changed the title to "Poweramp is being used by another device" Android Auto display issue

It's been there for about a year, on various releases of AA both pre- and post-Coolwalk. I'm currently running 8.7.630264-release, which is a relatively recent update but still has the same problem as has been reported by the other users in this thread.

My head-unit is a Hyundai factory fitted, with a USB connection to Galaxy A70 Android 11, and the problem was not present when I first starting using it so something has changed in the meantime. I'm going to check to see if there's an update for the firmware on the head-unit.

Of course the tricky bit may be working out which bit of the chain is causing it. Can I provide any diagnostic info?


Link to comment
Share on other sites

Bug Report sent, in the same Dropbox share that I put the MKA and MPG files into yesterday.

  • I plugged the phone into the car USB port and waited for AA to start.
  • Tapped to go to the music player screen and started playback, then paused it again.
  • The same error message is always visible whenever the full-screen music interface is shown on the car screen (whether playing or paused).
  • Generated log at that point.


Link to comment
Share on other sites

@andrewilley I can immediately say that this is probably caused by Volume Levels option. For some reason listening for volume events makes Android think app is used on another device. Something related to Spotify lawsuit, Google volume key fiasco and their patches around that. I will try to find some solution.

Thanks for the log.

Btw on Samsungs, the Samsung Sound Assistant volume step works in Poweramp automatically without use of Volume Levels and it allows up to 150 volume levels everywhere in the system.

Link to comment
Share on other sites

@maxmp I just checked, and yes that is indeed the cause. I turned the 'Volume Levels' option in PA back to System Default and the AA error message went away. So at least you have something to test with now.

[Edit] I also just tried with the Samsung Sound Assistant option instead (where a slider value of 2 gives around 75 steps, which is what I was using before) and that works fine with no error message in Android Auto.

@CX4ever @AntS @Robert56 Could you try turning PA Settings=>Audio=>Advanced Tweaks=>Volume Levels back to 'System Default' for now?


Link to comment
Share on other sites

Been having this problem for a while too, and turning off volume levels has fixed it.

As a bonus, it's fixed another couple of (presumably related) problems too (which were actually more annoying).

Skip track button on the steering wheel wasn't working; is now.

Album art wasn't showing on AA's tiled display; is now.


Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...