• Announcements

    • andrewilley

      Poweramp v3 Project Update   04/24/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code. It is hoped this will be ready for final beta-testing by the end of the May. See forum thread for more details and to discuss.    
maxmp

Requests for Hi-Res Support

465 posts in this topic

1. ZTE Axon 7

2. Android 7.0 (A2017UV1.1.0B15)

3. AKM AK4961 and AKM AK4490EN

The axon worked with Android 6.0/6.1 but the new 7.0 seems to have broken it. I'm sure you know why, just wanted to let you know. Hope it's an easy fix as I love Poweramp and when I went to use it after the update I could immediately notice the difference. 

 

Share this post


Link to post
Share on other sites

I second that about the axon 7.  I downloaded the nougat update and now it keeps saying hi res output failed everytime I use it.  The same thing happened to me and this was the whole reason I choose Poweramp in the first place please fix if possible. 

Share this post


Link to post
Share on other sites
1 hour ago, vikvicious said:

I second that about the axon 7.  I downloaded the nougat update and now it keeps saying hi res output failed everytime I use it.  The same thing happened to me and this was the whole reason I choose Poweramp in the first place please fix if possible. 

I'm sure these sort of issues will be fixed by the time PA v3 is officially released. However don't necessarily expect the next beta release to tackle these immediately as it will be for testing the new user interface.

Also, please ensure that you are using build 704 of the alpha-test in the meantime (which had some Nougat modifications) as some people still seem to be using 703.

Andre

Share this post


Link to post
Share on other sites
16 hours ago, andrewilley said:

I'm sure these sort of issues will be fixed by the time PA v3 is officially released. However don't necessarily expect the next beta release to tackle these immediately as it will be for testing the new user interface.

Also, please ensure that you are using build 704 of the alpha-test in the meantime (which had some Nougat modifications) as some people still seem to be using 703.

Andre

Yeah I figured it's probably an easy fix that just had to be addressed when there's time. I was using 704 and it doesn't work. Just says high res output failed. 

Thanks for the quick response by the way. Appreciate it. 

Share this post


Link to post
Share on other sites

1. Motorola Droid Turbo 2

2. Android 6.0.1

2. SOC: Snapdragon 810

States Failed: Poweramp High-Res Exp Output

Share this post


Link to post
Share on other sites
On Wednesday, February 08, 2017 at 0:28 AM, Vie Lovins said:

 

Hi-Res Output on wired headset issue with Android 6.0.1 

Samsung Galaxy Note 4 SM-N910H 

Exynos 7 Octa/ 5433, Wolfson DAC, Android 6.0.1 Official. 

Hi-Res Output on wired headset not yet work in Alpha Build 703. I try to install Alpha build 704 and no solve my problem. If I activate Hi-Res Output no music can I hear, just knocking sound continuously. Hi-Res Output on wired headset work if DVC are off, but volume too low and SQ is bad. 

Andre has given me a explanation about Hi-Res on Android 6.0.1 Galaxy Note 4 SM-N910H. Now, I will waiting new Beta Version and hope can fix my problem. Thank you. 

 

Share this post


Link to post
Share on other sites

Oneplus 3

Stock rom Oxygen os 4.0.3 Android nougat 7.0

Because the option to turn on the hi res output is available when the os still in marshmallow (and it works) 

 

 

 

audio_policy.conf

Edited by SatriaPerdana

Share this post


Link to post
Share on other sites
On 09/02/2017 at 1:59 AM, vikvicious said:

I second that about the axon 7.  I downloaded the nougat update and now it keeps saying hi res output failed everytime I use it.  The same thing happened to me and this was the whole reason I choose Poweramp in the first place please fix if possible. 

The 24 bit output you were using before with Poweramp was actually not the A7's AKM AK4490EN DAC, it was the SD 820's built-in sound processing. I guarantee if you use the garbage stock music app and listen to some lossless files with high end headphones you'll notice there is an obvious quality difference, and that's with the stock music app (or the firmware?) actually truncating any 24 bit files to 16 bit.

Basically I'm saying if you really wanted to use the A7 for hi-fi sound, you're stuck using the buggy trash tier stock music app unless there's another music player which works with it now. Last I checked there was nothing but false reports and they were just using the SD 820's sound processing. The stock music player drives me insane, I'm extremely disappointed it's taking this long for Poweramp to be updated.

Share this post


Link to post
Share on other sites
On 1/26/2017 at 1:41 PM, andrewilley said:

I just had a message back from Max re: 7.0 Android compatibility issues with the current 704 alpha build:

Andre

Yeah, Hi-Res output doesn't seem to work on my Sony Xperia XZ with Android 7.0 and build 704. Is there anything I can do?

Share this post


Link to post
Share on other sites
11 hours ago, Neo Cyrus said:

The 24 bit output you were using before with Poweramp was actually not the A7's AKM AK4490EN DAC, it was the SD 820's built-in sound processing. I guarantee if you use the garbage stock music app and listen to some lossless files with high end headphones you'll notice there is an obvious quality difference, and that's with the stock music app (or the firmware?) actually truncating any 24 bit files to 16 bit.

Basically I'm saying if you really wanted to use the A7 for hi-fi sound, you're stuck using the buggy trash tier stock music app unless there's another music player which works with it now. Last I checked there was nothing but false reports and they were just using the SD 820's sound processing. The stock music player drives me insane, I'm extremely disappointed it's taking this long for Poweramp to be updated.

Actually, I was under the impression that there is no snapdragon dac active on board in axon 7. Axon 7 min has the same behavior where the stock player sounds much better. It only has the ak4962dac built into it(still Poweramp says it has snapdragon 24bit varian). My guess is that it has either to do with how the dac is being used by Poweramp or tit has something to do with the decoder Poweramp uses

Share this post


Link to post
Share on other sites

In an other post I said it was working with Onkyo DP-X1A but in fact it does not I tried to apply this trick

http://forum.powerampapp.com/index.php?/topic/8735-requests-for-hi-res-support/&page=6#comment-34753

it is not working  Probably because of a software update here some links witch can be useful to help to implement Power-amp V3 on Onkyo the first one from Pergasus21

http://www.head-fi.org/t/780642/onkyo-dp-x1-dual-sabre-dacs-balanced-sabre-btl-amp-mqa-dsd-256-android-5/3480#post_12254387

and this one from ironFly showing the issue showing in a logcat

http://www.head-fi.org/t/780642/onkyo-dp-x1-dual-sabre-dacs-balanced-sabre-btl-amp-mqa-dsd-256-android-5/13815#post_13264879

 

Please fix it for the Onkyo DP-X1A Hi res player

 

 

 

 

Share this post


Link to post
Share on other sites

Lenovo ZUK Z2

Snapdragon 820 24bit 192kHz PCM

Stock and custom Android 7.1 has a problem " Failed: Poweramp Hi-Res Exp Output , Using default output "  :(:(:(

On android 6.0.1 everything is working well.

Share this post


Link to post
Share on other sites
22 minutes ago, EndziuS said:

Please fix it.

Please remember you are testing an ALPHA-test product, not even beta-test yet. Your information will help with further development, but in the meantime if it is not working for you on your particular ROM please report the issue and revert to the release build.

Andre

Share this post


Link to post
Share on other sites
On 13/02/2017 at 0:03 PM, lantian said:

Actually, I was under the impression that there is no snapdragon dac active on board in axon 7. Axon 7 min has the same behavior where the stock player sounds much better. It only has the ak4962dac built into it(still Poweramp says it has snapdragon 24bit varian). My guess is that it has either to do with how the dac is being used by Poweramp or tit has something to do with the decoder Poweramp uses

That's false because they can't pick and choose the components of an SoC. It stands for System on a Chip for a reason, that's exactly what it is, the 24 bit DAC on that thing isn't magically removed. Whether or not it's active is one thing, but it's 100% there, and Poweramp sounds so different from the stock player that it wouldn't be surprising if it really is using that 24 bit DAC.

Share this post


Link to post
Share on other sites

HTC 10.
Snapdragon 820 24bit 192kHz with Snapdragon Aqstic codec.
Android 7.0 with HTC Sense 8.0. FW version 2.41.401.3.

(Going through the kernel sources available at http://www.htcdev.com/devcenter/downloads I found it uses the WM8775 or some variant of it. But that contradicts Qualcomm's claims. This device seems tricky on the audio part).

Using alpha-703 with DVC disabled results in 48Khz playback, but it uses the dedicated audio codec.
With DVC enabled it falls back to the on SoC WCD9330/5 with WSA881x.

I'll dig into the sources and see if I can find any configuration that indicates the correct output chip.

Hopefully this gets implemented until beta.

 

 

Share this post


Link to post
Share on other sites
17 hours ago, Albert said:

HTC 10.
Snapdragon 820 24bit 192kHz with Snapdragon Aqstic codec.

Android 7.0 with HTC Sense 8.0. FW version 2.41.401.3.

 

 

I dug through the kernel configuration sources and apparently the Qcom SD Aqstic is WCD9335 compatible.

Here's the audio_policy.conf.
"compress_offload" should be the transport for this phone.

audio_policy.conf

Share this post


Link to post
Share on other sites

Xiaomi Mi Max

Android 7

Snapdragon 650

Build 701; 702; 703; 704  In android 7 not working hi-res support, in android 6 working great. 

Share this post


Link to post
Share on other sites
On 19/02/2017 at 2:45 PM, Dilbersha said:

1.Motorola moto x 2nd generation (indian version)

2. Android 6.0 (stock)

3. Check file attached

 

Help me asap

audio_policy.conf

Anyone please help

Share this post


Link to post
Share on other sites
4 hours ago, Dilbersha said:

Anyone please help

With what? You are testing an alpha-test release of a forthcoming app, it is not supported as yet as it is still in development. If you are free to revert to the regular build until v3 is officially released if you prefer.

Andre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now