Jump to content
maxmp

Requests for Hi-Res Support (please state which build of Poweramp you are using)

Recommended Posts

1. Lenovo Z5 Pro GT

2. Android Pie

3. https://www.devicespecifications.com/en/model/15374e88

5.

00:56:05.918 v3-build-860-arm64-play
Device: Lenovo Lenovo Lenovo L78032 heart msmnile [arm64-v8a, armeabi-v7a, armeabi]

FAILED to read=/vendor/etc/audio_output_policy.conf
reading=/vendor/etc/audio_io_policy.conf
has direct_pcm_24, sampling_rates=44100|48000|88200|96000|176400|192000|352800|384000
AUDIO_OUTPUT_FLAG_DIRECT direct_pcm_24
has direct_pcm_24 formats=AUDIO_FORMAT_PCM_24_BIT_PACKED|AUDIO_FORMAT_PCM_8_24_BIT|AUDIO_FORMAT_PCM_32_BIT
FLAG_VARIANT_DIRECT_HD via direct_pcm_24
forcing FLAG_DLFCN FLAG_NEEDS_DEEP_BUFFER FLAG_NEEDS_EXTRA_SLEEPS
USB can handle Hi-Res - sdk=28
OK flags=0x874616600000000
FLAG_VARIANT_DIRECT_HD
FLAG_SUPPORTS_PCM_8_24
FLAG_SUPPORTS_PCM_24
FLAG_SUPPORTS_PCM_32
FLAG_SUPPORTS_UNITY_GAIN_STREAM
FLAG_SUPPORTS_USB
FLAG_NEEDS_EXTRA_SLEEPS
FLAG_SUPPORTS_LDAC
FLAG_DLFCN
FLAG_NEEDS_DEEP_BUFFER
FLAG_ALLOW_DVC_EFFECT
FLAG_BT_DVC_EFFECT
INTERNAL_OUTPUT_FLAG_SR_384K
INTERNAL_OUTPUT_FLAG_SR_352K
INTERNAL_OUTPUT_FLAG_SR_192K
INTERNAL_OUTPUT_FLAG_SR_176K
INTERNAL_OUTPUT_FLAG_SR_96K
INTERNAL_OUTPUT_FLAG_SR_88K
INTERNAL_OUTPUT_FLAG_SR_48K
INTERNAL_OUTPUT_FLAG_SR_44K
 

Share this post


Link to post
Share on other sites

Can you add this one?

1. Realme C3

2. Realme UI 1.0 [RMX2020_11_A.02] | Android 10

3. Mediatek Helio G70

4. Build 856-860

03:21:20.347 v3-build-860-arm64-play
Device: realme realme RMX2020 RMX2020 oppo6769 [arm64-v8a, armeabi-v7a, armeabi]
	FAILED to read=/vendor/etc/audio_output_policy.conf
FAILED to read=/vendor/etc/audio_io_policy.conf
FAILED to read=/system/etc/audio_policy.conf
reading=/vendor/etc/audio_policy.conf
has outputs_primary, sampling_rates=44100|48000|96000|192000
has outputs/primary formats=AUDIO_FORMAT_PCM_32_BIT|AUDIO_FORMAT_PCM_16_BIT
has usb
has usb outputs
has usb_device, sampling_rates=dynamic
has usb formats=dynamic
USB can handle Hi-Res - sdk=29
OK flags=0x304001c00000000
FLAG_VARIANT_MTK_HD
FLAG_FORCE_PCM_8_24
FLAG_SUPPORTS_USB
FLAG_SUPPORTS_FLT_DYN_RANGE
FLAG_SUPPORTS_LDAC
INTERNAL_OUTPUT_FLAG_SR_192K
INTERNAL_OUTPUT_FLAG_SR_96K
INTERNAL_OUTPUT_FLAG_SR_48K
INTERNAL_OUTPUT_FLAG_SR_44K

audio_policy.conf

Share this post


Link to post
Share on other sites

1. Onkyo DP X1 via USB to Chord Mojo DAC/Head-Amp

2. Android 5.1.1 (latest version for the Onkyo)

3. The Onkyo ist a High-res player

4. Poweramp version v3-build-860-am32-play

 

I do have no issues with the Onkyo music player app. It works!

Share this post


Link to post
Share on other sites
Posted (edited)
  1. Device model : POCO X2
  2. ROM version : Android 10, MIUI 11
  3. Why do you think your device supports Hi-Res (link to device features, etc.)? Audio IO Policy attached. Also SD 730G Qualcomm page talks about PCM 32bit/384k.
  4. For recent Poweramp builds, screenshot of Settings / Audio / Advanced Tweaks / Audio Outputs Detection Logs : attached.

I must add 24 bit works but there's no 32 bit option, also the volume when I enable 24 bit audio is lesser than 16bit and upon enabling DVC it decreases even more.

Screenshot_2020-03-19-23-24-49-929_com.maxmpz.audioplayer.jpg

audio_io_policy.conf

Edited by Noobie

Share this post


Link to post
Share on other sites
Posted (edited)
3 minutes ago, maxmp said:

@Aeolus from the screenshot it seems to be supported out of box.

Yes but when I have Hi-Res Output activated I get absolutely no audio from Poweramp. I made a post in the bug thread and @andrewilley suggested I make a post here

Edited by Aeolus

Share this post


Link to post
Share on other sites
Posted (edited)

@maxmp nothing works. As long as I have Hi-Res Output activated in Poweramp I get no audio from Poweramp on my LG V60.

Edited by Aeolus

Share this post


Link to post
Share on other sites
8 hours ago, Aeolus said:

@maxmp nothing works. As long as I have Hi-Res Output activated in Poweramp I get no audio from Poweramp on my LG V60.

Just a thought, but you don't have any of the device's own audio enhancement features enabled do you?

Andre

Share this post


Link to post
Share on other sites

1. Xiaomi poco F1 

2. Pixel 4XL rom . Android 10

3. Snapdragon 845 

I installed the app today and was able to get 24bit/192hz output of which I'll post pic . But I got a notification and the audio broke. And now im not getting any audio when I select hi res output. When i select hi res output, the song is playing but no audio is coming out. I tried every way. Re install it. Reset defaults,focus audio change. Everything but it's not working. Only 16bit audio is working. Please help me out. I'm hoping for a quick reply. Thanks for your efforts

4. Link to build.prop Audiopolicy.conf audio_output_policy.conf files :

https://drive.google.com/folderview?id=1-2lAreiJrmbEbgsBHizdrmaG24H1lVxM

Share this post


Link to post
Share on other sites
On 4/6/2020 at 1:28 AM, andrewilley said:

Just a thought, but you don't have any of the device's own audio enhancement features enabled do you?

Andre

Yes I do and I have tried turning it off. Nothing works.

Share this post


Link to post
Share on other sites
On 4/14/2020 at 2:38 PM, Aeolus said:

Yes I do and I have tried turning it off. Nothing works.

I get the same thing on my V60 as well, nothing works when switching to Hi-Res.

Share this post


Link to post
Share on other sites
7 hours ago, traviswhayne said:

I get the same thing on my V60 as well, nothing works when switching to Hi-Res.

Same issue as above users on LG V60. 

Share this post


Link to post
Share on other sites

Screenshot_20200501_193015.thumb.jpg.04e3ce764a6a028ee5eac49f9a41e7af.jpgScreenshot_20200501_193015.thumb.jpg.04e3ce764a6a028ee5eac49f9a41e7af.jpg1. vivo IQOO Neo3

2. Android 10 IQOO UI PD1981C_A_1.7.4

3.it has Independent HiFi chip.But I don't know the model of the hifi chip.

Share this post


Link to post
Share on other sites

@maxmp  still no luck with Hi-Res Output

 

LG V60

Snapdragon 865

Android 10 (Stock)

Build 869

I also noticed for some reason the Hi-Res Out sample automatically sets to 16bit 48khz no matter what options I set.

 

Screenshot_20200502-172717.png

Screenshot_20200502-172741.png

Share this post


Link to post
Share on other sites

@Aeolus In your case, LG for some reason specifically removed qualcomm branding in few places Poweramp uses to detect Snapdragon. Can you please share your build.props file (or install Device Info HW app and share the first General tab)?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...