Jump to content

Poweramp builds 948-957


maxmp

Recommended Posts

  • Replies 429
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

4 hours ago, Mandolo5758 said:

Why can't this text be detected on Poweramp ?

Well to start with, your lyric filename has a .TXT extender not .LRC. Rename it to  Anggun - A Rose In The Wind.lrc  and it should be detected fine.

Officially (according to the rather minimal spec) LRC files are only meant to be used for synchronised lyrics with timecodes by the way - which your file is not - but in the most recent Poweramp beta release Max has allowed general text files to be used too, so please make sure you are using the latest beta too.

Andre 

Link to comment
Share on other sites

6 hours ago, andrewilley said:

Well to start with, your lyric filename has a .TXT extender not .LRC. Rename it to  Anggun - A Rose In The Wind.lrc  and it should be detected fine.

Officially (according to the rather minimal spec) LRC files are only meant to be used for synchronised lyrics with timecodes by the way - which your file is not - but in the most recent Poweramp beta release Max has allowed general text files to be used too, so please make sure you are using the latest beta too.

Andre 

I'm using the latest beta v956 ,,, 

Problem is solved, cos I've downloaded the lyric .lrc. ok.

Link to comment
Share on other sites

Hi everyone,
I think the latest build (or maybe it's from the Skin update itself) reset my Widget and Notifications theme. The Player skin is fine.
Buttons lost their modern touch and I can't find another setting that brings back my previous design.
Do you have any clue (sorry if it's not the right place) ?

Player - That still has its Skin applied :

Screenshot_20230309_225902_Poweramp.jpg

Notification & Widget that have these bold controls.

Screenshot_20230309_230012_One UI Home.jpg

Screenshot_20230309_225832_One UI Home.jpg

Edited by RockinMad
Link to comment
Share on other sites

@RockinMad To solve the issue with Notifications, please find the setting this way.

1. Setting, 2. choose Look and Feel 3. choose Notification,

then you will have four options, make yourself a choice and see if there's any problem,Screenshot_2023-03-10-16-05-57-810_com.maxmpz.audioplayer-edit.thumb.jpg.c4844b72a0cbbb5cc846c4b8683141c8.jpg

 

And if you want to change the setting of wigdet, please tap the top right edge of the wigdet.  And by the way, I noticed that there's something change about the wigdet, but I forget whether it's a changing from Android 13 or Poweramp.

The design of buttons it's related to Skins, so you will see the setting in your Skin App. A short cut to the skin setting it's to long press this button.Screenshot_2023-03-10-16-13-14-797_com.maxmpz.audioplayer-edit.thumb.jpg.cd72c0281fabdd31c71bd96d39e27f6e.jpg

 

Hope these could help you to solve the issue.

Link to comment
Share on other sites

2 hours ago, Loweaul said:

@RockinMad To solve the issue with Notifications, please find the setting this way.

1. Setting, 2. choose Look and Feel 3. choose Notification,

then you will have four options, make yourself a choice and see if there's any problem,Screenshot_2023-03-10-16-05-57-810_com.maxmpz.audioplayer-edit.thumb.jpg.c4844b72a0cbbb5cc846c4b8683141c8.jpg

 

And if you want to change the setting of wigdet, please tap the top right edge of the wigdet.  And by the way, I noticed that there's something change about the wigdet, but I forget whether it's a changing from Android 13 or Poweramp.

The design of buttons it's related to Skins, so you will see the setting in your Skin App. A short cut to the skin setting it's to long press this button.Screenshot_2023-03-10-16-13-14-797_com.maxmpz.audioplayer-edit.thumb.jpg.cd72c0281fabdd31c71bd96d39e27f6e.jpg

 

Hope these could help you to solve the issue.

Thanks Loweaul, 

Unfortunately the notifications settings either don't do anything or make the notification disappear. 

Maybe something is corrupt because I've recently moved to a new phone? 

As for the widget, all settings offered keep the same design for the buttons. 

Link to comment
Share on other sites

@RockinMad Yeah, as maxmp said, it's about the Android version, there are lots of changes in Android 12 or 13, the notification and more changes in Android 13 is related to the issues you mentioned.

So actually we can't find a way to reverse, it means that if you go back to older version of Poweramp, things won't change.

Link to comment
Share on other sites

8 hours ago, RockinMad said:

Ah, hard to fix then. Well it's minor but that's bothering lol 

Well if there's no other solution at the moment, I'll wait! 

Thanks anyway ;)

I guess the Android developers are the only one who accounts for the issues.

They made a lot of changes throughout Android 12 to 13, the notification and the widget had changedi design twice in the update.

So yeah, why don't we just accept?¬†ūüėā¬†and it might be the only way.

Link to comment
Share on other sites

@pedrini69 these are firmware issues which can be only worked around if I get those specific firmwares and test on my devices or alternatively with the active help of the user with the affected firmwares (willing to test intermediate builds + share logs). This takes a lot of time and often firmwares are updated/fixed before even we investigate issue fully (usually happens for MIUIs). The animation on/off toggle will be added, but user should enable/disable this manually though on the affected launcher (widget is shown and wrongly animated by the launcher).

Link to comment
Share on other sites

2 hours ago, maxmp said:

@pedrini69 these are firmware issues which can be only worked around if I get those specific firmwares and test on my devices or alternatively with the active help of the user with the affected firmwares (willing to test intermediate builds + share logs). This takes a lot of time and often firmwares are updated/fixed before even we investigate issue fully (usually happens for MIUIs). The animation on/off toggle will be added, but user should enable/disable this manually though on the affected launcher (widget is shown and wrongly animated by the launcher).

Quite happy to test intermediate builds and share logs - please do ask

Link to comment
Share on other sites

Build 957:

  • widget animation disable option in widget configuration (other page)
  • fixes for avrcp bluetooth info not updated for some firmwares
  • UNSYNCEDLYRICS tag support
  • fixed parametric Q factor over 10
  • fixed standalone streams importing
  • new Android Navigation Bar: No Background option. For Samsungs @ Android 13 - to hide the default navigation background
  • increased max. possible number of list items for Auto. The number is larger if "Album Art for Tracks" is disabled, but still limited to about 1700
Link to comment
Share on other sites

@antonridd thanks for the report. I can see it rendered OK in Poweramp widget configure dialog, but not rendered by your launcher properly (on Android, widgets are rendered by your launcher, not the app). What is your launcher? Does it render it properly right after reboot? If so, at what moment does it start to render incorrectly (e.g. track change, after reconfigure, after changing some widget option, just randomly, etc.)? The 956-957 builds do not have changes related to widget styling.

Link to comment
Share on other sites

well the flicker on the widgets keeps on happening, didn't seemed to be the album animation. 

Maybe is an issue exclusive to my phone?

This is the launcher im using, maybe you can reproduce the bug

https://apt.izzysoft.de/fdroid/index/apk/com.saggitt.omega

altough it has happened in all the launchers i've used

Edited by pedrini69
Link to comment
Share on other sites

4 hours ago, pedrini69 said:

well the flicker on the widgets keeps on happening, didn't seemed to be the album animation. 

Hmm, looks very much like the update animation between tracks - old artwork disappears and new artwork fades in with a very slight zoom effect. Does this happen at any other times? Have you tried turning the Album Art Animation feature off in the widget configuration menu (new in the 'Other' tab)? 

Andre

Link to comment
Share on other sites

@pedrini69 what is your device/firmware/dpi settings if modified/launcher and launcher scaling settings (from your screenshot your scaling doesn't seem standard).

Poweramp uses standard dp pixels to set the sizes in widget. Why your launcher renders some elements properly and some elements weirdly scaled - is a question to the launcher devs. I still can try to reproduce it locally if I can reproduce your environment on my device. Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
√ó
√ó
  • Create New...