Jump to content

Can't Cast directly through Poweramp


Osiris
 Share

Recommended Posts

  • Replies 45
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

@Osiris  I assume Max has not been able to replicate this issue, without which it would be hard to work out what your specific phone/Android/Chromecast device is doing. Have you sent any logs to the support email address when this issue occurs? Have either of you tried removing the unlocker app (once validated, it can be uninstalled for the time being).

@maxmp Could this be related to the shared used ID issue that a few people reported, possibly linked to Unlocker being present?

Andre

Link to comment
Share on other sites

@andrewilley HI Andre. I appreciate the response.

 

I have sent logs to the support email. They told me to uninstall the app and unlocker from the play store and reinstall the apk directly from Poweramp. I did that with no luck. I also tried removing the unlocker app with no luck. This issue is very strange. Casting was working perfectly all week for me. Last night for seemingly no reason it stopped working and I can't get it to work again. I can also confirm that casting from other apps (SoundCloud, YouTube, etc.) is functioning normally. Please let me know what steps I can take or what information I can provide to help figure this out. Thanks. 

Link to comment
Share on other sites

@Osiris current builds (922/923) works fine with Chromecast. Poweramp is tested with Home, Home max, CCwTV, Sony android TVs. What is your CC device? 
Please note that casting files from your Poweramp requires Chromecast access to your phone, this means it won’t work in “isolated” network, even if other players such as Youtube and Spotify do work - as they stream directly from internet.

Link to comment
Share on other sites

@maxmp I have multiple devices (home, home max,ccwTV) and when it doesn't work for one it doesn't work for all of them. Also it does work some of the time for days at a time so I don't think it's something on my end with respect to access (correct me if I'm wrong). Then it seems to stop working randomly. I am not adjusting any settings in Poweramp or on my phone in general. 

 

Link to comment
Share on other sites

I also experienced problems with PA streaming via chromecast consistently for about two years. With online streaming services like Spotify I never had any problems.

For a few month now streaming with PA via chromecast works quite stable after changing the settings of my WiFi network. My three streaming speakers and my mobil device are exclusively connected to the 5 GHz band, which has a different SSID name compared to the 2.4 GHz band. For the 5 GHz WiFi a permanent channel is set, which isn't reserved for preferred user (e.g. radar). WiFi band-steering is deactivated. Perhaps this helps.

Regards

Link to comment
Share on other sites

@GeilerHeinz that's interesting. I have been thinking my Poweramp Chromecast issues may have something to do with my wifi settings. The problem is that I have a nest router and there's no separate 5ghz ssid nor is there a way to force it to connect to the 5ghz band. This makes me wonder if it works when it's connected to the 5ghz band and doesn't work when it's connected to the 2.4 band. @andrewilley @maxmp any thoughts?

Link to comment
Share on other sites

One of the complications with Chromecast output is that Poweramp needs to send the entire audio data from your source file to the target device over your WLAN. Other streaming services (YouTube, Spotify, etc) just tell the Chromecast device what they want it to play and the CC device fetches the music from the internet itself, nothing is sent from the phone. This can make direct comparisons a bit tricky.

Andre

Link to comment
Share on other sites

@andrewilley That makes sense. I also have tried casting local audio from VLC player (which I would imagine works similarly to Poweramp) and it is also working. Could the issue be caused by Poweramp being incompatible with the way my nest router switches between 5ghz and 2.4ghz? This might explain why it works some of the time. Any thoughts?

Link to comment
Share on other sites

Regarding differences of casting local files with PA and VLC player, that's what @maxmp answered once:

Poweramp streams raw (decoded) PCM. While this requires more data to be sent to the chromecast device, it also ensures we don’t double recompress audio (thus higher quality/less compression artifacts) and also all supported formats are “castable”.

https://forum.powerampapp.com/topic/19181-constant-interruptions-while-streaming-via-chromecast/?do=findComment&comment=84963

Link to comment
Share on other sites

Also, routers normally handle the different connections on the LAN/WLAN - so it shouldn't matter whether devices are connected back to the router/switch by 2.4GHz / 5Ghz wi-fi or by ethernet cable. Generally, 2.4GHz will give you a greater range from the router, but possibly slower throughput. 5GHz might be a bit more fussy about location and wireless distances, but when it does connect it is faster.

Andre

Link to comment
Share on other sites

Sure, it depends on the local stability of the WiFi band. At my place the 2.4 GHz WiFi is very crowded with networks of my neighbours, that's why I use the 5 Ghz band. But it's essential that the device and the speakers aren't steered to another band nor access point while streaming.

Regards

Link to comment
Share on other sites

  • 9 months later...

Same issues here.  Was working fine a few days ago but when I attempted to cast to a single speaker or to a speaker group, I experience the same issues...connection sound from speaker(s) but then no audio and in PA app, it seems to replay over and over the last 1-2 seconds (from where it was stopped previously).

Link to comment
Share on other sites

  • 1 month later...

OK, I was having this issue when casting to a new Nest Audio.

Then I remembered I was using AdAway's non-root VPN ad-blocking solution.. so I turned off AdAway's VPN, restarted PA (cleared all open apps) and lo... it works fine.

Hopefully that may help someone.

Android 11, PA Build 945

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...