Jump to content

Android13 infinite crashes


Mining
 Share

Recommended Posts

build-939-bundle-play[939004-333c8a71] 64bit

Pixel 4XL

Android 13

8/15 Update official version of Android 13
Open Poweramp after update
will keep flashing and turn off my phone
After booting it will show that my system is damaged
But you can enter the system by pressing continue.
Please check the problem and fix it

I can't listen to music now, so sad

 

I upload to Youtube
You can see that the playlist cannot be read
but can be read by folder
After playing, the phone flashes directly and shuts down
Android 12 does not have this problem
It should be that Poweramp conflicts with the Pixel series

 

8/20 Update Now select the old version as the notification type and it can be used normally

 

Edited by Mining
Link to comment
Share on other sites

  • Replies 46
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Android 13 is not an official product yet, but it should be supported by the time it is fully released. Thanks for the info.

Have you tried a clean re-install of Poweramp by the way? Someone reported issues with Hi-Res output crashing, so going back to Output defaults (or even by clearing app data) might help. Backup your playlists/etc first though.

Andre

Link to comment
Share on other sites

Hello, the official version is out...
Reinstalled, same problem
I saw the problem with that person, but he didn't automatically shut down
I guess something in Poweramp is conflicting with PIXEL

Link to comment
Share on other sites

 

26 minutes ago, Mining said:

I guess something in Poweramp is conflicting with PIXEL

Or something in Pixel is conflicting with Poweramp of course... Google do love moving the goalposts. Yes, official release was in the last few days for a few devices. 

So same problem even with the default OpenSL ES Output?

@maxmp is this something you are working on?

Andre

Link to comment
Share on other sites

  • Mining changed the title to Android13 infinite crashes
16 minutes ago, andrewilley said:

 

或者 Pixel 中的某些東西當然與 Poweramp 發生衝突……谷歌確實喜歡移動球門柱。是的,最近幾天正式發布了一些設備。 

即使使用默認的 OpenSL ES 輸出也會出現同樣的問題?

@maxmp 這是你正在做的事情嗎?

安德烈

That's right, I reinstalled and played the same thing with default settings
But I have backed up the config file first.

Link to comment
Share on other sites

32 minutes ago, andrewilley said:

解決不兼容問題後,您將能夠再次恢復舊的導出設置。

安德烈

The problem now is waiting for the developers to fix
I don't care about the settings here.

Link to comment
Share on other sites

2 hours ago, Mining said:

The problem now is waiting for the developers to fix
I don't care about the settings here.

The problem is Google pushing out OS updates before the devs have a chance to work through the beta changes. Poweramp is not the only app with issues in since A13 launched. But I'm sure that is why it was only pushed to Pixel devices so far.

I'm sure @maxmp will have it updated shortly.

Link to comment
Share on other sites

Posted (edited)
19 minutes ago, MotleyG said:

問題是谷歌在開發人員有機會完成測試版更改之前推出了操作系統更新。自 A13 推出以來,Poweramp 並不是唯一存在問題的應用程序。但我確信這就是為什麼到目前為止它只被推送到 Pixel 設備。

我確定@maxmp 很快就會更新。

To be honest with the A13 I didn't have any problems
Even the online banking APP is normal

In addition to the Poweramp exception

Edited by Mining
Link to comment
Share on other sites

Poweramp build-939-bundle-play

Pixel 4a 5G (US)

Android 13, August 5, 2022 Update, stock ROM

I just upgraded to Android 13 today, and I'm experiencing the exact same problem as the OP's video. Poweramp opens fine, but as soon as it starts playing music, i.e. pressing the play button or autoplaying when attaching headphones, the screen will flicker a few times before the system reboots. I've also attached a support log if that is helpful. Let me know if the devs need any more information. Thanks!

 

Poweramplog.txt

Link to comment
Share on other sites

52 minutes ago, kpro said:

Poweramp build-939-bundle-play

Pixel 4a 5G(美國)

Android 13,2022 年 8 月 5 日更新,庫存 ROM

我今天剛剛升級到 Android 13,我遇到了與 OP 視頻完全相同的問題。Poweramp 可以正常打開,但是一旦開始播放音樂,即按下播放按鈕或連接耳機時自動播放,屏幕會在系統重新啟動前閃爍幾次。如果有幫助,我還附上了支持日誌。讓我知道開發人員是否需要更多信息。謝謝!

 

Poweramplog.txt 9.15 KB · 1 次下載

It turns out that I'm not the only one who is lonely. It seems that everyone with pixel should have this problem.

Link to comment
Share on other sites

If this is an issue with Pixel devices, it may be limited to specific models. I upgraded my Pixel 6 to Android 13 earlier today and have not had any crashes or freezing using high res output in Poweramp with either USB DACs or Bluetooth.

Link to comment
Share on other sites

1 hour ago, CrimsonSky said:

If this is an issue with Pixel devices, it may be limited to specific models. I upgraded my Pixel 6 to Android 13 earlier today and have not had any crashes or freezing using high res output in Poweramp with either USB DACs or Bluetooth.

Did you play directly from your phone speaker without crashing?

Link to comment
Share on other sites

I tried using Hi-res output with Aux and a wired headset attached and the crash still happens. Bluetooth also ends up crashing. I also tried setting AAudio Output for speaker and still crashing. So it seems like pressing Play is enough for this to happen. I found someone reporting more or less the same issue almost a month ago with Android 13 beta.

From this user's previous posts, it seems like they're using a Pixel 6.

Edit: I tried disabling the "Show on lockscreen" option but the issue is still there.

Link to comment
Share on other sites

Now this is interesting I'm not having this issue YET with another media player I was using (Cloud Player) had this exact same issue which caused me to uninstall because it's completely useless.

Devs don't seem to really care to fit it either. 

How power amp is working for me on android 13 after a fresh install and not for you other's having problems is beyond me

I'm using a Pixel 6 btw.

Link to comment
Share on other sites

Also just updated to Android 13 on a Pixel 6 and having the same issue.

Screen flicker, leading to phone crashing rebooting. Showing corrupted data in recovery but boots normally.

Reinstalled Poweramp, played the first song fine but as soon as I skipped one went back to crashing the phone. That’s as far as I’ve gotten so far.

Link to comment
Share on other sites

I have the same issue, but I think i know the cause, and can recreate it easily. The issue for me was that some songs didn't have album art. Essentially any song that had 'Unknown artist' obviously won't have album art. So when it came time to play the song it lead to crashing my phone over and over until it rebooted itself.


I 'fixed' it by giving it an artist and manually choosing the album art.

Hope this helps find the root cause!

 

Pixel 5a here btw. Updated to Android 13 and latest version of Poweramp possible: build-939, play

Link to comment
Share on other sites

3 hours ago, zzzaap said:

The issue for me was that some songs didn't have album art. Essentially any song that had 'Unknown artist' obviously won't have album art. So when it came time to play the song it lead to crashing my phone over and over until it rebooted itself.
I 'fixed' it by giving it an artist and manually choosing the album art.

Thanks for the info, could the other people who have been experiencing this issue with Pixel/Android 13 confirm if it's the same for them?

Andre

Link to comment
Share on other sites

Max doesn't spend a lot of time on the forums as it can be a bit a rabbit hole that takes time away from actually working on the app. That's why I'm here. :) Not to mention the 'other issues' arising from where he currently lives. I'll message him to suggest he takes a look at this thread sooner rather than later.

Andre

Link to comment
Share on other sites

8 hours ago, zzzaap said:

I have the same issue, but I think i know the cause, and can recreate it easily. The issue for me was that some songs didn't have album art. Essentially any song that had 'Unknown artist' obviously won't have album art. So when it came time to play the song it lead to crashing my phone over and over until it rebooted itself.


I 'fixed' it by giving it an artist and manually choosing the album art.

Hope this helps find the root cause!

 

Pixel 5a here btw. Updated to Android 13 and latest version of Poweramp possible

I had Settings > Album Art > Force Default Image turned on. So even when I added an Album Art, it would still crash. However, if I turn that off and play songs that show an Album Art, then it doesn't crash anymore! Thanks for the workaround! Hope it can help narrow down the issue.

Link to comment
Share on other sites

@Mining unfortunately the issue is not reproducible on my Pixel 6 @ Android 13, nor on Android 13 emulator (default settings, build-940). If you have backup of your Poweramp settings please send those to gpmaxmpz@gmail.com.

There are few broken things on Android 13 (notification, direct file access), so I would suggest resetting at least Notification options on your device to the default settings or try to change notification type in Poweramp settings to a different type. Direct file access (Legacy file access in Poweramp) seems to be completely removed from the Android 13 release, but this should tested further as Android may enable some compatibility modes for an app which went through Android upgrade, etc.

 

Link to comment
Share on other sites

@kpro Previously, some OEM firmwares exhibited similar behavior with the empty album art default image (zig zag logo). The logo was optimized out by Play when the custom APK was generated for the phone (so called bundle installation). Recent Poweramp builds have explicit configuration options disabling such optimizations, so I would suggest re-installing the latest build, or installing uni build APK over the Play installation.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...