Jump to content

Id3 Tags Not Working


Recommended Posts

Ok, I love Poweramp, but for some reason my id3 tags are not updating? I mean the album, artist, and years are updated to what I entered, but the Genres won't update? Ot just puts all my music into an unknown category. I noticed that I had an unknown category in the Genre list so I clicked to see what was up, and just a few albums were saying they had unknown Genres. So I tried re-entering them, but that didn't work. So I did a full rescan and now all my albums are saying the genere is unknown? I mean the genre I entered is in the id3 tag but it's like it's not registering? I hope yall can understand what I'm saying lol I have a hard time explaining stuff nonvocally. Anyways, if someone could help please let me know. Thank yall and have a great day!

Link to comment
Share on other sites

  • Replies 40
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

What device, Android version, and Poweramp version are you using? I haven't experienced this myself, but perhaps you have recently updated to an Android version where there is now a different allowance required for proper file access?

Link to comment
Share on other sites

So all the other tags are displaying as expected - Titles, Artists, Albums, Track#, etc - but just the Genre data is not being picked up, even after a FULL Rescan? Sometimes re-editing a single tag externally (e.g. on a PC) and then syncing the file back to your Android device may get missed by a regular scan, but a Full Rescan should find everything.

What happens if you long-press on a song and view its Info/Tags, do you see Genre information in there?

What ID3 tag editor are you using?

Andre

Link to comment
Share on other sites

  • 2 weeks later...

Hi everyone,

I upgraded/updated my micro SD card on my FiiO M11, build 933, Android 7.0 and experienced the behavior where Poweramp is unable to recognize the Genre tag despite having it populated.

I've attempted a Full Rescan and this has not corrected the problem.

Thanks.

Link to comment
Share on other sites

The original poster of this thread never came back to follow up on this so I don't know if they've resolved the problem. Do you see exactly the same as they did, that even after a FULL Rescan all of the other tags are fine (Title, Album, Artist, Year, etc) but every song is listed in the Genre category under "Unknown Genre" ?

Andre

Link to comment
Share on other sites

21 minutes ago, blindsight13 said:

Good morning Andre,

From my library 1723 tracks/files are reporting Unknown Artist, Album Genre. However, when going to the Info/Tags Genre, Artist, Album, Year etc. are all populated with information. 

Thanks.

And to confirm, you have run a "Full Rescan" to wipe the database and start fresh? This is the third option down on the Settings>Library page. The top line that says "Refresh" will only add new or changed files to the existing database and won't make corrections to files that were previously added.

Link to comment
Share on other sites

9 minutes ago, blindsight13 said:

Yes this is after a Full Rescan. I am doing some testing right now and did another Full Rescan. Count now went down from 1723 to 1267. I am checking to see if I can keep reducing this amount with more Full Rescan's.

This is quite strange. Running a Full Rescan effectively wipes put the existing library database then scans all media files as new. I can't explain why this would change the count of files missing tag info. Especially on your M11 that is at A7.0, as this would not be affected by the recent SFA issue introduced by Google to protect us from our own file structures. You mention this is a new card, are you sure it had the songs transferred over successfully from the original source?

Link to comment
Share on other sites

I have done two more Full Rescan's and the count went down from 1267 --> 96 --> 0. So all my tags are now good. One item of note was I removed the sleep timer so that the device was up for the entire duration of the Full Rescan so I don't know if this was part of the issue. Maybe the Full Rescan will only work if the device is not in Sleep mode. I have a large library and this could be a bigger challenge if you have an extremely large library to keep the device active for.

Link to comment
Share on other sites

Interesting note about the sleep timer, but I think that only affects playback (if you are talking about the timer in Poweramp). I have a library of almost 24k songs, mixed from some older mp3 but mostly ALAC files. This fills a 512GB Sandisk Extreme uSD card. It usually takes about 15 minutes to run a complete Full Rescan if I make a lot of changes to the library on this card. But it has not had any problems with collecting the tag data for the library.

Good that you have it working now, regardless of whatever was the root cause.

Link to comment
Share on other sites

I assume that by "sleep timer", @blindsight13 is not referring to PA's playback timer which stops music after a user-defined duration. Instead I think this might be Android's screen timeout, which could make some sense. If Android is preventing PA from gaining fast enough access after the device goes into a low-power screen-off state, the scanner could indeed fail.

We'd need some input from @maxmp on that though, but in the meantime please make sure that Poweramp and the unlocker app are both excluded from any power-saving or optimisation processes in Android's app settings.

Andre

Link to comment
Share on other sites

I'm having the same issue. Is the only way to fix this with a full rescan? Usually a Playlist scan would repair this. But this time a normal scan isnt resolving it. 

Is there a way to import ratings after a full rescan? 

The songs will still play but even if I edit the tags it won't save them. Also it doesn't let me re add album art or really modify anything. 

S22, internal storage. 

Link to comment
Share on other sites

@Andrew Evenstar It sounds as though there is an access permission issue with your storage (especially if edited tags won't save). You can't modify album art embedded inside audio files with Poweramp though, only the local version that PA displays. Are you seeing that same issue as the original poster - i.e. Artist, Albums, etc are reading correctly, but not Genres? Or are all tags missing?

A Full Rescan should not destroy your ratings - as long as the same existing files are found again - but to be safe it might be worth exporting both ratings and playlists first using PA Settings=>Export Settings/Data. You could also try using File Access Legacy Mode (in PA Settings=>Misc) to avoid using the newer Android Storage Access Framework (the latter being slower and more restrictive).

If a Full Rescan does not resolve the issue, try revoking storage permissions (so everything is cleared, which would include local ratings) and then re-grant access to your music folder(s). You can then restore ratings/etc from your backup. For details, see 

Finally, if you have upgraded to Android 12 from an older setup and so might have some old configurations still present, it might be worth clearing all app data and allowing PA to restart as a clean installation and rebuild its library. 

Andre

Link to comment
Share on other sites

Thanks for the help. A full re-scan did not fix it. i just went with starting over fresh. It's okay... I've been using PA for a decade. I love the app. A fresh start with a new phone is fine. I just hope it does not keep happening ! I did the revoke storage action. 

Link to comment
Share on other sites

so it just happened again, not sure what caused it. i think the only think i imported was playlists and possibly album art. no system settings. 

i removed storage permissions and re-added my main folder, which is just the "music" folder on the root of the device. just curious but does anyone know why this happens or are there logs to show why?

best 

Link to comment
Share on other sites

Posted (edited)

Here's a screenshot of how files in my playlist look. this time i did not remove full app permissions. but i did go into storage and removed the folders, then re-added and did a full scan. the issue still persists. the songs will still play but i can't edit the tags of these files. 

 

 

Screenshot_20220504-151822_Poweramp.jpg

Edited by Andrew Evenstar
Link to comment
Share on other sites

This is back to PA being unable to 'deep scan' (for want of a better word) certain audio files for some reason. It has discovered the existence of the .mp3 files during its initial directly crawl - which merely hunts through all of your music folders and subfolders looking for certain file types such as MP3, FLAC, etc - but when it went back on a second pass to properly open and read the embedded tag information from each of the newly-found files, it was unable to do so. This failure to detect tags will result in just the raw filename being displayed, but with no other details such as cover art, name of Artist, Album, Track Title, etc.

What do you see when you long-press on one of these filename-only entries and view Info/Tags, especially compared to one of the fully detailed songs? Is the path information any different for example, and do the tag contents display correctly in that overview screen?

It is possible that your phone went to sleep during the scanning process (the second phase takes a lot longer than the initial directory crawl). If so, try another Full Rescan while preventing the screen from going to sleep and see if perhaps something in the phone is preventing PA from getting the access it needs?

Andre

Link to comment
Share on other sites

when i long press and try to view info/tags, nothing happens, the small popup menu at the bottom screen disappears. 

i also did a full rescan and set my phone to never sleep and kept Poweramp the active app. the issue is still there. I will try a full re-scan again. if that does not work i'll revoke all permissions and storage and try again. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...