Jump to content

Recommended Posts

Posted (edited)

Version: v3-build-874-arm64-play [874004-517ac8a1] Full Version 64 bit

Device: Samsung S10 Plus G975F

Android version: 10

No custom rom

 

I'm not sure when the last Poweramp update was but this all started happening about a month ago and it's only now after uninstalling/reinstalling things I've figured out it seems the issue is Poweramp.

So usually I bluetooth connect my phone to my hifi or Galaxy Buds, and this past month I've had nothing but issues. Constant overheating, terrible battery life (2 to 3 hours on screen time) and lag making the phone almost unusable. Initially I did think it was the latest android update, but after the issues persisted I went about uninstalling different apps to see if there was any difference. After uninstalling Poweramp a few days ago the lag, overheating and battery issues have disappeared. So logically I'm thinking it must be this app. It also happens when I play music straight from my phone so I don't think it's exclusively a bluetooth problem. Any help would be appreciated because it's still easily the best music player out there and I really don't want to switch to a new one. 

Thanks 

Edit: there are other issues with the app too in this one month time frame I forgot to mention; new music added doesn't seem to appear in the recently added section and tracks that were previously in my library no longer show up until I open them via file manager, and when they do play through Poweramp I can only see the "info/tags" & "lyrics" options. Album art, artist, album, genre etc all disappear. 

Edited by LaRusso
Extra info

Share this post


Link to post
Share on other sites

It could be a file scanning issue. If that is not completing correctly, and it carries on running, that could indeed drain the battery faster than normal.

Try wiping app data and allowing it to start over again (you'll need to set your music location again in  ☰ Settings > Library > Music Folders, and allow permissions again). Remember to backup Settings and export any internal Playlists first (don't restore the settings to start with though, the problem may be in there).

Andre

Share this post


Link to post
Share on other sites

Poweramp scanning is always visible (rotating progress) and also it's not allowed when player in the background. Actually, nothing in Poweramp allowed to be in background (when not playing) more than ~1 minute on Android 10.

Also, if Poweramp consumes battery it's immediately visible in system battery usage stats.

Share this post


Link to post
Share on other sites
6 hours ago, andrewilley said:

It could be a file scanning issue. If that is not completing correctly, and it carries on running, that could indeed drain the battery faster than normal.

Try wiping app data and allowing it to start over again (you'll need to set your music location again in  ☰ Settings > Library > Music Folders, and allow permissions again). Remember to backup Settings and export any internal Playlists first (don't restore the settings to start with though, the problem may be in there).

Andre

Yeah I've done this, I wiped the cache and data before the last uninstall, reinstalled it yesterday and my phone still heats up after about 1 minute, heat seems to mainly come from the top area of the device around the volume buttons (don't know if that info might help lol) so not sure how to fix this one. I've even wiped the cache partition hoping that might somehow sort it but unfortunately not. 

Share this post


Link to post
Share on other sites
1 hour ago, maxmp said:

Poweramp scanning is always visible (rotating progress) and also it's not allowed when player in the background. Actually, nothing in Poweramp allowed to be in background (when not playing) more than ~1 minute on Android 10.

Also, if Poweramp consumes battery it's immediately visible in system battery usage stats.

It's strange because even when it's overheating, lagging and the battery drain is happening the device care shows everything as normal. It just got really hot again before after playing some music for 2 minutes and when I closed Poweramp it had cooled back down after 5 minutes. Really weird and I'm not sure what to do. 

Share this post


Link to post
Share on other sites

Post your battery stats (after the issue with the overheating). You may also try to send a log from Poweramp Settings / Support immediately after the lagging.

Please note that if you use sd card, buggy sd card may cause device lagging (on system level - but that will affect apps reading from sd card, e.g. Poweramp reading music), in this case check that sd card on PC for errors. Thanks!

Share this post


Link to post
Share on other sites
18 hours ago, maxmp said:

Post your battery stats (after the issue with the overheating). You may also try to send a log from Poweramp Settings / Support immediately after the lagging.

Please note that if you use sd card, buggy sd card may cause device lagging (on system level - but that will affect apps reading from sd card, e.g. Poweramp reading music), in this case check that sd card on PC for errors. Thanks!

Ok thanks I'll see what I can do. Is there any app in particular that's best for recording battery usage or should I just use the stock system one? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...