• Announcements

    • andrewilley

      Poweramp v3 Project Update   04/24/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code. It is hoped this will be ready for final beta-testing by the end of the May. See forum thread for more details and to discuss.    
maxmp

Poweramp alpha-build-702

337 posts in this topic

12 hours ago, Don024 said:

How does the USB otg storage works? 

As it worked before (pre-6.0), you just need to select USB storage once in Settings / Folders/Library / Music Folders

 

8 hours ago, Hoàng Khanh said:

Iam using Sony Xperia Z3,When active Hi-Res option,it says failed.Can anyone help me ?

What is exactly your Xperia Model and Android version? I'll try to test on exactly that device.

 

8 hours ago, Roi007leaf said:

Using a custom rom on my g3 I don't see the hi res option

Please note, as a rule Hi-Res support exist only in stock ROMs. CM and other AOSP ROMs (usually) have these drivers removed/disabled and max output fixed on 16bit 44.1/48khz.

Also, V4A, of course, will convert your sound back to 16bit 44.1/48khz anyway. Though, I have plans of integrating V4A into Poweramp as plugin, no root required. But this is sort of opposite to Hi-Res, it's about adding more DSP processing.

 

8 hours ago, foxsprout said:

One thing; I'm using Exynos Note 4, and I read several articles already that it should support 24/192, but Samsung only sampling them to 16/48 no matter what the music player is.

Note4 (latest OTA ROM) is fully supported by Poweramp alpha2, we tested on that device with sample rates up to 192khz. Though, my ROM can be different (Samsung ROMs are varied by world regions and other factors). I would suggest changing buffering for Hi-Res output - e.g. increase number of buffers to 3-4 and check if this helps.

 

4 hours ago, decipher said:

ever since alpha 01, I've been having some lag whenever I bring down the notification panel while on the "now playing" screen, sort of get to 10 fps. Is this a known issue? what can I do to solve this?

This is not common, I can't see this behavior, except may be for very old devices. It may be also some ROM option to force non-foreground app to reduce its CPU/GPU usage as well.

 

3 hours ago, andrewilley said:

I actually don't see these two options in my menu at all (Note 3 running Android 4.,4.2):

  • - 30/50/100 volume levels (Settings/Audio/Advanced Tweaks)
  • - custom volume panel (Settings/Audio/Advanced Tweaks)

Are they there for everyone else?

This option is available for Android 5.0+.

 

2 hours ago, CruzerX said:

miss typo in sample rate 44.1>41.1

Thanks, string resources typo, fixed.

Share this post


Link to post
Share on other sites
11 minutes ago, marvell said:

What about Meizu? 5

I'm interested in adding Hi-Res support for as many devices as possible. Can you please PM me /etc/audio_policy.conf file from your device? That will help to identify if Hi-Res output is possible for that device/ROM.

Thanks!

Share this post


Link to post
Share on other sites

The musicFX button has disappeared in this. Rolling back to alpha 1. I use v4a so it's a deal breaker. Hope it's fixed.

Share this post


Link to post
Share on other sites

Most of the cover art issues appear to be resolved in alpha2 (downloading art, and display of embedded art on MM devices) but Playlist-mode is still not showing any cover artworks at all in the player screen.

Andre

Share this post


Link to post
Share on other sites
21 minutes ago, whiplash1 said:

The musicFX button has disappeared in this. Rolling back to alpha 1. I use v4a so it's a deal breaker. Hope it's fixed.

MusicFX tested and works, but following changes applied regarding its functionality:

- button moved a bit (now it's next to Mono button)

- it may not work with Hi-Res (for all of my test devices it does work, but this is experimental feature)

- if it fails for OpenSL output, you may try to switch to AudioTrack output (Poweramp settings / Audio / Output). Again, it works for all my test devices, but knowing how it's implemented in Android, I see possible point of failure here

Share this post


Link to post
Share on other sites

Wow so my days of constant nagging for Album Artist tag support is finally over. THANK YOU!

 

*Goes searching for Fiio Q1* Proper Hi-Res on phone, here I come!

Share this post


Link to post
Share on other sites

Hey there, Max. Just made an account today after using Poweramp for over a year.
Thanks for all the awesomeness. But I'm here for another reason.

I'm currently using a OnePlus One.
http://www.gsmarena.com/oneplus_one-6327.php

The OPO is running Sultan's CM13 ROM.
http://forum.xda-developers.com/oneplus-one/orig-development/rom-kernel-unofficial-cyanogenmod-13-0-t3242700

I'm on the latest Poweramp alpha-701 and going into Audio Output, I can see the experimental high-res output setting. However, upon activating it for the headset, I get a failed popup. If I recall correctly, the OPO should natively support 24bit 96/192khz output thanks to using the same audio chip the LG G2 uses. If you have the time to help me on this, it'd be much appreciated. Thanks!

Share this post


Link to post
Share on other sites

Confirmed, album art not showing whilst in playlist mode. Galaxy S7 Edge.

Share this post


Link to post
Share on other sites

Visualization is awesome. But sometimes I want to stop this. Here is the problem. When Poweramp is running, from right panel I disabled the visualization. It works fine. But when I stop the player and replay again, visualization starts automatically. This happens for both builds 700 & 701.

If this is a bug then please fix this. If not, then I have a request of option to fully stop the visualization.

Samsung 7582, OS 4.2.2

Share this post


Link to post
Share on other sites

Just installed alpha build 701 on Moto Nexus 6 (rooted, stock 6.0.1) which does support hi-res output.

Is there any guide to help learn how best to sync all these settings-- audiotrack output, opensl es output?  Does usb dac need to be on to get hi-res output? 

Looks promising, thanks!

Share this post


Link to post
Share on other sites

ViperFX Not Working ?? Any way to Fix this ?? (Direct Volume Control is already Disabled) 

Share this post


Link to post
Share on other sites

I downloaded Alpha 2 and wanted to give some feedback here since my issue deals with this.

First off, I'm able to search, so when I long press on the album, I get results and can see album covers to select.  
I read Max's response about the servers and the ability to actually download the covers, so I'll give that some time.
However, I'm still having a problem setting album art.  I thought I'd do a test.  I long pressed the album cover and pick from a couple of album covers
 have saved in my gallery.  When I do this, I still am not seeing the album art change.  The images are ones that I use for other albums on my phone
so I know they aren't to big.  This happens in both folder mode and playlist mode.

Phone: Samsung, Note 4, running Android 5.0.1

Share this post


Link to post
Share on other sites

Which audio output is generally preferred- Audiotrack or OpenSL ES?
Is there any difference in audio quality, or are they only different due to device support?

Share this post


Link to post
Share on other sites
13 hours ago, CruzerX said:

miss typo in sample rate 44.1>41.1

tmp_9973-Screenshot_2016-03-23-17-14-431389054876.png

Hey, am I reading this right? You've enabled Hi-Res output for the Bluetooth? How?

6 hours ago, JimJamz said:

Hey there, Max. Just made an account today after using Poweramp for over a year.
Thanks for all the awesomeness. But I'm here for another reason.

I'm currently using a OnePlus One.
http://www.gsmarena.com/oneplus_one-6327.php

The OPO is running Sultan's CM13 ROM.
http://forum.xda-developers.com/oneplus-one/orig-development/rom-kernel-unofficial-cyanogenmod-13-0-t3242700

I'm on the latest Poweramp alpha-701 and going into Audio Output, I can see the experimental high-res output setting. However, upon activating it for the headset, I get a failed popup. If I recall correctly, the OPO should natively support 24bit 96/192khz output thanks to using the same audio chip the LG G2 uses. If you have the time to help me on this, it'd be much appreciated. Thanks!

Probably the ROM, I am using Resurrection Remix (Android 6.0) with my OPO and it's working, Variant Snapdragon 24-bit PCM, although when listening to ordinary VBR MP3s the sound is actually worse, it's quieter, narrower and quite a bit distorted. Not sure if it's the MP3, the EQ I have set or simply bad compatibility...

Share this post


Link to post
Share on other sites
6 minutes ago, Feilakas said:

Probably the ROM, I am using Resurection Remix (Android 6.0) with my OPO and it's working, Variant Snapdragon 24-bit PCM, although when listening to ordinary VBR MP3s the sound is actually worse, it's quieter, narrower and quite a bit distorted. Not sure if it's the MP3, the EQ I have set or simply bad compatibility...

Dang. If it really is the ROM's issue, then I hope there'd be something I could change myself to allow hi-res output to work, since I really like staying on Sultan's ROM.
Plus, I've had to clean flash at least 3 times this week and I'm just too exhausted to move to another ROM.

But thanks for confirming that the OPO is able to output 24bit on the hardware side.

Share this post


Link to post
Share on other sites
2 hours ago, JimJamz said:

Which audio output is generally preferred- Audiotrack or OpenSL ES?
Is there any difference in audio quality, or are they only different due to device support?

For non Hi-Res: OpenSL for everything except USB DAC. If any issues - AudioTrack then - it's a bit more stable, but that is what really depends on device/ROM.

Share this post


Link to post
Share on other sites
13 hours ago, maxmp said:

Note4 (latest OTA ROM) is fully supported by Poweramp alpha2, we tested on that device with sample rates up to 192khz. Though, my ROM can be different (Samsung ROMs are varied by world regions and other factors). I would suggest changing buffering for Hi-Res output - e.g. increase number of buffers to 3-4 and check if this helps.

Checked. No luck there. Still those knocking sounds. Maybe because I'm using custom ROM? Though the custom ROM itself is based on my model's (N910S) latest OTA and I doubt they changed the drivers. If it is indeed ROM poblem, I have to say I'd wait for Marshmallow rather than changing to stock ROM now :)

Share this post


Link to post
Share on other sites

Poweramp alpha2 build-702

This build fixes issues reported today for 701:

- some non-english tags are better handled for mp3

- non-rectangular embed art is handled properly in notification

- fixed album art when playing Playlists and Queue

- dsf files should be played without extra click between them

- resume after bt call is adjusted a bit 

- issue with MusicFX button should be resolved now

- typos fixed

- eq preset assignment for usb/other outputs

Share this post


Link to post
Share on other sites

Just tested the latest build on Note 5 and Nexus 7 (2013) both using stock 5.1.1 rom and connected to Fioo E10K USB DAC (supports up to 24bit/96Khz playback), my findings are:

On Nexus 7 + Fioo e10K I can enable the hi res audio playback, but only  at 24 bit 48Khz, playback without any problem.

On Note 5 + Fioo e10K I also able to enable the hi-res audio playback thru usb audio, but at 24 bit 192Khz (which also odd, the DAC should not support that rate, although it playback fine) 

Btw, is it possible to enable bit perfect audio playback without any resampling? eg playingg 16 bit 44.1Khz will send to the DAC untouched.. and playing back 24bit 96K will also do the same

Share this post


Link to post
Share on other sites
On 3/23/2016 at 10:45 AM, Hoàng Khanh said:

Iam using Sony Xperia Z3,When active Hi-Res option,it says failed.Can anyone help me ?

Screenshot_2016-03-23-10-41-47.png

It happens when Iam using Sony Xperia Z3 Lollipop 5.0.2 but i when i enable DVC,It works :D.but when i update to Lollipop 5.1.1,I can't see "Wired Headset" option in Hi-res option :(

Share this post


Link to post
Share on other sites
4 hours ago, Feilakas said:

Hey, am I reading this right? You've enabled Hi-Res output for the Bluetooth? How?

Probably the ROM, I am using Resurrection Remix (Android 6.0) with my OPO and it's working, Variant Snapdragon 24-bit PCM, although when listening to ordinary VBR MP3s the sound is actually worse, it's quieter, narrower and quite a bit distorted. Not sure if it's the MP3, the EQ I have set or simply bad compatibility...

how u get the screen ? i m with lg v10 

Share this post


Link to post
Share on other sites

Still getting the "decoder timed out" message with the song stopping now and again.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.