Jump to content
griff

Poweramp in Android Auto and Volume Dipping on Notifications

Recommended Posts

Hi all. 

Just curious who else is using Poweramp in Android Auto, and has Android 9 on their smartphone? I ask because I recently got a new phone (LG G8s ThinQ) and it runs Android 9. Previously I was using an LG V20 which was running Android 7. Now with the new phone I am getting these super annoying volume dips during music playback in Android Auto. I am certain it's not a Poweramp bug, but an Android 9 (or maybe 😎 thing. My wife is also on Android 9 and uses Android Auto in her car, but doesn't use Poweramp (she uses Google Play Music) and she gets the annoying volume dips during music too. These volume dips only happen when the phone gets a notification (message, email, reminder, etc). Here's a video of the issue occurring.

I've googled the issue and found very, very little. One solution was to install an automation app and then with it create a recipe which will put the phone into DND (Do Not Disturb) mode during music play. Yeah, that works, but it's a band-aid fix IMO. Now you have an extra app running, another notification running, ugh... So either people are not noticing this volume dip issue, or just putting up with it. Cos the volume does return back to the level it was on in about a second. But it is still ridiculously annoying. IMO most people using Poweramp won't just put up with this kind of BS, so I've decided to post here to see if anyone can shed light on this, and hopefully provide a solution!

EDIT: I am aware Poweramp has a feature in Settings > Audio > Audio Focus, called Short Audio Focus Change / Calls. And in the same Audio Focus settings there's one called Duck Volume. When I have these disabled I simply get the system notification sound playing over the music. So this wasn't a solution either. But it might be my best option? The annoying thing is on my old phone running Android 7 I didn't have to disable these settings. Music playback was simply never interrupted with volume dips! 

Share this post


Link to post
Share on other sites

Thanks for the detailed issue description. 

Does this happen for stock (or any other) player? If it does,  it’s some system level feature/bug/option. Poweramp just receives system message and reacts accordingly: it pauses, ducks volume, or does nothing.
In Poweramp this is controlled via: Audio / Audio Focus options and per specific Audio / Output / <active output> / <active device> / No Duck option, which forces “pause” behavior.

Also, if you’re using hi-res output, try to use standard definition outputs (AudioTrack / OpenSL).

Share this post


Link to post
Share on other sites
4 hours ago, maxmp said:

Thanks for the detailed issue description. 

Does this happen for stock (or any other) player? If it does,  it’s some system level feature/bug/option. Poweramp just receives system message and reacts accordingly: it pauses, ducks volume, or does nothing.
In Poweramp this is controlled via: Audio / Audio Focus options and per specific Audio / Output / <active output> / <active device> / No Duck option, which forces “pause” behavior.

Also, if you’re using hi-res output, try to use standard definition outputs (AudioTrack / OpenSL).

@maxmp is there a way to put an option to ignore the duck request, with no pause and no notification sound when PA is playing? I think this is the option that several people are looking for, including myself. I would still like to see the notification pop-up, and the sound would be acceptable, but only if PA is not currently playing. Basically a "No Duck + No Pause + Suppress System Sound" option.

Share this post


Link to post
Share on other sites

Hi Max, thanks heaps for replying! 

9 hours ago, maxmp said:

Thanks for the detailed issue description. 

Does this happen for stock (or any other) player? If it does,  it’s some system level feature/bug/option. Poweramp just receives system message and reacts accordingly: it pauses, ducks volume, or does nothing.
In Poweramp this is controlled via: Audio / Audio Focus options and per specific Audio / Output / <active output> / <active device> / No Duck option, which forces “pause” behavior.

Also, if you’re using hi-res output, try to use standard definition outputs (AudioTrack / OpenSL).

I've just tried with the stock LG music player, and yes, it also gets a volume dip when a message comes in. And as far as I can see there's no option or setting to disable this, unlike Poweramp (go Poweramp!). So that tells us this is an Android system thing right? Android 9 at least. 

I've gone back into Poweramp Settings and disabled Short Audio Focus Change / Calls and Duck Volume (had to disable this one first). This might be the best solution. I tried having just Duck Volume disabled, but Poweramp won't allow it. 

I'm not using hi-res output, Poweramp is set to OpenSL ES Output. 

7 hours ago, MotleyG said:

@maxmp is there a way to put an option to ignore the duck request, with no pause and no notification sound when PA is playing? I think this is the option that several people are looking for, including myself. I would still like to see the notification pop-up, and the sound would be acceptable, but only if PA is not currently playing. Basically a "No Duck + No Pause + Suppress System Sound" option.

I def need the music to pause when a call comes through. Glad that is a separate option in Poweramp! Regarding notifications though... messages, emails, other alerts, it is not necessary to pause the music. But yes, we don't want the music to duck! 

Share this post


Link to post
Share on other sites

Just did another test... I ensured the above mentioned settings are DISABLED (Short Audio Focus Change / Calls) and (Duck Volume), played some music and had my wife message me. The music did not dip / duck, BUT there was an ever so subtle interruption to the music playback. Might be worth looking into. This might be as good as it gets for now though... 

Share this post


Link to post
Share on other sites
On 5/11/2020 at 4:24 PM, maxmp said:

Unchecking Short Audio Focus in Settings / Audio / Audio Focus should do that.

I've done this, and the focus does not change now. However the notification sound from the system still happens as well, mixed into the music that is playing. Is there a way to disable the system sounds while PA is playing?

Share this post


Link to post
Share on other sites
21 hours ago, MotleyG said:

I've done this, and the focus does not change now. However the notification sound from the system still happens as well, mixed into the music that is playing. Is there a way to disable the system sounds while PA is playing?

What version of Android are you running? I'm running 9. 

Share this post


Link to post
Share on other sites
26 minutes ago, griff said:

What version of Android are you running? I'm running 9.

Android 10, running stock on LG G8thinQ. I don't mind the notification sounds when music isn't playing or if PA is not running even. But when playing music I'd prefer to not hear the notifications.

BTW - this happens through the headphone and USB outputs. So even when listening at home on my USB-DAC the notifications are noticeable. I don't use the built-in speaker too often, so I haven't noticed it there.

Share this post


Link to post
Share on other sites
On 6/15/2020 at 11:19 PM, MotleyG said:

Android 10, running stock on LG G8thinQ. I don't mind the notification sounds when music isn't playing or if PA is not running even. But when playing music I'd prefer to not hear the notifications.

BTW - this happens through the headphone and USB outputs. So even when listening at home on my USB-DAC the notifications are noticeable. I don't use the built-in speaker too often, so I haven't noticed it there.

I'm on Android 9, running stock on LG G8s ThinQ. I'm in the same boat as you, I don't mind the notifications if the phone is NOT in DND mode, or if Poweramp is running. BUT when Poweramp is playing music, there should be no interruptions to the music. 

I listen to music with my phone (using Poweramp of course) with wired headphones, in the car via Android Auto with either USB or Bluetooth (it's not clear to me which AA uses) and when at work with Bluetooth headphones. I need to do more testing because the wired headphones is at night when I'm in bed so I have DND running, and thus no notifications are heard. And when I'm at work I put my phone into vibrate only mode. 

Share this post


Link to post
Share on other sites

I'm no expert in this area (I'm sure @maxmp will know though) but with all the newer Android security rules, do individual apps even have the ability to disable and enable a device's Global notification settings?

Andre

Share this post


Link to post
Share on other sites

Been doing some tests while at work today. Didn't put my phone in vibrate mode like I normally do and started listening to music. Both with wired and Bluetooth headphones (separately, of course). Got several Gmail emails and Facebook Messenger messages while listening to music and all of them forced the music to dip or pause so I could hear the notification alert. Bloody ridiculous! I'm annoyed at this, but to be clear not at Poweramp in any way. I am certain the culprit is Android (cos this wasn't an issue on my old phone which was running Android 7 - I'm currently on 9). 

Now I'm double checking my Poweramp settings, and in Settings > Headset / Bluetooth > Audio Focus: I have Short Audio Focus Change / Calls ENABLED. The notes for this shows this factors calls, notifications, navigation, etc). I am thinking this needs to be specifically just for calls? And then what if we had a setting like this but just for notifications, etc? My reasoning is this: While working I can listen to music and I don't need to be bothered / interrupted by sounds for emails, messages, etc, but a phone call is usually important. So that's ok to be interrupted. 

FYI the two other settings in Audio Focus, Duck Volume and Permanent Audio Focus Change are DISABLED. 

Share this post


Link to post
Share on other sites
11 hours ago, griff said:

Now I'm double checking my Poweramp settings, and in Settings > Headset / Bluetooth > Audio Focus: I have Short Audio Focus Change / Calls ENABLED. The notes for this shows this factors calls, notifications, navigation, etc). I am thinking this needs to be specifically just for calls? And then what if we had a setting like this but just for notifications, etc? My reasoning is this: While working I can listen to music and I don't need to be bothered / interrupted by sounds for emails, messages, etc, but a phone call is usually important. So that's ok to be interrupted. 

FYI the two other settings in Audio Focus, Duck Volume and Permanent Audio Focus Change are DISABLED. 

I have the same features enable/disabled. The only change from older versions of Android is that the notification sounds now happen, just without PA ducking. So I agree that this is a change to the Android OS, and so far I have had no luck finding any OS feature that changes this behavior. So unless there is some way that PA can intercept the notification and block the sound, I guess there is no other solution. Definitely not a PA problem, but if there is a way around it, that would be great!

Share this post


Link to post
Share on other sites

You could launch PA as part of a task in something like Tasker or even things like Bixby Routines on Samsung devices. It would be a specific setting for while PA was running though, it would not alter depending on playback status. [Actually, thinking about it, that must mean that apps can indeed control global Notification volume settings]

Andre

Share this post


Link to post
Share on other sites

While looking into this a few weeks back, I found these set of instructions: https://www.guidingtech.com/disable-android-notifications-playing-music/

Basically you need to install an app like Tasker (it's called Macrodroid) to put the phone into DND mode during music playback. I tried it and it added it's own tiny glitches / split second of music being cut or something similar so I aborted that idea. But to me, it's a bandaid solution. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...