Jump to content
Poweramp
jaffab

Bug - Playlist sorting no longer rememebered

Recommended Posts

I have to say first off, I am NOT a fan of the new Poweramp.  There was nothing wrong with the old software.  If it isn’t broke, why fix (or in this case, break) it?

So having spent a few days with it, I notice that the playlist settings are very broken.

In the old system, I could reorder it with ease, and it stuck with that ordering.  Now, it seems to do what it wants.

Under old system – goto folders, select a folder, add to playlist.  Go to playlists, find play list, select it, select options, resort, sort by album, click playlist – it starts playing, in album order.  And it sticks to this order.

Under new system - goto folders, select a folder, add to playlist.  Go to playlists, find play list, select it, select options, resort, sort by album, click playlist – it starts playing, in album order. 

BUT, whilst the initial playing is in TRUE album order, if the playback is paused (say you turn off Bluetooth speaker, headset or switch off connected car), when it starts again, the order is changed and seems to have changed but takes off either numeric parts of albums, or is sorting it in track order, or is random.

So an album of “21 dreams” now seems to be sorted with the other “d” albums (not at the front).    Not sure what the order is, but it is no longer in the true album order first selected.

Share this post


Link to post
Share on other sites

I have also witnessed a similar behaviour.

I am mostly selecting "Repeat List" and "Shuffle Songs", so I should be kept in an endless loop of the same list in shuffled order.

If I select an artist A, listen to it and disconnect my head phones, the music pauses as expected. When I reconnect them it resumes as configured, but as soon as the song is finished, either a random artist, or the next list will be started and eventually a song becomes stuck on 0:00 and the UI becomes unresponsive: Pause, Next/Previous track/list doesn't work. Navigating to another list works, but I cannot select any other song anywhere. I have to unplug my head phones, force stop Poweramp and start it again, connect my head phones and then every other time it crashes seconds after I plug in my head phones, going back to normal working order after the crash.

The same behaviour happens when I am listening to playlists instead of artists: Listen to playlist A, unplug head phones, plug in head phones, song of playlist A finishes and it goes to some other playlist until the app becomes partly unresponsive (song selection, both selecting a song or the play/shuffle buttons inside a list; play/pause, etc.)

Currently I'm abusing the queue as my playlist, as I haven't had such issues with that. It's just cumbersome clearing the queue and adding whatever I want to listen to everytime.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...