Jump to content
Poweramp
Sign in to follow this  
AkashS04

Extreme Bass Preset Breaks Earbuds

Recommended Posts

I am using Poweramp for almost 10 months. I use Extreme Bass Preset with Amp Level High (60%) and 100% Bass and Treble and I noticed that couple of my earbuds are spoiled or broken down. Either one of the speakers not working or speaker membrane spoilt and having torn sound in one speaker. Can any one pls sugggest if that could be the reason and if Developer can work on this so even extreme settings will not break down the earbuds. Or using High Impedence earbud will work?

Share this post


Link to post
Share on other sites

Man what earphones were you using..??

And doing that kind of extreme sound tuning will not only break your hardware..(amp at 60%..??) But destroy the hearing experience.

Yes the App maybe the reason why that happened due to your tuning setup.

Share this post


Link to post
Share on other sites

I agree, it's rather like complaining that your car tyres wear out more quickly if you constantly drive your car at 100mph and always brake violently rather than driving sensibly. If you choose to overdrive your audio equipment, you could break it. The same applies to your ears by the way.

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...