Jump to content

Bluetooth headset buttons completely unresponsive

Recommended Posts

I have Poweramp 2.0.10 build-588 (the latest version of Poweramp 2 available on Google Play) installed on my Moto G 2015 running stock Marshmallow (I believe fully updated as well). My bluetooth headset is an Audio Technica AT-PHA50BT (listed on their site as a bluetooth amp) with apt-x support, with the usual three-button playback setup (previous, play/pause, next). After my bluetooth headset is connected to my phone, music playback is ok, and of course I can control playback on my phone, but the bluetooth buttons are completely unresponsive — even play/pause doesn't work! Yet all three buttons work when I play music and video on Spotify and VLC. As sort of a last resort, I've tried resetting Poweramp entirely (going to Android system preferences -> apps and clearing the app's storage), but to no avail. 

I also have an Asus Zenwatch 2 (an Android Wear smartwatch) connected to my phone at all times, and music control (play/pause, previous, next, volume up/down) from the watch doesn't work as well, so I'm guessing it's an issue with the way Poweramp is communicating with Android's bluetooth A2DP service? I've tried resetting just about everything (headset, watch, Poweramp, everything short of a hard reset of the phone itself, although I don't see why I'd need to do that since I got it fresh just a few days ago), and playback controls still don't work at all. Please help.


EDIT: I might add that my previous phone was a Sony Xperia Z3 Compact, which I had for about a year and a half, and bluetooth playback control used to work properly but suddenly just stopped working about three months ago, I have no idea why, but I never tried troubleshooting the problem. Also, I acquired my headset before I bought my smartwatch, and these two had no issue regarding playback control for about half a year, but suddenly bluetooth playback control both stopped working for no apparent reason (music still played ok through the headset, it's just that I have to pull out my phone to control anything)

Link to comment
Share on other sites

  • 5 months later...

Android updates regularly seem to break random features (it's a case of moving goalposts) and Max has been concentrating on the new interface work for v3 so hasn't revisited the old release build for a while. I can't say for certain, but I suspect fixes will probably occur via the newer v3 fork rather than the old v2 build.


Link to comment
Share on other sites

  • 3 weeks later...

NooB here but I've been using Poweramp for years.  Best Android Player by far IMO.

Anyway I got some BOSE SoundSport Bluetooth earbuds for Christmas.  They sound amazing BTW.  I too am having problems with the headphone buttons working.  

Poweramp version 2.0.10-build-588-play (full version).  My phone is an HTC M8 (AT&T) running Android 6.0 6.20.502.5  HTC Sense 7.0 

They work sometimes and sometimes they don't.  I've tried everything!!!!

Help and thanks!!!!

Link to comment
Share on other sites

  • 2 months later...

I've had this problem since last year and have been searching for a solution since then.

Poweramp seems to lose BT control input priority permanently when you open an application which also has BT controlled functions (play, pause, next, prev) like YouTube or Smart Audiobook Player.

The only fix I could find was to either reboot the phone (not practical in the least) or go into settings in Poweramp and untick and retick "react to buttons" under bluetooth settings.

Today I finally installed the v3 alpha and it seems to mostly have fixed the problem

Link to comment
Share on other sites

  • 6 months later...


This topic is now archived and is closed to further replies.

  • Create New...