Jump to content

Poweramp doesn't add opus file in library but plays them.


Sjokoladekake
 Share

Recommended Posts

I wanted to switch from samsung music to Poweramp.
Most of my files are opus encoded in a .oga file. I converted them from flac with free:ac and never had a problem.
As I said in the title, Poweramp doesn't add in the library any of those file, but when I go into my file explorer, and open them with it, it plays them fine.
I already disabled the "ignore short tracks" feature but it didn't changed anything.
I don't know where to ask, so I ask here, is it a bug or something I do wrong ?

Sorry for my English, and thanks in advance.
 

Link to comment
Share on other sites

I assume the scanner code is not configured to detect that particular file extension, although the decoder engine can cope with the data contents and thus PA can play the file directly. It ought to just be a case of Max adding the .oga extender to the valid list for the scanner. To confirm this, try changing the extender of one file to something PA knows and see if it gets picked up on the next scan.

[Edit: I just did a test, and for me the PA scanner picks up OGG files with either .oga or .ogg extenders. Perhaps there is something amiss with the Vorbis tag metadata in your files?]

Andre

Link to comment
Share on other sites

The .oga extension works fine for me when I tested it. (I copied the same file as .ogg and .oga and both were scanned into the library). What version of Poweramp are you using? It might be worth trying a FULL Rescan (in Settings > Library) in case any scans took place before the files had finished copying over to your device.

Andre

Link to comment
Share on other sites

So, I did the full rescan but it still didn't work, so I took a few screenshots this time.

First, I put 2 tracks of a same album in the same folder and I renamed only one in .oga: (https://imgur.com/a/brxlDeu)
Then, I selected only this folder on Poweramp : (https://imgur.com/a/iHlGTSZ) (I erased one folder name because it contained personal info)
And, only the .ogg renamed one showed up on the app (https://imgur.com/a/pGS647q)

I noticed that it showed up as an ogg file (next to the length) whereas if I played the .oga file with PA through my file explorer, it would show up as a opus file.

Do you have any ideas on how to solve this ?
And again, many thanks for your help !

Link to comment
Share on other sites

What does the Library > Folders view show? You should see one folder which has two song files in it. Otherwise, try copying the SAME file twice (ideally the song that worked before), but with one copy named as .oga and the other named as .ogg. Again, Full Rescan to avoid any old data still being present. I'm assuming you are using the latest Poweramp release, build 893.

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...