Jump to content

Poweramp auto start when bluetooth connected


Vee

Recommended Posts

I have Poweramp that was force stopped and did not open it in my phone.

I connect my phone Bluetooth with my car and when it connected Poweramp just auto start the app and play the audio.

I did not ask to do that, I just want to connected the Bluetooth and choose the music player app myself. (because Poweramp did not support single play audio file).

 

Link to comment
Share on other sites

It is already disabled. Almost everything about Bluetooth was disabled.
This never happens before (as I remember, until last week).

I was just reset everything about Poweramp so, I cannot see any command now. I'll try again tomorrow.

Link to comment
Share on other sites

Quote

==================
10:05:11.830 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_DOWN name=AVRCP source=0x101 virt=false repeat=0 actionTime=598402602 isAvrcp IGNORED isNotButtonPress=false enable_headset_controls=false
==================
10:05:11.833 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_UP name=AVRCP source=0x101 virt=false repeat=0 actionTime=598402633 isAvrcp IGNORED isNotButtonPress=false enable_headset_controls=false
 

This never happens until ...(I'm not sure the exact date) last week.

I force stopped Poweramp + Full version unlocker. Clear all opened apps.
Connect smart phone with car bluetooth > push on aux button (to switch to bluetooth audio).

What happened before is nothing happen, I can open music player of my choice (which is supported single play one track and end). 👍

What happened now is Poweramp open itself and I have to close it then I can control car audio with my app. 👎 👎 👎

Resume on Bluetooth was disabled but it does not help.

Link to comment
Share on other sites

  • 1 year later...
5 hours ago, NewZed said:

Why has this problem never been addressed? 

It has been addressed multiple times. There are options to control this action in Settings > Headset/Bluetooth.

However sometimes the external headset or car stereo is the culprit, issuing a MEDIA_PLAY (or MEDIA_PLAY_PAUSE) event when it connects, which PA responds correctly to. To see if this is the case for you, after this issue occurs take a look at Settings > Headset/Bluetooth > Last Processed Commands and post the results here.

Andre

Link to comment
Share on other sites

  • 1 year later...

@andrewilley I'm experiencing the same issue as above. Whenever I turn on my car the radio connects vua Bluetooth and automatically opens PA and resumes my last played song. I don't want this. I've read your other forum responses to people with that same issue. I've disabled and renabled all those settings. No change. I'm wondering if the culprit is my stereo unit doing this. You mentuoned the way to find that out was to go to: Settings > Headset/Bluetooth > Last Processed Commands and post the results here.

 

Here are my results. Please let me know what you think can be done to stop this from occuring....

 

Many thanks

 

==================
17:12:11.074 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_DOWN name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=90720466 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=0
==================
17:12:11.110 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_UP name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=90720502 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=0
==================
17:12:11.383 PlayerService RESUME
from PSMediaButtonReceiver resumePlaying 
==================
17:12:11.383 PlayerService RESUME
from PSMediaButtonReceiver IGNORED
==================
17:12:17.717 HeadsetPlugReceiver headset event
disconnection BT=false am mode=0 no_keep_notif_on_dscn=false
==================
17:12:18.834 BTReceiver headset event
connection BT=true am mode=0 BOSS 616UAB
==================
17:12:20.640 BTReceiver headset event
disconnection BT=true am mode=0 BOSS 616UAB no_keep_notif_on_dscn=false
==================
17:12:20.869 PlayerService onRoutingChanged
newDevice=speaker oldDevice=bt
==================
17:12:20.869 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=1
==================
17:12:23.044 PlayerService TOGGLE_PLAY_PAUSE
from NotificationHelperViaBuilder pausePlaying 
==================
17:12:24.439 PlayerService STOP_SERVICE
from NotificationHelperViaBuilder 
==================
17:16:07.849 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_DOWN name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=90957230 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=2
==================
17:16:07.881 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_UP name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=90957273 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=2
==================
17:16:08.165 PlayerService RESUME
from PSMediaButtonReceiver resumePlaying 
==================
17:16:08.165 PlayerService RESUME
from PSMediaButtonReceiver IGNORED
==================
17:16:15.306 BTReceiver headset event
connection BT=true am mode=0 BOSS 616UAB
==================
17:16:16.979 PlayerService TOGGLE_PLAY_PAUSE
from NotificationHelperViaBuilder pausePlaying 
==================
17:16:17.668 PlayerService STOP_SERVICE
from NotificationHelperViaBuilder 
==================
17:16:49.645 HeadsetPlugReceiver headset event
disconnection BT=false am mode=0 no_keep_notif_on_dscn=false
==================
17:17:00.407 BTReceiver headset event
disconnection BT=true am mode=0 BOSS 616UAB no_keep_notif_on_dscn=false
 

Link to comment
Share on other sites

There seem to be a lot of events occurring during connection which @maxmp would be able to diagnose better then me, but could you confirm that you did not press the Play button at the following point, as the log is saying that PA received a Play comment from the Bluetooth device:

17:16:07.849 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_DOWN name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=90957230 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=2
==================
17:16:07.881 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_UP name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=90957273 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=2

Andre

Link to comment
Share on other sites

On 2/23/2022 at 2:25 AM, krazzyvishal said:

I've found the culprit that caused the same issue with me. It was Poweramp Equalizer app which had the same setting turned on.

I'd been wondering why my Android Auto system had recently started exhibiting this auto-starting issue too, and when I checked the commands log I noticed a MEDIA_PLAY button event was being issued about 15 seconds after everything else had connected, but it was assigned from com.maxmpz.equalizer :

18:28:55.062 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_DOWN name=Virtual source=0x301 virt=true repeat=0 actionTime=182391645 sourcePak=com.maxmpz.equalizer flags=0x540 playerState=2
==================
18:28:55.075 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_UP name=Virtual source=0x301 virt=true repeat=0 actionTime=182391648 sourcePak=com.maxmpz.equalizer flags=0x540 playerState=2

I checked the stand-alone PA-EQ app, and it had indeed activated this feature for some reason - and the fact that the main EQ functionality is disabled does not seem to prevent the auto-play mode from triggering. If this has started affecting anyone else, go into the Poweramp Equalizer app and in Settings > Utils you should turn OFF these top two items:

image.png

Andre

Link to comment
Share on other sites

  • 10 months later...

 I'm still having this issue. I'm on Pixel 7 with Sony xm4's. I have both options on both apps (player and eq) turned off.

I get the following commands (though I don't really know how to read them), and I don't press anything when I connecg the headphones. It happens only with Poweramp so I doubt it's somethin my headphones are sending.

Screenshot-20230114-002432.png

Link to comment
Share on other sites

@roeezzz Poweramp is apparently receiving a button-press event KEYCODE_MEDIA_PLAY via Android, which it is responding correctly to. Looks like it's coming from com.android.nfc, though I don't know why the NFC service would be doing that. Do you have an NFC management app set to trigger on BT connection for some reason?

Andre

Link to comment
Share on other sites

It means something in the NFC system that you are using is sending a KEYCODE_MEDIA_PLAY event to tell the current media software to start playing (a BUTTON_DOWN instance followed a few milliseconds later by a BUTTON_UP - so a simulation of a press and release interaction). Poweramp is correctly responding to that command by starting playback. You could prevent that from happening by disabling PA Settings=>Headset/Bluetooth=>Respond to Buttons, but that would mean you would not be able to use any other button functionality that the headset might offer either. 

@maxmp The button event does seem to be arriving very soon after the remote device has connected, I thought such commands were meant to be ignored for the first few seconds? Is it perhaps the fact that it is coming from the NFC module rather than from the headset directly that could be causing this?

Andre

Link to comment
Share on other sites

on ANDROID AUTO OPTIONS/CONFIGS, just disable "START/PLAY MUSIC AUTOMATICALLY". Aparently my problem is solved. PS: this was happpening even when headphones were connected in the usb port, and bluetooth devices too. 

MOTO EDGE 20 PRO and MOTO EDGE 30 ULTRA here. I hope it helps anyone else. 

Link to comment
Share on other sites

22 hours ago, mOuStAcHe_BR said:

on ANDROID AUTO OPTIONS/CONFIGS, just disable "START/PLAY MUSIC AUTOMATICALLY". Aparently my problem is solved. PS: this was happpening even when headphones were connected in the usb port, and bluetooth devices too. 

MOTO EDGE 20 PRO and MOTO EDGE 30 ULTRA here. I hope it helps anyone else. 

UPDATE: unfortunatelly, the autostart problem is back again. Trying to disable AD2P HARDWARE on development options on android 12. I will update if it works. 

Link to comment
Share on other sites

@mOuStAcHe_BR Have a look in Settings=>Headset/Bluetooth=>Last Processed Commands to see if a KEYCODE_MEDIA_PLAY or KEYCODE_MEDIA_PLAY_PAUSE event is being issued by the BT device (often Android Auto sends its media and commands via Bluetooth, even when a USB cable is plugged in). You can stop PA responding to that for testing purposes using the Button options in the same menu.

Andre

Link to comment
Share on other sites

1 hour ago, andrewilley said:

@mOuStAcHe_BR Have a look in Settings=>Headset/Bluetooth=>Last Processed Commands to see if a KEYCODE_MEDIA_PLAY or KEYCODE_MEDIA_PLAY_PAUSE event is being issued by the BT device (often Android Auto sends its media and commands via Bluetooth, even when a USB cable is plugged in). You can stop PA responding to that for testing purposes using the Button options in the same menu.

Andre

Andre, now I don't know what prevents the autoplay command but right now the issue seems to be there again. The button option is still enabled as I need to keep the car media controls functional.

What I did was install greenefy, change this settings on development options on Android 12. 

The only action that prevents the issue is killing/force stop PA on Android. 

 

Follow the processed command line


==================
11:41:05.998 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
11:41:05.998 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
11:41:06.443 BTReceiver headset event
connection BT=true am mode=0 Audi MMI 2002
==================
11:41:06.898 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
11:41:07.502 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
11:41:09.371 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PAUSE ACTION_DOWN name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=27796822 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=2
==================
11:41:09.399 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PAUSE ACTION_UP name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=27796851 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=2
==================
11:41:09.740 PSMediaButtonReceiver android.intent.action.MEDIA_BUTTON
KEYCODE_MEDIA_PLAY ACTION_DOWN name=Virtual source=0x0 sources=0x301 virt=true repeat=0 actionTime=27797191 sourcePak=com.android.bluetooth isAvrcp  flags=0x0 playerState=2
==================
11:41:09.746 PlayerService RESUME
from PSMediaButtonReceiver resumePlaying 
 

 

 

Screenshot_20230120-113608.png

Screenshot_20230120-113538.png

Screenshot_20230120-113938.png

Link to comment
Share on other sites

  • 1 month later...

@mOuStAcHe_BR Hi, if you are still having the issue, you need an app like Tasker to stop the playback.

Disabling the button controls in Poweramp works in some cars, but then you lose the media keys on your steering wheel for example (next/prev) or the touch display so not the best solution.

 

To get the best of both worlds, an app like Tasker can intercept the play media request from the car.

I followed this video a few hours ago and it worked. I struggled with this issue for a long time as well.

 

@andrewilley I wonder if the Tasker approach can be implemented in Poweramp directly so we will not need a third-party app. Anyway, it works, so it is just a "could be nice to have" thing.

Edited by mirko77
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...