Jump to content
Poweramp
Endymion86

Metadata not displaying on car HUD with Galaxy S8?

Recommended Posts

Hey guys! I recently got a new phone (Samsung Galaxy S8), and metadata like artist name, album name, song title, etc no longer displays on my car (2012 Mazda 3)'s heads-up display. It has worked perfectly fine before this on my last phone (LG G4). 


Music plays just fine, it's just that the metadata doesn't display.
 
I realize this is most likely an issue with the phone itself using a different version of bluetooth compared to my last phone, but since you guys are the gurus when it comes to troubleshooting this kind of stuff... is there any chance you can look into it, and see if it'd be an easy fix to implement in Poweramp (v2 or v3, I've tried it on both) itself? Like, maybe a toggle-able option to make Poweramp force the phone to transmit metadata the old way so that it'll display in situations like this?
 
Just an idea. Not sure who else to contact/ask.

Share this post


Link to post
Share on other sites

Yup, there are three options under "bluetooth metadata" in the settings menu, and I've tried toggling all three options, and no artist/track info has shown up on my car's HUD. The options are:

 

1) Metachanged Intent

2) CyanogenMod Metachanged Intent

3) Send Album - Artist with Metachanged Intent

 

None of these have solved the problem, unfortunately. I have a feeling that it has less to do with Poweramp , and more to do with the actual bluetooth AVRCP being sent from the galaxy S8, but if there's a chance it can be something that Poweramp can fix on its end, that'd be perfect (considering the same app worked fine and transmitted metadata correctly on a different phone, and LG G4).

Share this post


Link to post
Share on other sites

Once max has got Poweramp V3 to market, hopefully he'll be able to return to these old niggle issues that have been around for years.

Andre

Share this post


Link to post
Share on other sites

I'm having the same issue. Also involving a Mazda 3. Now, I'd discard the 'Bluetooth 5.0' explanation, as the OnePlus 5 also has Bluetooth 5.0, and I had no issues with that one. I'm certain this is Samsung's OS screwing something up. 

Share this post


Link to post
Share on other sites

I'm not sure, after Oreo, I kept losing bluetooth and 1+ recommended a "hard wipe". I don't know what buttons to push to bring it back. All I get now is connection and volume (no next song,  or previous) haven't used phone,  hands free yet. 

Share this post


Link to post
Share on other sites

With Oreo, many people are reporting no track controls or metadata via their bluetooth devices, so I don't think a hard-wipe of the device will help. I think it will need some code in Poweramp updating (this applies to both the v3 alphas and the main release). 

Andre

Share this post


Link to post
Share on other sites

So I have this issue with my vehicle, displays no artist no title. Metadata settings do nothing. I use my other music app called GOM player and the info shows in my car. I like Poweramp but this is frustrating so I'll have to go back to using my other player. Anyone have a fix yet for this? I'm using oreo 8.1 on a Google pixel. 

Share this post


Link to post
Share on other sites

I had this issue with my S8 and my BMW 3 series 2014...  Music played fine but no song name or album info was displayed.  I fixed it by upgrading the car audio software version with a USB and a file I downloaded from BMW site.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×