Jump to content

Shuffle mode keeps turning off and Repeat keeps turning on


Byron

Recommended Posts

Build 976, Pixel 7, Android 14

I mainly use Poweramp for playing music in my car via Bluetooth.

Everyday and sometimes multiple times a day shuffle will turn off and repeat will turn on.
Each time I turn repeat off and shuffle on but at some point after this it resets and shuffle turns off and repeat turns on. I think there may've been a time or two where shuffle was off but repeat wasn't on.
I originally was curious if it could be a problem with the phone being in my pocket and accidentally pressing buttons, but I have now ruled that out as I've removed the buttons from the notification interface and it still happens.

Passionate Poweramp supporter here. Hope you can help me resolve this real annoyance.

Link to comment
Share on other sites

  • Replies 54
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Does this only occur when Bluetooth is connected to your car, or during local playback too? If BT only, it might be worth looking in Settings=>Headset/Bluetooth=>Last Processed Commands in case anything odd is being sent by the headunit via the AVRCP Bluetooth command protocol.

What playback Category are you using, and is there anything unwanted left in the Queue?

Do the Repeat and Shuffle icons on the player screen actually visibly change on the screen, and/or does the track counter alter too (next to the Repeat icon; it may need to be enabled via Settings=>Look and Feel=>Player UI=>Show Track Counter)? If so, can you upload a short screen recording of when it happens?

Andre

Link to comment
Share on other sites

Ok, I will look at the last commands when I notice it happen again.

I'm playing using All Songs and I turn shuffle on.

The Repeat and Shuffle icons do change yes.

Unfortunately I haven't figured out how to reproduce the problem. It sort of just happens randomly so I don't know if I can get a screen recording.

It seems to have only started happening recently though. I have just upgraded to Android 14 if that helps and obviously have the newest Poweramp. Nothing in the car has changed.

Link to comment
Share on other sites

I am also experiencing this. I just upgraded my phone and went from Pixel 4a 5G (Android 13) to Pixel 8 Pro (Andeoid 14). I watched repeat get set after connecting to Bluetooth. I see where it's calling onSetRepeatMode but no idea why. The repeat button on my car's dash doesn't even do anything in Bluetooth mode. It only works for USB or SD card media.

 

ouPIalL.png

Link to comment
Share on other sites

@Byron Both your log and the one from @Richard Robertson seem to show Repeat or Shuffle instructions being sent via the Bluetooth stack, which Poweramp is responding to.

As in both cases this only started occurring after your upgrades to Android 14, I guess it's probably not coming from the BT device itself but is an Android issue (unless previous Androids masked it?) but @maxmp should be able to diagnose it further.

Andre

Link to comment
Share on other sites

Ok, maybe I'm insane but I spent the last hour going through a Bluetooth HCI snoop log. I found the offending packet. Supposedly my Uconnect Bluetooth is assigning repeat mode 3 and shuffle mode 1. Not sure what those mean or why considering the interface in my car doesn't even act like repeat and shuffle work on Bluetooth and for Android 13 and below, this didn't happen in Poweramp. Now I feel like i should try capturing on my old phone that still runs Android 13 and see if the same packet is coming through.

I also still need to locate and try a non-car Bluetooth audio device to test that.

Link to comment
Share on other sites

I'm having the same repeat issue since upgrading my Pixel 6 to android 14. I'm getting the same repeatmode=2 command popping up, and keeps coming up if I try to change the repeat mode to off. I don't seem to be getting the shuffle issue though. Not sure if it helps but my car is a 10 year old Ford. Also, I don't have the problem when using a Bluetooth headset.

Some sort of option under the Bluetooth settings to ignore repeat and shuffle commands would be useful as I don't use either.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

My Samsung Galaxy A54 just updated to OneUI 6.0 (Android 14) and I can confirm that this Repeat/Shuffle modification is NOT happening with any of my BT devices, they just connect and wait for audio. So presumably this is an early Pixel Android 14 bug, which hopefully Google will fix in a future update.

Connecting Headphones:

==================
13:09:42.849 BTReceiver headset event
connection BT=true am mode=0 Parrot Zik V1.10
==================
13:09:43.082 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
13:09:43.082 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2

Connecting Speaker device:

==================
13:11:05.084 BTReceiver headset event
connection BT=true am mode=0 TWC Communicator
==================
13:11:05.551 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
13:11:05.551 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2

And my car headunit (no idea why all the rapidly repeated messages after connection) :

==================
13:42:39.162 BTReceiver headset event
connection BT=true am mode=0 Hyundai i30 (Andre)
==================
13:42:39.798 PlayerService onRoutingChanged
newDevice=bt oldDevice=speaker
==================
13:42:39.798 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
13:42:41.028 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
13:42:41.677 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
13:42:42.652 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
13:42:43.389 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
13:42:44.506 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
13:42:45.812 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2
==================
13:42:46.607 PlayerService reloadPipeline
 allowPlaying=true forceResume=false state after reload=2


Andre

Link to comment
Share on other sites

@maxmp: Many thanks for the help.

I have just tested the following version of Poweramp on my Pixel 7 (Android 14 including all updates):
build-976-bundle-play [976004-c2601e58]

Should the current beta version be - right?

Unfortunately, the behavior still occurs with me.

Link to comment
Share on other sites

  • 3 weeks later...

I use the 'Play' version yet Google's still showing v976. Is v980 going to be available on Play soon?

Just a thought, this new setting ignores commands following connection, however my phone and car keep trying to sync the setting, up until it's disconnected. If I try to correct it on my phone, something (I'm assuming the API calls back and forth with the car) turns it back to 'repeat on'. My concern is that it'll be fine for the first x seconds, then change after that. Having said that, perhaps it'll allow them to be in sync somehow?

Once I can install 980, i'll check what happens and report back if that's OK?

Link to comment
Share on other sites

@mporcas Sorry, I cropped the screenshot too much! It's the second of the new controls (now highlighted) that you need to set in order to permanently ignore any Repeat/Shuffle commands being issued by your device's Android version.

New releases are always made available here on the forums first, and also by opting in to the 'beta' option in the Play Store, which allows new features to be tested by a subset of the userbase before a wider release is made to everyone. Once any minor initial issues are found and ironed out, the Play Store will get updated for everyone.

Andre

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...