Jump to content

Pixel 6 Now Playing feature no longer working

Recommended Posts

I noticed yesterday that the Now Playing feature on my Pixel 6 is no longer working. In the Now Playing Settings it says "com.maxmpz.10329 is using device audio" and "Songs aren't identified while device audio is being used by other apps".  I get this error whether or not Poweramp is running. 

Build 948-957P

Pixel 6 on Android 13

Link to comment
Share on other sites

I have the same issue here. Same build number, android version, but on a Pixel 6a.

I noticed this happening whenever I switch from Bluetooth to speaker directly without stopping Poweramp first. If I force stop Poweramp before I turn off my bluetooth, this doesn't happen. If I forbid Poweramp to run in the background, this also doesn't happen.
After the error Scott described happens, nothing you do can resolve it, except for restarting your phone. Force stopping Poweramp and the Android intelligence service (which handles the feature) do nothing.
Please fix this as soon as possible as I rely on this feature for work partially and I often forget to cut off Poweramp before disabling bluetooth. I'm ready to provide logs and test debug builds if need be.

Link to comment
Share on other sites

I use Hi-Res for all my outputs (Speaker, Bluetooth, USB DAC)
I have not observed whether this happens after the USB DAC gets used, will test now.

Okay, so it happens when I switch from Bluetooth to USB DAC.
It does not happen when I go from USB DAC to Speaker.
Seems to me as there is some issue with the bluetooth handoff 

Further digging in regards to Andre's question - decided to try switching to OpenSL ES.
I get no issues no matter the combination of output devices I switch between. It must be something in the latest update that has messed something up with the Hi-Res playback as previously it was working fine to my knowledge.

Link to comment
Share on other sites

@smsimeon while non-playing, Poweramp unloads itself in 5 seconds after pause/going background. This behavior can be overridden by Keep Notification option.

As for Hi-Res output, you can try to use AAudio output which usually works OK with higher resolution audio on Pixels (though I guess issue may still persist if it's firmware issue related to the hi-res audio).

Link to comment
Share on other sites

@maxmp Tried all three modes on my ride to my grandma yesterday and on AAudio there's been no issue with "Now Playing" on the Pixel.
Not sure what the issue was with Hi-Res, but I realistically only use it with one bluetooth receiver for my home audio system so its not that big of an issue. 
I haven't tried it under the Pixel, since I got it recently, but with my previous phone anything else than "Hi-Res" as output produced hissing at quiet parts of any song and distortion at below 50Hz.

Link to comment
Share on other sites

  • 4 weeks later...

Just a quick update. 

This whole thing might be a pixel problem, rather than a Poweramp one. Recently used it with Android Auto a lot and I noticed on occasion, Poweramp would not start up with the connection being established. Happened with AAudio, OpenSL and Hi-Res. After the Android Auto connection, navigation and everything works as expected, but when opening the "Now playing" feature, it shows Poweramp using the audio channel.  Again, have to force stop it and then launch it again just to work at all.
Decided to try removing Poweramp to test whether the same thing happens with the built-in music app. Not only does the same thing happen, it somehow bricks the Android Auto connection and I have to cold boot the system in the car. "Now Playing" option shows the same error that the channel is being used, but with no app as the culprit. 
It is weird to how it happens randomly. I cannot notice a pattern. Will write to the pixel community forums, hopefully Google fixes this.

Link to comment
Share on other sites

This may be completely unrelated, but we saw an issue with a report of a device already in use message in Android Auto before. Just in case it's a similar issue, could you change Settings=>Audio=>Advanced Tweaks=>Volume Levels back to System Default. Probably not related, but worth a try.


Link to comment
Share on other sites

Just double checked and this is indeed set as default and was when I was using it in the car. I do have the custom volume panel enabled though, if it makes a difference.
I doubt that its Poweramp at fault for this specific issue, probably not for the main one either. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...