Jump to content

"Open SL ES" is not turning off


Mr. Max
 Share

Recommended Posts

You can't have 'no method' assigned for any given output, so you can't turn off the active method. Just enable the new one and the old one will become disabled.
 

@maxmp As more methods got added to the list, I've started to feel for a while that the hierarchy ordering of the Output menu is no longer very user-friendly, as illustrated by this question. I would much prefer for the output devices to all be listed in the first level of menu, with the various technical methods for each device laid out underneath. Perhaps even with no drill-downs at all, allowing the options to be chosen on a single screen using your nifty new oval-shaped radio buttons, thus:

    Wired Headset/AUX
        (OpenSL ES)  (AudioTrack)  (AAudio)  (Hi-Res)  ⚙
    Speaker
        (OpenSL ES)  (AudioTrack)  (AAudio)  (Hi-Res)  ⚙
    Bluetooth
        (OpenSL ES)  (AudioTrack)  (AAudio)  (Hi-Res)  ⚙
    USB DAC
        (OpenSL ES)  (AudioTrack)  (AAudio)  (Hi-Res)  ⚙
    Other Output Devices
        (OpenSL ES)  (AudioTrack)  (AAudio)  (Hi-Res)  ⚙
    Chromecast
       ⚙
    Restore Defaults
 

I think that would be a much simpler and more intuitive way to achieve the same ends.

Andre

Link to comment
Share on other sites

@andrewilley i tried that you said. Look firstly "open sl es" by default turned on. And i turned on "hi res audio" for "wired headset" after i go to now playing screen. Than it still showing audio output is "open sl es ,48khz" even i turned on "hi res audio, 192khz" output. In short "hi-res audio" output is not applying even after we turned on "hi-res audio" from setting.😔20220804_205543.thumb.jpg.f5905b4de3a0353482dabad2c5cfe1f8.jpg

Link to comment
Share on other sites

1 hour ago, Mr. Max said:

@andrewilley i tried that you said. Look firstly "open sl es" by default turned on. And i turned on "hi res audio" for "wired headset" after i go to now playing screen. Than it still showing audio output is "open sl es ,48khz" even i turned on "hi res audio, 192khz" output. In short "hi-res audio" output is not applying even after we turned on "hi-res audio" from setting.😔

What is your device, does it support this format on the headphone output?

Link to comment
Share on other sites

@MotleyG device :Samsung galaxy j8 android 10. And yes my device support high res audio output. And also my device have "Samsung Ultra High Quality Audio" support. In past days my Poweramp was support "hires 192khz" but from few days my Poweramp not able to support "hires audio" it only support "open sl es" output even with "hires 192khz" option turned on.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...