Jump to content
DevilSlayerDante

Widget album art not updating

Recommended Posts

Since updating from 874 to 877, my widget no longer updates album art with track changes. It's an old widget that is no longer supported but still functioned flawlessly until 877, and I see nothing in the changelog to suggest widget functionality has changed significantly.

LG G5 (RS988)

ANDROID 7.0

Share this post


Link to post
Share on other sites

There may have been some code changes to the way PA interacts with widgets when Max added:

On 7/12/2020 at 12:52 PM, maxmp said:

Build 877:

  • Repeat/Shuffle icons for 4x1 widget

What old widget are you using? I'm doubt using old widgets with the latest Poweramp is safely supported.

Andre

 

Share this post


Link to post
Share on other sites

There were no any changes recently in this regard in the API for widgets, but (like couple of years ago) Settings / Misc / Send Album Art for old API option was introduced, which is disabled by default. You probably need to enable that. Still Poweramp doesn't change this option if just updated (fresh reinstall or data clear resets the options, unless there is Play app data backup).

Share this post


Link to post
Share on other sites
16 hours ago, andrewilley said:

There may have been some code changes to the way PA interacts with widgets when Max added:

What old widget are you using? I'm doubt using old widgets with the latest Poweramp is safely supported.

Andre

 

Poweramp Widgets Kit

I didn't expect it to work, but it did work with 874, now...

14 hours ago, maxmp said:

There were no any changes recently in this regard in the API for widgets, but (like couple of years ago) Settings / Misc / Send Album Art for old API option was introduced, which is disabled by default. You probably need to enable that. Still Poweramp doesn't change this option if just updated (fresh reinstall or data clear resets the options, unless there is Play app data backup).

I never knew the "Send Album Art for old API" option even existed, so it was working before 877 with that setting disabled.  Now I've enabled it, removed the widget from my home screen, wiped the widget app's data, and added it back to my home screen, but it still isn't working.

Share this post


Link to post
Share on other sites
On 7/19/2020 at 3:41 AM, andrewilley said:

Your link to the Widgets Kit is broken. I assume it's a third-party product?

Andre

Hmm, I guess the link only works for users who purchased it, I can view the product page but can't install it, I kept the .apk with Titanium Backup from an older device.  And yes, it is a 3rd-party product by iKorolkov, same dev whom made the Poweramp v2 retro-hifi skin you're not so fond of 😁, and has since removed all of his Poweramp add-ons in favor of PlayerPro...which kinda sucks IMHO.

Share this post


Link to post
Share on other sites

As you say, it does look like that dev no longer supports or provides that app any more, as it was only ever designed for PA v2 and he removed it along with his old skins.

If Max has the time and inclination -  you'd need to ask him - he might be able to take a quick look at it from your backup file. Since you mentioned it still worked with build 874, it might be something simple, but to be honest it might be easier to just file in the 'obsolete' pile - which even its own dev has apparently done. As no-one else can download it now, and it was designed for PA v2, I rather doubt it's worth spending much time on now.

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...