Jump to content
TacoEmergency

Poweramp not finding any music files

Recommended Posts

Any help is greatly appreciated!

Poweramp doesn't locate any of my audio files. I'm using on an android head unit in my car. I've selected the correct folder. I've rescanned many times. I've deleted and reinstalled. I've ejected the SD card. 
I’ve checked all folders and tried specific folders with music and rescanned (full rescan too).

I’ve purchased full version, off google play. 

I’ve done this (haven’t gotten a reply from support, which is why I’m writing here): 

“Hello from Poweramp support team!

Please uninstall Poweramp Trial and Unlocker, restart your device and  update Poweramp (trial - which is the main app) from Poweramp site - https://powerampapp.com/downloads/Poweramp-v3-build-last-uni.apk
Thanks!“

im using Poweramp for my android head unit in my car. 

Here’s a video: 

thank you in advance for any help! 

Share this post


Link to post
Share on other sites

Video does not work, has you set it to public visibility?

What version of Android does your head-unit run? Do you see the SD Card folders listed in the Settings > Library > Music Folders screen, and can you tick/untick folders there? What about if you put a few songs in a folder on the device's internal memory as a test, can they be made to scan correctly?

Andre

Share this post


Link to post
Share on other sites

@andrewilley Thank you for the response!

heres the link: 

I accidentally deleted the last letter of link.

ive tried putting music on internal and it still won’t locate. 

im running Android 9.

for some reason when I’m in Files, it keeps asking me to Grant Access. Maybe that’s it? I’ve tried going in Settings and allowing it to “make any changes”. But it doesn’t “stick”. 
 

maybe that’s it? 
but again, any other “player” app I download works totally fine. They see all my music files without having to do anything. It’s only Poweramp that cant find anything.

Big thank you for helping! 

Share this post


Link to post
Share on other sites

You should't need to Grant Access for reading permission to the SD Card (only for writing). I assume you've already tried the advice of uninstalling everything, rebooting, and re-installing?

If you go into Android Settings > Apps > App Permissions check that the Poweramp app is set as allowed in the Storage section.

Andre

Share this post


Link to post
Share on other sites

Thanks for the detailed videos.

Seems like some issue with storage access. Very hard to remotely debug, if you can capture logcat (right after you hit Full Rescan button) that would be helpful.

Share this post


Link to post
Share on other sites

@maxmp Do any of the current catlog apps provide enough info for you on non-rooted recent-ROM devices, or would the log file need to be captured via an adb terminal session (which might be a bit complex for a non-techie user)?

Andre

Share this post


Link to post
Share on other sites

Sorry Max, I always thought that option was for sending a previous-crash log, not a recent usage catlog. You learn something new every day! :) 

Andre

Share this post


Link to post
Share on other sites

@TacoEmergency thanks for the log. From the log, cause of the issue is:

02-27 17:04:53.790 31822 31895 W ScanDispatcherService: Media not mounted

There is a simple check in Poweramp scanner which won't scan the storage if media (storage/sd card/etc) is not mounted, as this will cause tracks removing from the playlists, categories, etc. 
Unfortunately your ROM seems to always indicate that media is not mounted.

If you wish, I can try to prepare test build which tries to workaround that, but that will require test build testing + log again from your device.

Share this post


Link to post
Share on other sites
On 3/18/2020 at 12:25 AM, TacoEmergency said:

Any word? @maxmp

Max did offer a few posts ago to create a test build for you, which would mean downloading a new special build and sending him new logs. He asked if you wanted him to do this, but I can't see a reply.

Andre

Share this post


Link to post
Share on other sites

@maxmp you mentioned making a test build for my system, can you do that? 
I really want this to be my main audio player. I love the look, feel and functionality. 
let me know what you need from me. 

Share this post


Link to post
Share on other sites

The latest build 871 includes all those changes. In your case you probably want to enable File Access Legacy Mode (search in Settings). Thanks !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...