Jump to content

Bluetooth's broken/unusable - works with other music apps except PA


Recommended Posts

Bluetooth is broken on Poweramp from my end - trying to connect it to my car. All other music apps like Spotify and Soundcloud with Bluetooth work well no problems playing music. I can't play music from PA as bluetooth keeps disconnecting/reconnecting on the PA app.


My device: ONEPLUS 3T

Android version: Android Pie 9.0/Oxygen 9.0.3

Poweramp version: Build 833

Link to comment
Share on other sites

I am having (I think) the same problem.

Device: Oneplus 3
Android: OxygenOS 9.0.3
Poweramp: 830

When my device attempts to connect to the car Bluetooth, it seems to make an initial connection (car drops a notification saying it connected) but then the Bluetooth service on my phone seems to crash and restart itself. The icon goes dark, turns back on, and begins the connection process again. This creates an endless loop of connecting, success, disconnected, etc. On rare occasion when I turn off the Bluetooth service and turn it on again it will connect and stay connected, and when it does the app works fine and plays music. I have tried clearing the Bluetooth cache and data, and removing the device from the car and re-pairing. The issue happens even when the app isn't open, but must be running in the background. I had mixed success trying to force stop the app and then start it. The only surefire way is to uninstall the app. I repeat: I can't reliably use my car's Bluetooth without uninstalling the app completely. It seems like Poweramp does something when a new Bluetooth connection is established which is causing the service to break.

Update: Explored the force-stop a little more. With the app stopped the connection will (always?) succeed. When I then start the app, either (a) it begins utilizing the Bluetooth connection properly (pulls up song info, responds to controls) or (b) it does not play nice with the Bluetooth either not interacting with it (begins playing sound from the phone speaker) or it crashes the service and begins the loop again.

Link to comment
Share on other sites

I'm having the same issue.

Device: Sony Xperia 1
OS: Android 9 (stock)

I tried installing old builds and connecting to my Car one by one, and I found the issue was introduced by the Build 817. The Build 815 worked just fine, but the Build 817 or latter didn't.

I also found the crash is likely to be caused by the AVRCP (or MediaBrowser) related code. Here is the crash log of the "com.android.bluetooth" extracted from the Bluetooth HCI Snoop Log.

2019-06-26 14:21:32 system_app_crash (text, 872 bytes)
Process: com.android.bluetooth
PID: 27516
Flags: 0x30c8be45
Package: com.android.bluetooth v28 (9)
Foreground: No
Build: docomo/SO-03L/SO-03L:9/55.0.D.6.146/3574101995:user/release-keys
UUID: 0dc050bc-02bb-404d-8856-86ac5327a93c

java.lang.ArrayIndexOutOfBoundsException: length=0; index=-1
	at com.android.bluetooth.avrcp.BrowsedMediaPlayer.onBrowseConnect(BrowsedMediaPlayer.java:347)
	at com.android.bluetooth.avrcp.BrowsedMediaPlayer.access$200(BrowsedMediaPlayer.java:42)
	at com.android.bluetooth.avrcp.BrowsedMediaPlayer$MediaConnectionCallback.onConnected(BrowsedMediaPlayer.java:113)
	at android.media.browse.MediaBrowser$6.run(MediaBrowser.java:603)
	at android.os.Handler.handleCallback(Handler.java:873)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:338)
	at android.os.HandlerThread.run(HandlerThread.java:65)


Link to comment
Share on other sites

I tried switching the AVRCP version to 1.4, 1.5, and 1.6 but it didn't help. The device doesn't support 1.3. Modifying other BT options (e.g. optional codecs, sample rate, channel mode, etc...) didn't solve the issue either.

(Edited: I just found the device supports AVRCP 1.3 so let me try it later. But I hope the app to support 1.4 or higher...)


Link to comment
Share on other sites

@yas your problem is not related to the original poster issue. In your case this is related to Android support libs (AndroidX). These are updated in latest builds, try 835.

@milklover12 I guess you can post a bug report for that ROM on their bugtracker/forum, and please uncheck Poweramp Settngs / Audio / Direct Volume Control (DVC) / No DVC For Bluetooth Absolute Volume option.

Link to comment
Share on other sites

@yas as you can see there is no com.maxmpz anywhere, i.e. that bug is in Android libs (some of those are updated in 838). Though, your issue can't cause connection/sound problems, at most it will cause no-title/album displayed over BT.

As for custom ROMs with non-standard/tweaked BT implementations - disabling option Settings / Audio / Direct Volume Control (DVC) / No DVC for Absolute Volume will help. Note: disabling Direct Volume Control or any other options there won't help. Thanks!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...