Jump to content
Poweramp
Kloppstock

Substaining error hacking noice after song swich

Recommended Posts

I believe that my combination of personal sounds-settings inside PA creates an incompatibility that make up this pretty rare but even though frequent

random error occuring upon switching song only....where i instead of music can hear a substaining hacking noice and it wont go away if switching to another song.

the only resett is to close down PA and pull out the earphones and reinsert them, both actions in combiantion seem to be needed to fix it

But no...this is not a earphone problem since i have tested different earphones and this happen in all earphones, but a problem occuring inside or whit PA

Any ideas what it could be?

Share this post


Link to post
Share on other sites

Yes, I also know that. Try increasing the output buffer ( Settings > Audio > Output > [<plugin>] > [<device>] > [<settings>] > Buffer Size )

Share this post


Link to post
Share on other sites

You could also try resetting output methods to defaults and see if that helps.

Andre

Share this post


Link to post
Share on other sites
6 hours ago, blaubär said:

Yes, I also know that. Try increasinf the output buffer ( Settings > Audio > Output > [<plugin>] > [<device>] > [<settings>] > Buffer Size )

The only thing i found there was "chromecast output" 

i increased buffer size from 1500 to 2100ms just for fun

Share this post


Link to post
Share on other sites
1 hour ago, Kloppstock said:

The only thing i found there was "chromecast output" 

You mean to say that you have neither audiotrack nor open opensl nor hi-res ?

5152019224541.jpg

Share this post


Link to post
Share on other sites
4 hours ago, blaubär said:

You mean to say that you have neither audiotrack nor open opensl nor hi-res ?

5152019224541.jpg

Everyhing is deafult setted, i have never visited this section before, i have only messed with the main equalizer settings since in not an advanced user ;)

You told me to increase buffer size, and i took for granted you ment inside Chromecast output

but i see now that there are several settings yes...that i have no clue what it means

OpenSL: Everything is deactivated by deafult

Audiotrack output: Everything is activated by deafult excluded USB DAC

Its you who must suggest me what i shall sett the buffer to i think, i see 2 menus of interest

"Speaker" and "Other output devices" 

 

Hi - Res Output: I have now activated USB DAC 

Its "buffer size "setting is more complicated than the chromecast counterpart

Shall i increase both "Buffer ms"=50ms  and Buffers=2

to what different value?

 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, Kloppstock said:

You told me to increase buffer size, and i took for granted you ment inside Chromecast output

Ok, what output device DO you use ? Is shown in the info bar on the main playing screen. You can long press this to get even more information.

516201963324.jpg

516201963512.jpg

Share this post


Link to post
Share on other sites

For each output device (speakers, headset, bluetooth, etc) you can control what method PA uses to play audio to that device - for example OpenSL, AudioTrack, or the Experimental High-Res output.

You can activate a new option by enabling that device in Settings > Audio > Output > [AudioModeName]. OpenSl or HighRes are the most common for headset use. Whichever one is enabled is the one that will be used to send sound to that output device. You can then use the cogwheel icon to go in and adjust the settings - such as buffer size - for that device.

By the way, does anyone else think this screen would now be a lot more user-friendly and intuitive if the Audio > Output menu contained the list of devices first (Headset, Speaker, Bluetooth, Chromecast, USB DAC, etc) with the currently chosen option in small text underneath the title. Then you would tap to drill down into each one individually to change its technical mode (to OpenSL, HighRes, etc) and adjust other settings? Just seems more logical that way to me, and much easier for new users to understand.

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

Just seems more logical that way to me, and much easier for new users to understand. 

That would be more intuitive.

Another idea would be a matrix "devices vs plugins" with checkboxes for selection. Long press on a checkbox could then open the settings.

Share this post


Link to post
Share on other sites
6 hours ago, blaubär said:

Ok, what output device DO you use ? Is shown in the info bar on the main playing screen. You can long press this to get even more information.

516201963324.jpg

516201963512.jpg

Output: Flags 0xAO NO_HEADROOM_GAIN FLT_EXTENDED_DYN RANGE Latency 93ms

Buffers: 1X  (46 ms 20448 audioframes)

 

 

Share this post


Link to post
Share on other sites
28 minutes ago, Kloppstock said:

Buffers: 1X  (46 ms 20448 audioframes)

then try the next bigger preset

516201913595.jpg

( in this screenshot "speaker" is the device I use - you'll have to select the buffer for the device that you use, whatever that is of course )

Share this post


Link to post
Share on other sites
On 6/16/2019 at 1:59 PM, blaubär said:

then try the next bigger preset

516201913595.jpg

( in this screenshot "speaker" is the device I use - you'll have to select the buffer for the device that you use, whatever that is of course )

 

On 6/16/2019 at 11:11 AM, andrewilley said:

For each output device (speakers, headset, bluetooth, etc) you can control what method PA uses to play audio to that device - for example OpenSL, AudioTrack, or the Experimental High-Res output.

You can activate a new option by enabling that device in Settings > Audio > Output > [AudioModeName]. OpenSl or HighRes are the most common for headset use. Whichever one is enabled is the one that will be used to send sound to that output device. You can then use the cogwheel icon to go in and adjust the settings - such as buffer size - for that device.

By the way, does anyone else think this screen would now be a lot more user-friendly and intuitive if the Audio > Output menu contained the list of devices first (Headset, Speaker, Bluetooth, Chromecast, USB DAC, etc) with the currently chosen option in small text underneath the title. Then you would tap to drill down into each one individually to change its technical mode (to OpenSL, HighRes, etc) and adjust other settings? Just seems more logical that way to me, and much easier for new users to understand.

Andre

Ok im currently testing this new setting form blaubär, so far so good

If nothing changes i thank you

 

Share this post


Link to post
Share on other sites
On 6/16/2019 at 1:59 PM, blaubär said:

then try the next bigger preset

516201913595.jpg

( in this screenshot "speaker" is the device I use - you'll have to select the buffer for the device that you use, whatever that is of course )

Accutally i noticed oretty long time ago now.... that the error is not fixed, do you have any further calibrations? please

 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Kloppstock said:

Accutally i noticed oretty long time ago now.... that the error is not fixed, do you have any further calibrations? please

Do you have any more detailed information yet? I don't think you have as yet mentioned what phone you have, ROM version, Poweramp build version, or even your active choice of output method... all of which makes it a bit hard to suggest anything more.

Andre

Share this post


Link to post
Share on other sites
On 7/17/2019 at 8:05 PM, andrewilley said:

Do you have any more detailed information yet? I don't think you have as yet mentioned what phone you have, ROM version, Poweramp build version, or even your active choice of output method... all of which makes it a bit hard to suggest anything more.

Andre

Lenovo A plus Android 5.1 

I dont know what rom version and audio-output i have so you can choose from this screendump

Poweramp Build 830:

 

Less.png

Screenshot_2019-07-21-16-11-21.png

Share this post


Link to post
Share on other sites

1) Your Poweramp build is a but old, latest is currently 838.

2) Your device is pretty low spec by today's standards, but still ought to work. 1GB  RAM / 8GB storage and a Mediatek processor are probably not working in your favour either. Android 5 is the first version supported by Poweramp v3, any older and you would need to use the legacy v2 version of the app.

Your screenshot above doesn't show the settings when you have a headset plugged in, it looks like it was taken based on Speaker output? Headset is probably set for AudioTrack output.

Reset to default output settings again, plug in your headset, and try switching to OpenSL ES Output for headset use (or AudioTrack if OpenSL is already selected) by tapping on that mode in the Output menu and then switching on Wired Headset/AUX as a used device. I don't think trying hi-res will be an available option with your device's headset port, but it's worth checking anyway to see if Wired Headset/AUX is listed as a choice if you tap Hi-Res in the Output menu. With each output method, you can adjust the settings such as buffer/etc independently, so for each one try increasing the buffer gradually (either by selecting preset or increasing the sliders).

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...