Jump to content
Poweramp
fraga.matias

Music ''jumps'' after update in Xiaomi Note 6 Pro

Recommended Posts

Hey! New to the forum, but I've been using Poweramp for a few years now, love it, and never had an issue with it. Until now...

My Xiaomi Note 6 Pro updated its OS, and now Poweramp, unless the app is open, will jump like a scratched CD when playing music. Could this be an issue with compatibility with the new OS from Xiaomi?

Poweramp is v3-build-826-play (full version)
Stock Rom - Android 9 PKQ1.180904.001

If anyone can help me fix this it would be very much appreciated!

Thanks,
Matias

Share this post


Link to post
Share on other sites
8 hours ago, fraga.matias said:

My Xiaomi Note 6 Pro updated its OS, and now Poweramp, unless the app is open, will jump like a scratched CD when playing music. Could this be an issue with compatibility with the new OS from Xiaomi?

Maybe. Go to Settings > Audio > Output. and hit Restore Defaults. Does that help ?

Share this post


Link to post
Share on other sites

 

7 hours ago, blaubär said:

Maybe. Go to Settings > Audio > Output. and hit Restore Defaults. Does that help ?

Sadly not, the problem persists

Share this post


Link to post
Share on other sites
2 hours ago, fraga.matias said:

 

Sadly not, the problem persists

Try to increase the buffer size in Settings > Audio > Output > [plugin] > [device]

Share this post


Link to post
Share on other sites
45 minutes ago, blaubär said:

Try to increase the buffer size in Settings > Audio > Output > [plugin] > [device]

The only place in Audio > Output that I found had a buffer size option was Output > Chromecast Output .  Increasing the buffer size there didn't solve the problem.

Share this post


Link to post
Share on other sites
36 minutes ago, fraga.matias said:

The only place in Audio > Output that I found had a buffer size option was Output > Chromecast Output .  Increasing the buffer size there didn't solve the problem.

You'll have to go two steps further from Output, as I wrote , to Settings > Audio > Output > [plugin] > [device]

4142019192926.jpg

414201919305.jpg

4142019193047.jpg

Share this post


Link to post
Share on other sites
8 minutes ago, fraga.matias said:

My bad, I didn't get that at first. I've tried that now, but still it doesn't work.

Mmm... does this happen with files from internal memory or SD card ? Whatever you have, could you try the other ?

Share this post


Link to post
Share on other sites

It's the internal memory, the phone has enough memory so I didn't bother to buy a SD card. I figure its gotta be some compatibility issue with the updated OS. This new version of Poweramp worked just fine before the updated OS...

Share this post


Link to post
Share on other sites

Does this happen with the screen on too, or only after the screen has gone to sleep?

Andre

Share this post


Link to post
Share on other sites
1 hour ago, andrewilley said:

Does this happen with the screen on too, or only after the screen has gone to sleep?

Andre

It happens if I don't have the app opened on screen. If the app is running in the background, but I have the screen on, on another app or whatever, it still happens. The only moment where it doesn't happen is when I have the app open and the screen on.

Share this post


Link to post
Share on other sites
8 hours ago, fraga.matias said:

It happens if I don't have the app opened on screen. 

In which case it is something in your device's Android system that is not giving enough priority to running background tasks. I don't know what you can do about it though (if it was just during screen-on then you could tell Android not to put PA into a doze status)

Andre

Share this post


Link to post
Share on other sites

I have a MiMax3 running  9 PKQ1.181007 recently upgraded from Android 8 which runs PA without any issues.

Have you tried to uninstall  and re-install PA after upgrading your phone?

There is a per app "background limitations" under battery optimization in phone setting that might down prioritize PA if those settings are active.

Kim

Share this post


Link to post
Share on other sites
4 hours ago, andrewilley said:

In which case it is something in your device's Android system that is not giving enough priority to running background tasks. I don't know what you can do about it though (if it was just during screen-on then you could tell Android not to put PA into a doze status)

Andre

 

2 hours ago, 6b6561 said:

I have a MiMax3 running  9 PKQ1.181007 recently upgraded from Android 8 which runs PA without any issues.

Have you tried to uninstall  and re-install PA after upgrading your phone?

There is a per app "background limitations" under battery optimization in phone setting that might down prioritize PA if those settings are active.

Kim

There was in fact some background limitation thing being applied to PA, however after setting it on ''no restrictions'' the problem was still there, so I tried uninstalling the app and installing it again and... voilá!  I should have tried that earlier. Sometimes the simplest solutions are the right ones... Thanks for all you help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×