Jump to content

Doesn't play on android 13

Go to solution Solved by andrewilley,

Recommended Posts

Hi, my name is Javier.
Since my Samsung S20 has been updated to android 13, Poweramp does not play. Skips songs giving error. Before it worked perfectly. I have uninstalled but the error persists.
Has this happened to anyone else?
Is it a documented bug?
Sorry for my bad translation, I write from Spain.
Thank you
build-945-bundle-play [945004-2d535bbf] full version 64b
Samsung Galaxy s20
Android 13
The playback is as I have always done, I select the music folder, scan the entire library and press play.

Link to comment
Share on other sites

  • Solution

Long-press on one of the songs in the Library and check Info/Tags to ensure they actually point to real songs. For Android 13,  check that you set and given access permission to a folder, not to the root of your storage.

You could also try using File Access Legacy Mode in Settings=>Misc, but that may not work in recent/future versions of Android.


Link to comment
Share on other sites

I just updated to One UI 5/Android 13 yesterday and am now running into the same issue. The legacy button doesn't appear to be working either, and I tried making sure the permissions and drive were all selected properly again.

I tried uninstalling and reinstalling the program today, and I think it does have to do with some sort of root/folders issue, since I'm unable to import the old settings file into the new installation. It gives me the following error when I try to do that:


.com.Android.externalstorage has no access to content ://media/extenal_primary/file/1000015933

Any ideas on what I can do here? I went to the App permissions and made sure it could read the Music folder, and granted folder access within the app. What exactly is it asking me to do here and how can I grant it within Android 13?

Link to comment
Share on other sites

@Larry 609 Latest versions of Android really don't like giving permissions to the root level of user storage. If you can't restore settings, have you tried putting your saved settings file into PA's own work directory, which should always be able to be read: Android/data/com.maxmpz.audioplayer/files/ (note: no underscore in folder name).

I would clear PA app data first, and then try to assign your Music Folders location as the first task in the 'new' setup. Don't try to use a root location, just enable the music folder(s) you wish to access, and any subfolders of that location will be automatically enabled too. Initially use the default regular Android (SAF) mode, or if that really won't work try using Legacy File Access Mode.

I personally tend to avoid using the default Android 'Music' folder as there are some complications with the way Android applies rules to it - e.g. you can't put a .nomedia file in there to stop the system scanner from accessing it too. Instead I prefer to set up my own named master folder - e.g. 'My Music' or 'Audio'.

Once that is done and your music library has been scanned, only then try to import your saved settings file.


Link to comment
Share on other sites

Unfortunately, it doesn't appear anything is working. I tried those options and the player still won't play any of the music. It does scan the music and playlists properly into the library pretty much every time, but it'll always show the "Failed to play file!" alert every time I try to actually play something.

Right now, I'm more concerned with just getting the songs to play again, as opposed to bringing on the old settings and streams back in.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...