Jump to content

96khz not working on Sony WF-1000XM4 and Samsung Galaxy A12

Recommended Posts

I just bought a pair of WF-1000XM4 earbuds and realized both it and my phone have LDAC codec capabilities. However, despite it showing as enabled through my phone's developer options, Poweramp doesn't seem to want to play with LDAC codec enabled unless I set it somewhere under 96 kHz; setting it to 96 kHz results in dead silence. I'm not sure what to do in this case.


Link to comment
Share on other sites

@maxmpyes, and I have the earbuds' audio quality set to LDAC through the phone's bluetooth settings. the Sony headphones app verifies it's enabled, and developer options indicate audio should be playing at 96 kHz and 32 bits. Unless I'm misunderstanding what you mean, I thought this meant I could have hi-res playback.

The problem is that, whenever I try to play music with the Hi-res codec in the Poweramp app, it won't process music at 96 kHz unless I set down a notch to 48 kHz. 





Link to comment
Share on other sites

After looking at your screenshots again, I think Poweramp may be overriding the 48khz selected and outputting to 96khz regardless. The fact that Poweramp states it's using 96khz is a good thing. Like Max said, if you long press the bitrate in the main screen you can see what the resampler is actually doing. If your content is already 96hz it would state there's no resampling. If your music is sourced from a regular CD and is 44.1khz it would show it being resampled to 96khz. Otherwise something funky is going on. The output screen you're looking for will look something like this (except not outputting 44.1khz):


Edited by CrimsonSky
I'm bad at proofreading
Link to comment
Share on other sites

minor update: I tried updating to the newest build available for beta testers, which is 942.

A few things I noticed: Sample Format now only goes up to 24 bits, and specifically when it's set to 96 kHz (which I still can't hear anything with). Setting it to 48 kHz still produces sound, but changes the Sample Format to 16 bits, unlike before when it was 32 bits in general ("Using" sample rate now changes to match "Selected" sample rate though).

I'm honestly at a bit of a loss on what to do, because unless I'm misunderstanding, updating may have made things worse.



Edited by Adam Kruszynski
Link to comment
Share on other sites

@Adam Kruszynski can you please make 2 screenshots of Audio Info dialog (bottom of it, where output settings are visible):

  • one with 96kHz selected in Hi-Res output for BT
  • the one with 48kHz selected in Hi-Res output for BT

Also, does 96kHz result in no sound at all, or in very very low sound volume?

Samsung Hi-Res support, including LDAC is solid and stable, but I guess low end devices may have hi-res modes specifically disabled/limited.


Link to comment
Share on other sites

@maxmp Here's the two screenshots.

96 kHz has no sound at all, even when turned up to 100. although it's worth noting that the little visualizer in the EQ pages indicates that something is playing, as pictured in the third screenshot.

As far as I can tell, in my phone's developer options and the Sony Headphones app, LDAC 32 bit playback should be fine. The only thing is that Android 11 keeps resetting my LDAC playback quality to Adaptive Bit Rate, rather than Optimized for Audio Quality (990kbps/909kbps) whenever I reconnect the earbuds. Beyond that, I haven't noticed a problem with playback on other apps. Though that may just be because Poweramp is the only one I use to listen to Hi-Res music (I uninstalled Spotify awhile ago and I've only tested these earbuds with YouTube besides).

Should I try reinstalling Build 939?





Link to comment
Share on other sites

  • 2 weeks later...

@Adam Kruszynski I would advise the latest 943 build (beta on Play) or apk from this forum, but still, Poweramp doesn’t choose the codec and the codec parameters. Some limited adjustments are possible via Developers settings.

From my experience and instrumented tests by audio capturing the output of LDAC enabled Fiio BTR3, codec constantly changes 96khz sampling rate back to 48khz (this is not visible anywhere on the phone or the device as audio system still runs on 96khz), or do not even initiate 96khz if interference is detected or your phone is in pocket. Successfully you can’t hear difference as humans do not hear above 20khz.

Link to comment
Share on other sites

T̶h̶e̶y̶'̶r̶e̶ ̶a̶ ̶p̶a̶i̶r̶ ̶o̶f̶ ̶J̶a̶b̶r̶a̶ ̶E̶l̶i̶t̶e̶ ̶7̶ ̶P̶r̶o̶'̶s̶,̶ ̶l̶i̶k̶e̶ ̶t̶h̶e̶ ̶o̶n̶e̶s̶ ̶I̶ ̶o̶w̶n̶e̶d̶ ̶p̶r̶i̶o̶r̶ ̶t̶o̶ ̶g̶e̶t̶t̶i̶n̶g̶ ̶t̶h̶e̶ ̶S̶o̶n̶y̶ ̶b̶u̶d̶s̶ ̶(̶I̶ ̶h̶a̶d̶ ̶t̶o̶ ̶r̶e̶t̶u̶r̶n̶ ̶t̶h̶e̶ ̶f̶i̶r̶s̶t̶ ̶p̶a̶i̶r̶ ̶J̶a̶b̶r̶a̶ ̶b̶u̶d̶s̶ ̶t̶o̶ ̶A̶m̶a̶z̶o̶n̶;̶ ̶l̶o̶n̶g̶ ̶s̶t̶o̶r̶y̶)̶.̶ ̶ ̶I̶'̶m̶ ̶a̶w̶a̶r̶e̶ ̶I̶'̶m̶ ̶m̶o̶s̶t̶ ̶l̶i̶k̶e̶l̶y̶ ̶d̶o̶w̶n̶g̶r̶a̶d̶i̶n̶g̶ ̶m̶y̶ ̶l̶i̶s̶t̶e̶n̶i̶n̶g̶ ̶e̶x̶p̶e̶r̶i̶e̶n̶c̶e̶,̶ ̶b̶u̶t̶ ̶I̶ ̶h̶o̶n̶e̶s̶t̶l̶y̶ ̶r̶e̶m̶e̶m̶b̶e̶r̶ ̶b̶e̶i̶n̶g̶ ̶h̶a̶p̶p̶i̶e̶r̶ ̶w̶i̶t̶h̶ ̶t̶h̶e̶ ̶f̶i̶r̶s̶t̶ ̶p̶a̶i̶r̶ ̶I̶ ̶h̶a̶d̶,̶ ̶a̶s̶ ̶w̶e̶l̶l̶ ̶a̶s̶ ̶h̶a̶v̶i̶n̶g̶ ̶t̶o̶ ̶f̶i̶n̶e̶-̶t̶u̶n̶e̶ ̶t̶h̶e̶m̶ ̶a̶ ̶l̶o̶t̶ ̶l̶e̶s̶s̶ ̶t̶o̶ ̶g̶e̶t̶ ̶s̶o̶m̶e̶t̶h̶i̶n̶g̶ ̶c̶l̶o̶s̶e̶ ̶t̶o̶ ̶w̶h̶a̶t̶ ̶I̶ ̶l̶i̶k̶e̶.̶ ̶T̶o̶ ̶b̶e̶g̶i̶n̶ ̶w̶i̶t̶h̶,̶ ̶I̶ ̶o̶n̶l̶y̶ ̶e̶n̶d̶e̶d̶ ̶u̶p̶ ̶s̶w̶i̶t̶c̶h̶i̶n̶g̶ ̶b̶e̶c̶a̶u̶s̶e̶ ̶I̶ ̶h̶a̶d̶ ̶t̶r̶o̶u̶b̶l̶e̶ ̶w̶i̶t̶h̶ ̶J̶a̶b̶r̶a̶'̶s̶ ̶Q̶C̶ ̶a̶f̶t̶e̶r̶ ̶t̶h̶e̶ ̶f̶i̶r̶s̶t̶ ̶p̶a̶i̶r̶.̶ ̶I̶ ̶s̶e̶e̶m̶ ̶t̶o̶ ̶h̶a̶v̶e̶ ̶l̶u̶c̶k̶e̶d̶ ̶o̶u̶t̶ ̶t̶h̶i̶s̶ ̶t̶i̶m̶e̶ ̶t̶h̶o̶u̶g̶h̶.̶


Update: after a lotta trial and error, I finally settled upon a pair of Samsung Galaxy Buds2 Pro. these go up to 24bit/48kHz, but afaik there's no noticeable difference from 96kHz. Using these with OpenSL ES Output and Float32 Sample Format enabled allows me to use 24bit/48kHz in the PA app. 

Edited by Adam Kruszynski
Update on earbuds
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...