Jump to content

Incorrect output with Android auto


agw0121
 Share

Recommended Posts

When I use Poweramp with my Android auto, I found the music output is incorrect.

The sound is played by mobile but car speaker.

However I change the music app to Google music, it can output by car stereo correctly.

Would you please help to check the issue?

 

Phone: Asus Zenfone 5z with Android 10

Car: Mercedes w213

 

 

Link to comment
Share on other sites

2 hours ago, agw0121 said:

The sound is played by mobile but car speaker.

Do you mean the PA display and controls show correctly on the car head unit, but the sound comes from the phone speaker rather than the car speakers? Have you tried using any of the other Settings > Audio > Output options?

Andre

Link to comment
Share on other sites

  • 2 weeks later...

Yes the car unit can display the correct music, but the music is played by the mobile even I use headunit to play the music. I didn't do any setting change.

It is only happened with Poweramp, if I change to Google Music it can be played by car stereo.

 

Link to comment
Share on other sites

Unfortunately, Poweramp doesn't control the route music takes - this is done by Android and out of app control completely (except Chromcast, but this is not an output, it's a network endpoint). I can only recommend changing Audio Output types (e.g. switching to non-hi-res output, if hi-res is used, etc.). Thanks!

Link to comment
Share on other sites

Hi I just check the audio-output setting.

 

When I encountered this incorrect output, I go-to this option and pick "default setting" It could play by car stereo. But I have to set it for each connection. Can it provide any direction for saving?  I do not want to change the settings Everytime.

Link to comment
Share on other sites

After you have run Settings > Audio > Output > Restore Defaults, try selecting each of the Settings > Audio > Output methods in turn (enable your playback option in OpenSL ES, then Audio Track, High-res, etc). The chosen type should stick if you find one which works best for you.

Also, try Settings > Audio > Advanced Tweaks > Force Speaker Off (for High-Res Output)

Andre

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...