Jump to content
Poweramp
Mr_SeLeNiO

Open file

Recommended Posts

@maxmp Can you throw some light here? Trying to send an intent to open a file and I can't make it work, I don't know if there is a problem with the API, or if it is Tasker, or if I'm just a noob.

This is what I tried so far:

Action: com.maxmpz.audioplayer.API_COMMAND

Cat: None

Data: file:///storage/2EAE-2BA7/Music/0emulated/HI RES/09. Three Little Birds.flac

Extra: cmd:20

Target: Service

 

Tried all combinations by changing/filling: 

  • Cat to Default
  • Mime Type to Audio/*, text/*, text/plain, and text/html
  • Data I tried file:// instead of file:///
  • Target Activity and Broadcast Receiver
  • Class to PowerampAPI
  • Package to: com.maxmpz.audioplayer.player.PlayerService, com.maxmpz.audioplayer, com.maxmpz.audioplayer.player

Note 1: when I fill Package, I don't get any error, else I get the following:

Quote

18.15.11/JU analyse: Send Intent: 20 expected: null
18.15.11/JU Send Intent: analyse done: 20: class: int obj: 20 partWithoutMods: null static: false const true casted: false
18.15.11/E added int extra: cmd/20
18.15.11/E resolve implicit intent
18.15.11/MyPM no matching Service found for implicit intent
18.15.11/E result: stop task (error)
18.15.11/E Error: 1
18.15.11/MacroEdit action finished exeID 350 action no 0 code 877 status: Err next 0
18.15.11/MacroEdit action finished exeID 350 action no 0 code 877 status: Err next 0

 

Note 2: the following URI works*, but is not what I want:

 

Action: com.maxmpz.audioplayer.API_COMMAND

Cat: None

Data: content://com.maxmpz.audioplayer.data/files?lim=1&flt=three little birds

Extra: cmd:20

Target: Service

 

*the only thing that doesn't work in this case is lim, it throws every row it finds

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...