Jump to content
peon125

Can't use buttons on notification

Recommended Posts

Hi guys! 

I apologize in advance for my linguistic mistakes ;)

I've got LG G4c with Android 6.0 and Poweramp 2.0.10-build-588.

When i turn on Poweramp, everything goes well, but when I use any button on notification, notification bugs - artist's name, album and track titles disappear. Moreover I cant use buttons. I tap on them and nothing happens, but when I tap on the remaining place of notification, that brings me to Poweramp's screen, so that's ok. When i had Android 4.4.2 everything was good, this issue is occurring since when I've updated Android to 6.0 version. It looks like this.

Share this post


Link to post
Share on other sites

Where exactly did you get this Android 6.0 ROM and what is exactly its build number?

I test PA on all line of LG G devices on various OTA latest ROMs, including LG 4 @ 6.0 OTA, but I've never seen such issue. There were reports from some beta 6.0 LG Gx users, updating to OTA helped them.

Share this post


Link to post
Share on other sites

Unfortunately, this can be fixed only by ROM modder (basically they have incorrect colors/background colors set in theme). App has no any way to guess what colors are used by notification area. It usually works for system apps and apps which don't use advanced notification (they use system templates), because in these ROMs colors are changed in those templates, but not in system theme.

In Poweramp alpha 703 I specifically added also black/white manual override for notification colors (for most OTAs it will work OK for default auto setting), this will help with such ROMs.

Share this post


Link to post
Share on other sites

The problem is not only that the buttons become invisible, but also pressing them does nothing. This is very frustrating because you cant change or pause the music quickly. You have to open Poweramp.As the TS said, the first song works ok, its only after the song changes that the bug appears.

I am using Fulmics ROM on LG G3 (slightly customized stock ROM), so the issue might also be enabled by some settings in LGs ROM. But you could try to find a way to circumvent this problem. Since this problem does not happen in other apps, you might also find a bug in Poweramp that's just waiting to happen on a large scale. I can be a tester if you need a phone to test on. Just send me APKs with test or debugging code and I'll provide the feedback.

Please find attached two screenshots, both grabbed on the same phone, without the issue and with it.

poweramp_bug.png

poweramp_ok.png

Share this post


Link to post
Share on other sites
On 12.04.2016 at 8:04 PM, maxmp said:

Where exactly did you get this Android 6.0 ROM and what is exactly its build number?

unfortunately I hadn't get it from any official source and now I can't remember where I have found it. When I tried to update android in "official" way (by update menu in setting) my LG get a bootloop. It took me a while to repair it ;) build number is MRA58K

Share this post


Link to post
Share on other sites

Same problem with LG G3 (d855) on official Android 6.0 (v30b), no root, no custom recovery, full stock. Its works for few times, when changed options, but when i restart player, it does'not work again.

Screenshot_2016-04-15-16-13-35.png

Share this post


Link to post
Share on other sites
2 minutes ago, peon125 said:

so what exactly should I do?

When it's released (next day or two I gather) download and install it if you want to try it out. Available from the Downloads tab at the top of the screen. be warned though, it is an ALPHA test release, although it does seem remarkably stable and many people are using it on their main devices.

Andre

Share this post


Link to post
Share on other sites

Hi. I have faced this problem with my installation. LG G3 Android 6 v10 official LG rom and newest Poweramp available from google store. How can I fix it?

Share this post


Link to post
Share on other sites
8 hours ago, dth said:

Hi. I have faced this problem with my installation. LG G3 Android 6 v10 official LG rom and newest Poweramp available from google store. How can I fix it?

Have you tried builds 703 or 704, rather than the regular 589 version from the Google store?

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...