Jump to content

Poweramp repeatedly loses contact to song files on external storage.


Yukusoona
 Share

Recommended Posts

Dear Forum,

I am not sure what I am doing wrong to get the following problem.

Every now and then Poweramp loses its connection from listed songs to actual mp3 files. I have all mp3 files on my external memory card in my smartphone. Whenever the problem appears, Poweramp would act as if all songs listed in Poweramp had been deleted. If I try to play "all songs" in random order e.g., Poweramp would skip all songs from my music folder and rather play some voice recordings (which are in internal memory). I then have to rescan my library and afterwards everything works fine again. I know there is an option "auto-scan" but in my case it does not work very well because I tend to get automated rescans whenever I want to listen to some music (and rescans take some time...). Anyway, if I do not change anything in my music folder, why rescans?

There is another issue, probably related to the above-mentioned one: I have created a playlist and planted a shortcut to it on my home screen (via widget => playlist 1 x 1). After a few days this shortcut loses its functionality. All my songs in Poweramp work fine but when I tap on the playlist widget, nothing would happen. Just as if this playlist was empty (which is not the case).

I assume, all this has something to do with the fact that my songs are stored on external storage. But what causes this problem? And how could I fix this issue?

Thank you very much for you advice!

Yukusoona

Poweramp build-911-arm64-play
Full Version
64 bit

Samsung Galaxy S9 (SM-G960F), Android-Version 10 (no Root)

Link to comment
Share on other sites

22 minutes ago, Yukusoona said:

Anyway, if I do not change anything in my music folder, why rescans?

The simple auto-scan is just looking to see if there are any changes; if there aren't it won't change anything.

Do the storage access issues occur when you first run PA (which was a known Samsung issue) or also sometimes within sessions?

Andre

Link to comment
Share on other sites

No, as far as I remember, it has never happened within sessions. Problems only occur when I start Poweramp in order to listen to music. Do you have any idea? What is it about this "Samsung issue"? Anyway, was means it has been already fixed and should not be the causative problem?

 

Link to comment
Share on other sites

@Yukusoona As I understand it, the issue was first found in a Samsung Android 11 ROM, but an update about six months ago resolved it. Turning off the Auto Scan feature in PA Settings > Library > Scanner will prevent the issue from occurring anyway. Also PA Settings > Misc> File Access Legacy Mode should be disabled for Android 11, but it also may not help in Android 10.

See this thread to see if it describes your problem:

Andre

Link to comment
Share on other sites

I've had the same problem since upgrading to Android11.  Poweramp just will NOT work.

I reached out to support, uploaded logs...  Got nowhere.  They didn't even reply.

If I hit the + in Music Folders Selection I get  "Add Storage/Provider Plugin  Please use sidebar in the system dialog to select the target storage/provider plugin"

Then I get a "Failed  The folder selection system component seems to be missing/disabled/frozen on your device.  Please enable the component. Alternatively, you can enable legacy mode.  The file access legacy mode won't be supported in the future versions of Android"  then a quick popup "No Activity found to handle Intent { act=android.intent.action.OPEN_DOCUMENT_TREE(has extras) }"

I've made sure Poweramp has All Files and media access permission.  I tried enabling file access legacy mode, which worked!  Until either I reboot my phone or quit/restart Poweramp.  I've also cleared storage/cache of the app and uninstalled/reinstalled.

Version build-911-arm64-play

Oneplus 7t pro 5g mclaren on Android 11

Google Files app is installed and can browse storage. Music is stored in internal storage/Music

full purchased

EDIT:  Sorry.  Didn't mean to hijack this thread.  This is the first time I've read about someone with similar problems.

Link to comment
Share on other sites

@IH8Speedbumps First, don't use Legacy mode, it's not designed for Android 11. You don't say what device or where your music files are located, but I'm guessing probably on an SD Card?
 

Make sure you have the relevant Files system app installed (especially if you are running a custom or cutdown ROM):


Try clearing app data and permissions and starting the Music Folders selection process from fresh, granting permission again.

 

This will all change again with Android 12 probably, as Google continue to break storage access in the name of progress. :(

Andre

Link to comment
Share on other sites

"Legacy mode" was switched off in my case. I use Android 10 by the way. So all in all this does not seem to by the problem in my case, does it?

I have found another nuance of my problem: When I create a shortcut to a playlist on my android home screen (via widget), it would work for a while. But after 1 day or so tapping on the playlist widget would open Poweramp only but not start the playlist. However, when I open the same playlist from within Poweramp, it would start correctly. Thus, I get the impression that Poweramp loses connectivity to my songs and that somehow it regains it, which is why the playlist within Poweramp would continue working. But the shortcut on my home screen would keep the "lost connectivity", which is why it would not work.

Still, there are times where even my playlists within Poweramp get corrupt and stop working (as mentioned in my first post).

All in all, this makes me quite sad because I like Poweramp, I have got used to it but need to rely on my music software...

Link to comment
Share on other sites

If these issues are happening shortly after a reboot or power up, it is very likely the external storage has not yet mounted. If you have a slower uSD card, or even just a lot of files that the OS wants to scan first, it will take some time before Android makes this storage available to the system. So if Poweramp is started I’m the meantime, it won’t have access to this storage either.

Does the problem exist if the phone has been started and running for some time?

Link to comment
Share on other sites

@MotleyG No, unfortunately not. I know what you are talking about, but it's not the problem in my case.

First of all, I belong to those persons who do not switch their phones off at any time. I'd rather go into plane mode at nights but keep the phone on. So, my problems exist irrespective of reboots.

Secondly, I have just made the test: I have created a new shortcut to a playlist on my home screen. It works fine. I have then rebooted by phone and voilà: the shortcut still works. In other words, the playlists lose their "connectivity" to my songs for another reason (not related to reboots). 

Legacy mode is switched off in my Poweramp. "Auto scan mode" is also switched off. I have remounted my music folders: my main storage and the SD card are both completely accessible to Poweramp. I have granted Poweramp the special rights to use my SD card. Honestly, I don't really know what else to try out...

Link to comment
Share on other sites

3 hours ago, Yukusoona said:

@MotleyG No, unfortunately not. I know what you are talking about, but it's not the problem in my case.

First of all, I belong to those persons who do not switch their phones off at any time. I'd rather go into plane mode at nights but keep the phone on. So, my problems exist irrespective of reboots.

Secondly, I have just made the test: I have created a new shortcut to a playlist on my home screen. It works fine. I have then rebooted by phone and voilà: the shortcut still works. In other words, the playlists lose their "connectivity" to my songs for another reason (not related to reboots). 

Legacy mode is switched off in my Poweramp. "Auto scan mode" is also switched off. I have remounted my music folders: my main storage and the SD card are both completely accessible to Poweramp. I have granted Poweramp the special rights to use my SD card. Honestly, I don't really know what else to try out...

Is it possible your media card has some errors, or is breaking down? This does happen after time, especially if the stored data is close to the maximum capacity and is accessed often. Perhaps try with a different card made by a different manufacturer and capacity as a test. I don’t have this issue on two different devices on my side, one I LG G8 with a 400GB Sandisk Ultra card, and iBasso DX160 with a 512GB Sandisk Extreme card.

Link to comment
Share on other sites

@MotleyG Thank you for this advice. I'll keep this definitely in mind but must admit that right now I don't have the time (nor do I have another SD card) to switch/reinstall etc. My SD card is 64 GB and I bought it new with my Samsung S9 (about 2 years ago). So far, I have not had any other issues with my SD card. It is, by the way, encrypted (as offered by Samsung S9). But the encryption, too, has never caused any problems so far.

Link to comment
Share on other sites

1 minute ago, Yukusoona said:

@MotleyG Thank you for this advice. I'll keep this definitely in mind but must admit that right now I don't have the time (nor do I have another SD card) to switch/reinstall etc. My SD card is 64 GB and I bought it new with my Samsung S9 (about 2 years ago). So far, I have not had any other issues with my SD card. It is, by the way, encrypted (as offered by Samsung S9). But the encryption, too, has never caused any problems so far.

When you have a chance to do so, I would definitely try it without the encryption enabled. This is an added layer of actions involved while PA is trying to access many files in a short time.

The fact that you haven’t had other issues is not an indication the card isn’t failing. Remember that PA is actively pulling data each time it accesses files to play, and also it is indexing the folders and files whenever you update the library. There probably aren’t too many other applications doing this as intensely.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...