Jump to content

Voice search by album returns an error


returnofthem
 Share

Recommended Posts

I should be able to ask Google Assistant to play an album like this: "play the album <album> by <artist> [on <service>]" - the service bit is optional and if you omit it it will use the service configured as the default, which on my phone is Poweramp.

When I try this with Poweramp, for example, "Play the album Abbey Road by The Beatles" I get "Sorry, something went wrong. Please try opening the app to continue."

If I omit the words "the album", for example, "Play Abbey Road by The Beatles" then Poweramp starts playing one song from the album (seemingly at random) but does so in the "All Songs" list, so the next song will be from a completely different album. 

I've done the obvious things like checking that Poweramp recognises the album (it does, it's listed in the albums view in the library) and checked that the tags are correct (e.g. album artist and artist set correctly) and that all seems fine. If I use the same command but tell Google Assistant to use Spotify - "Play the album Abbey Road by The Beatles on Spotify" - then it works as expected.

If more info is needed let me know and I'll try to provide it. Thanks!

Poweramp: build-911-arm64-play [911004-cb218340] 64 bit
Device: Samsung Galaxy S10e
Android: 11
 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...