Jump to content

Incorrect track title & album art displayed


Recommended Posts

When starting Poweramp it displays the correct album art and track title. When skipping to the next track the preceding album art and track title remain, but if you watch carefully you can actually see the correct album art (for newly played track) for a fraction of a second in the right-to-left animation, but it just slides behind the wrong (preceding) track's art and disappears. The track title never changes to be correct. If you press skip again and again it'll finally show the correct album art and track title approximately once for every six track skips. So, for at least 80% of the time the wrong album art and track title are displayed. The songs all play fine and the decibel-o-meter moving graph shows correct too.

Circumstances:  playing all songs on shuffle, with visualizations running (the only way we use PA, and the only way we want to use it)

Background info:  Beelink GTKing, Android 9, v3-build-871-arm32-play, Full Version, Full version unlocker build-302

Already tried:  have read the three or four threads on this or very similar bugs that are in the forum from the past three years and tried to implement those settings to no avail, but to be honest the amount of available settings is pretty overwhelming

Link to comment
Share on other sites

I'm afraid I can't replicate this at all on my devices, with or without any visualisations running. Are you saying that on your phone screen, PA plays one song but usually displays the incorrect cover art AND incorrect Title/Artist/Album text? Are you using the default skin, and does it still happen with visualisation off?

Andre

Link to comment
Share on other sites

Its on my TV screen actually. This isn't running on a phone but on an Android TV box, but yes, on the screen it displays the wrong album art AND incorrect title/artist/album text. Also, this TV box is running full Android and not "Android TV" OS.

Will run PA exactly the same later but turn off visualizations and see what happens.

Have seen this same issue mentioned in older threads in this forum:

 

Link to comment
Share on other sites

Sounds like the problem is related to devices designed for TV use then, rather than regular phones/tablets.

Unless Max can duplicate this on any of his test equipment, it might be worth sending a debug log to him. Run PA and play some music and swipe several tracks to demonstrate the fault, then go immediately to Settings > Get Support > Send Log, and email the resulting log data to gpmaxmpz @ gmail.com. Please message @maxmp directly here too, letting him know what email address you just sent the report from and referencing this thread so he can link them up. 

Andre 

Link to comment
Share on other sites

Incorrect album displayed where? In Poweramp UI? What about miniplayer? If you drag image down does it transition to incorrect list row as well? 

I don't think this is ever reproducible as it will be very obvious. I would recommend updating to the latest builds anyway.

Link to comment
Share on other sites

The incorrect album art is displayed in the Poweramp UI.  I don't know what a miniplayer is. If you drag down the album art image it transitions to the CORRECT list row, and if you then hit the "now playing bar" near the bottom of the screen it returns to the original UI screen and then shows the CORRECT album art and track title for that same song.

Turning off visualizations does not affect this behavior, and will still show incorrect album art and track title many times over before "catching up" (see below for clarification of behavior).

Will send a log of this behavior tonight --> should I update to the latest builds first and then send log? Or wait to update until after sending log?

To clarify the behavior, when first starting the app:
plays song A and shows the correct album art and track title for song A
---> hit skip button to go to next track (song B )
plays song B but shows album art and track title for song A
---> hit skip button to go to next track (song C)
plays song C but still shows album art and track title for song A
---> will repeat this behavior 2X to 4X more times before it "catches up" and shows album art and track title for Song N, while playing Song N

Link to comment
Share on other sites

I would update to latest version and do a Full Rescan first, just in case that solves the problem, and it's also easier for troubleshooting.

The "mini player" is what you describe as the "now playing bar" by the way, i.e. the little one-line playback interface at the bottom of library list screens.

Andre

Link to comment
Share on other sites

Updated to newest available build... 874
Sent log on Jun 17 at 5:54 PM

The behavior is still there with the newest build, but it does seem to happen a bit less... ~60% of the time versus ~80% of the time with the older build
Also noted that this behavior still occurs without hitting the track skip button... by just letting the whole song play and it automatically playing the next track it will still show wrong art and track title

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...