• Announcements

    • andrewilley

      Poweramp v3 Project Update   04/24/2017

      As you may be aware, the Poweramp developer has been working hard on an updated material design user interface for Poweramp v3 which required a full ground-up rebuild of the code. It is hoped this will be ready for final beta-testing by the end of the May. See forum thread for more details and to discuss.    
Sign in to follow this  
Followers 0
iPokz

Bluetooth Metadata/Control not work On my Samsung Device

6 posts in this topic

Hello,

I have big problem about Bluetooth Metadata/Control on my Samsung Devices. 

I tried on Samsung Note 2 ( Android 4.3 ), Samsung S7 Edge ( Android 7.0 )  both not work :( ( Check/Uncheck metachange Intent both not work )

but on Asus Zenfone 5 ( Android 5.0 ) it working fine T_T 

this feature is important while driving a car.

 

 

iPokz

Share this post


Link to post
Share on other sites

Metadata transfer vie Bluetooth has always been a little flaky, but simple playback controls (Play/Pause, and << and>> ) should work. I use a Samsung Note 3 and BT play controls work fine (although there is sometimes a delay of up to a minute after connecting before the control functions work). 

Andre 

Share this post


Link to post
Share on other sites

Probably mentioned before that I also have the BT problem with my car headunit. Sometimes it works, sometimes it doesn't and I can't seem to be able to narrow it down to anything in particular. However, recently did some more experiments. 1) the Samsung music player (got a Galaxy S7 with more or less stock 7.0.x ROM) works fine. 2) a Galaxy S4 running a version of Android 6.x (CM) runs fine with the stock music player.  3) a Windows 10 phone works fine as  well.

Now, I can't remember why I was testing these other phones out but I noticed that after using them then PA (version 3 SW) on my S7 also started to work fine. For a while. I'm wondering if it could be some BT initialisation issue with PA? Just thought I'd throw out a theory ......

 

 

Share this post


Link to post
Share on other sites

Maybe an additional data point for Max to work on, or maybe not ..... got to work yesterday after BT was working OK for once. i.e. the track title/artist was scrolling on my car head set as it should. At work I hardly use my phone so when I left the same track was at the same position to play again. However, when it finished and a new track came on the old BT data was still on the headunit suggesting the new one hadn't been downloaded.

This works fine with other players as I mention above.

 

Over to Max .....

Share this post


Link to post
Share on other sites

Poweramp has stopped working between my Galaxy S7 Edge and my cars head unit after upgrading to Nougat.  After some testing last night, it appears all my other audio players correctly report track title / artist and respond to key commands.  This was working fine in Poweramp as well before the OS upgrade.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0