Jump to content

External SD card folders don't show up in Folder Hierarchy and don't appear to be scanned


Go to solution Solved by andrewilley,

Recommended Posts

I plugged an SD card via adapter to my Galaxy S21 Ultra. I added the music folders on the card to Poweramp's music library, and if I use an Android file explorer to open music files with Poweramp, it works.

But Poweramp doesn't show the music folders I selected under "Folders Hierarchy", and I don't think the folders are being scanned at all.

How can I get Poweramp to show these folders in its "Folders Hierarchy" view?

Link to comment
Share on other sites

I already did that; Poweramp can correctly allow me to choose the right folders, and can play files from the card if I go through a file explorer app and choose "Open with... -> Poweramp"

I don't get any permission errors (which I did at first until I granted them).

Link to comment
Share on other sites

Incase you don't know to grant permission, in Poweramp settings - library - Music folder - Add folder / storage. Select the storage or folder you want, then grant permission. It is advisable to create a folder on the root of the storage, then move your music into that folder, then set that folder(s) for Poweramp to access. 

Link to comment
Share on other sites

If it was a permissions problem I shouldn't be able to play the file in Poweramp, even if opened through a file explorer right? And I've checked every time I mount the card that Poweramp remembers the selected library folders on the card.

Link to comment
Share on other sites

  • Solution

First, check PA Settings => Misc => File Access Legacy Mode. Legacy mode does still work on Android 12 (are you using that?) so it might be worth trying if the newer SAF is not working for you.

Then disable access to the SD Card by tapping the 'X' in the Music Folders screen. Then go back through the process of re-granting access to just the main folder which contains your music (not to the root of the SD Card). Once done, re-tick that folder in the list (all subfolders will automatically get selected too) and if necessary then try a FULL Rescan..

Andre

Link to comment
Share on other sites

So I tried your suggestions and at first it didn't work until I realized that there's an actual FULL Rescan (not just the regular Rescan)... That's all that was really necessary. The legacy mode didn't make a difference.

Thank you!

Link to comment
Share on other sites

Full Rescan should have been triggered the first time you granted permissions to your Music Folders in the first place, perhaps the permission did not work at that stage? Full Rescan forces the whole library to be ditched and the storage scanned again from scratch. Sorry I assumed that had already been tried, but reading back through the thread I don't see it mentioned.

Andre

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...