Jump to content

Issues with Multiple Genres in tags


GeilerHeinz
 Share

Recommended Posts

Is there an solution for this issue?

For me it still exists under PA v3 build 893.

I have many audio files tagged with multiple genres via foobar2000, which uses the standard semicolon as separator. In PA settings I have set ; as symbol to split multiple genres. Nevertheless PA lists the particular audio files under newly generated genres like Blues Rock:Southern Rock instead of listing them under the existing genres Blues Rock and Southern Rock.

Regards

Link to comment
Share on other sites

As long as you have inserted semicolons as separators in your Genre tags, and have the semicolon character listed as one of the symbols in Settings > Library > Scanner > "Symbols to Split Multiple Genres", then it should work fine - and has done for more than two years now, since around alpha-test build 795.

If you have an old music database, you may need to do a Full Rescan (in Settings > Library) to update any previously saved non-split entries.

Andre

Link to comment
Share on other sites

1 hour ago, GeilerHeinz said:

... newly generated genres like Blues Rock:Southern Rock ...

Was that a typo, as that indicates a colon rather than a semicolon.

What do you see if you long-press on a song that should show separate Genres, and view Info/Tags? Can you post a screenshot of that, and the Settings>Library>Scanner screen?

Andre

Link to comment
Share on other sites

3 hours ago, GeilerHeinz said:

No, unfortunately that wasn't just a typo.

Well that's your problem right there then. That particular music file is using ":" (colon) as an item separator in its Genre tag, while you have told Poweramp to only use ";" (semicolon) for breaking up the Genre tag. So you wouldn't expect to see a string with a colon in getting split.

Just add a colon to the separator characters list in Settings > Library > Scanner > "Symbols to Split Multiple Genres". Make sure you leave a space between the two separator characters in that menu line (so it should be semicolon space colon). Then do a Full Rescan.

Andre

Link to comment
Share on other sites

Curious. In Foobar2000 I set semicolon as separator. That's why I interpreted the resulting colon in the genre tag in PA just as an indicator that the multiple genres cannot be parsed correctly.

Anyway. Adding colon in Settings > Library > Scanner > "Symbols to Split Multiple Genres" solved my problem. 

Thanks, Andre, for your hint to this simple solution.

Regards

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...