Jump to content
Sign in to follow this  
Nic

Duplicate songs and missing album art

Recommended Posts

I've recently had to change both phone and laptop - most files were easy to transfer, but music has been a problem: having down-loaded to my phone I was unsurprised that the Samsung Music did not bring up album art - I knew Poweramp would, it did, but I now have 2 of every song (x 250 Albums). Deleting Poweramp and all music, I tried Poweramp again: same issue. It seems that the app does not fully delete/uninstall - perhaps it would be useful to know how to remove it entirely?

Is there an answer ?- someone has suggested that Poweramp stops other apps getting album art - I've no idea - but I would like to be able to use my machine without glasses and Album covers help - much of the power of Poweramp is wasted on me,  I just want to be able to recognise music and play it...

Thanks for any help

Nick

Share this post


Link to post
Share on other sites

Uninstalling and re-installing should cause your PA system to go back to zero, and thus look for music from a fresh start (same can be achieved by using the FULL Rescan option within the app by the way).

If that still returns duplicates, check Settings > Library > Music Folders to ensure that your device isn't showing the same 'real' directory under two different symbolic location names, creating a 'phantom' directory. Check that your music folder is only ticked once.

Ensure you don't have any unnecessary .CUE files in your music folders, which would cause PA to see both the original audio file and also a second version created by the .CUE file.

Andre

Share this post


Link to post
Share on other sites

Hello again,

Apologies in anticipation...

I think the duplication issue is solved: eventually I factory reset the phone, re-loaded Poweramp etc - now I have a different problem which I think may be connected to Poweramp (as I have used the music stored on old device with PA to transfer to new laptop, and then to new phone).

Most of the transfer worked well but about 40 albums are classed as Unknown (though usually with the correct album art), and  these are missing the first track (which appears by itself as another, separate Unknown without the picture). I suspect this is as a result of a similar fragmentation which happened in Windows Media Player - but this I could "solve" (or so it seemed) by dragging/dropping the bits of albums together: it appeared that all was as it should be.

As will be clear: I'm just a user, with no computing knowledge (or inclination)

Thanks for any help...

Nick

Share this post


Link to post
Share on other sites

You could try a Full Rescan. It seems as though some tracks are being found by their filename, but their tag info (assuming it is correct) is not being read by the automatic scanner. With these problem songs, what do you see if you start the song playing and then tap Menu > Info/Tags ?

Andre

Share this post


Link to post
Share on other sites

Hi

Sorry not to respond - the Full rescan does nothing, I'm not sure where the Menu>Info/Tags are or is - I have only got the "temporary" version at the moment, maybe that makes a difference?

Yours

Nick

Share this post


Link to post
Share on other sites
6 hours ago, Nic said:

 I'm not sure where the Menu>Info/Tags are or is

When a song is playing, press the Menu icon (three-dots, usually in the upper-right of the screen) and select Info.Tags.

The trial version is exactly the same as the full licensed version, the only limit is time not features.

Andre

Share this post


Link to post
Share on other sites

Hi

I get it 

Example: Track 1 of Committments - no album art, shows as "unknown" everything and is separated from the rest of the album which is elsewhere and also unknown, others have the art but miss track 1 or variations on that theme....

 

Info/Tags:

/storage/68A9-01BE/Music/The Committments/The Committments/01Mustang Sally.mp3

genre:

Unknown

artist:

Unknown

album:

Unknown (08/09/2018 09;13:14)

album art:

no embedded album art

 Sorry

Nick

Share this post


Link to post
Share on other sites

Then it looks like that particular file has no embedded 'ID3' data tags, which is where title, artist/album names, etc are stored., and also cover artwork Try checking that file out with a tag editor program - I use TagSanner on my PC, but there are lots around.

Andre

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...