Jump to content
Poweramp
Sign in to follow this  
KennyPowers

song info displaying incorrectly over bluetooth

Recommended Posts

Information for the currently-playing song recently started displaying incorrectly on my car's head unit when playing audio over bluetooth.  Here is a picture demonstrating the problem:

https://photos.app.goo.gl/K2vswkbRQEadrruBA

As you can see, the "artist" line is now displaying both the artist's name and the album name separated by a '-'.  The "song name" line displays correctly.  Then, the "album name" line is displaying the song's duration and the file type separated by a '|'.  This just started happening within the last week or so (I have Poweramp set to automatically update).  Previously, all of the currently playing song information displayed correctly on my car's head unit.  So, for example, the song in the picture previously displayed as:

Nirvana
Love Buzz
Bleach

I'm running a Pixel 3 with the stock Android 9 rom.  Poweramp version is "v3-build-820-play (Full Version)".  I have made no firmware updates or settings changes to my car's head unit.

Share this post


Link to post
Share on other sites

Same issue in my car as well. Also it doesn't display the song length, and it will go from 0-5seconds then the timer will go back to 0.

I'm using pixel xl android 9.0 stock

Poweramp v3 build 820

VNnE3BY_d.jpg?maxwidth=640&shape=thumb&f

Share this post


Link to post
Share on other sites

This seems to be a problem with the way some bluetooth devices read the provided info from incorrect fields, see:

Andre

Share this post


Link to post
Share on other sites

I can confirm that disabling everything under "Settings -> Misc -> Android Auto" in Poweramp makes song info display correctly again in my non-Android Auto equipped car.

Share this post


Link to post
Share on other sites
On 2/18/2019 at 7:46 PM, KennyPowers said:

I can confirm that disabling everything under "Settings -> Misc -> Android Auto" in Poweramp makes song info display correctly again in my non-Android Auto equipped car.

Thanks this worked for me as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...