Jump to content

Crashing on Oreo


Recommended Posts

I'm currently on an AT&T Note 8 and using Poweramp version alpha-build-703-play and the trial unlocker. While on all stock Nougat Rom's up thru the latest security release N950USQS3BRA8, it works perfectly. But any of the pre-release Oreo Rom's Poweramp crashes, no errors, it just locks up and I have to force close it. 
 I've tried to clear cache, un-install/re-install with no luck. I've tried 4 different Oreo Rom's and have had the same problem with all 4. This includes the latest N950USQU3CRB1.

Link to comment
Share on other sites

  • 1 month later...

So I've had this issue on my Galaxy S8 SM-G950U on the latest Oreo beta. I though it had to do with the app not being full screen compatible but it would still crash and no longer launch no matter my display setting. A workaround that has worked for me after PA crashed and no longer starts is to go to Poweramp in Apps, Storage and change the "Storage used" to external. Power came back up without clearing my Data. Do note that when set to external storage you will get the splash screen on every initial launch after clearing the app from memory or restarting. Home screen widgets also no longer appear.

Link to comment
Share on other sites

  • 2 weeks later...

I'm having problems with the app crashing on my new phone sporting Oreo as well.

Phone/Model:  Samsung Galaxy S9+ SM-G965U1
OS:  Oreo v8.0.0
Android security patch level:  Feb 1, 2018
Poweramp version:  alpha-build-703-play (Full Version)

What's happening:
After a reboot Poweramp starts up normally, once.  If I close the app and try to re-open it I'm met with a black screen and have a few minutes a message from Android pops up indicating the app isn't responding, do I want to close it down or wait.  I can close it down and reopen it and after several attempts it will finally work.  If I keep Poweramp running "in the background" I have no problems with it.  (I've started using the "Lock apps" option in Android so when I "close all" it keeps Poweramp running.)

When I first installed Poweramp on this phone I didn't notice any issues at all.  I'm not sure if this is a coincidence, but around the time the Feb security patch installed this issue cropped up.  Another change I made around the same time was to change all 5,000 or so MP3 files I have on the phone to the FLAC format.  And when I did so I imbedded album art in the tag of each FLAC file - I did not do that when using MP3s.  I have tried uninstalling and reinstalling Poweramp.  I have tried doing the same thing while deleting the old settings file and starting from scratch with settings.  I have tried importing settings from the prior install after a clean install.  I have also tried disabling the "auto scan" option in Poweramp.  None of these efforts have made a difference.  Oh, and Poweramp is installed on internal storage.

I see this topic has been brought up elsewhere as well - thought I did so good posting in a thread I found as opposed to starting a new thread!  Ugh...


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...