Jump to content

Agama - Poweramp integration? Play music on startup


Go to solution Solved by GR80,

Recommended Posts

Hi there!

 

Is anybody using Poweramp with Agama launcher? I would love to have it play music automatically as soon as I start my car and everything loads but I always get the message on Agame Launcher "waiting for music player" and its like the music is paused and if I don't tap on pause/play it won't  just play the music. How can I go around this?

 

I have both apps (Poweramp, agama) fully paid for

Link to comment
Share on other sites

You  can tell PA to autostart playback, but there is the caveat that your device must have finished its own startup process and mounted the necessary storage first. See PA Settings=>Audio=>Audio Focus=>Resume on Start / Resume on Reopen / Wait for Storage.

Andre

Link to comment
Share on other sites

On 5/28/2022 at 3:01 AM, andrewilley said:

You  can tell PA to autostart playback, but there is the caveat that your device must have finished its own startup process and mounted the necessary storage first. See PA Settings=>Audio=>Audio Focus=>Resume on Start / Resume on Reopen / Wait for Storage.

Andre

Thanks for the quick reply. I did that.. enabled those two and it still shows "waiting for player" when agama launcher loads... It wont automatically play music unless I manually click/tap on play/pause

By the way, I must specify that if I open PA it will automatically play as soon as it opens. What I am trying to do is have it play when the Agama Launcher loads. Seems like the PA loads on the background but for some reason it won't play music right away unless I hit play in Agama launcher

Link to comment
Share on other sites

  • Solution

I found a way around this "issue"

Agama Car Launcher has an option to "auto start" apps. If I open the PA it will automatically play music, that's cool but that is what I was trying to avoid (or hitting pause/play in the Agama Car Launcher). I want it automated!

Setting the auto start times to 5 seconds for PA and 7 seconds for the Agama Car Launcher works perfectly. Basically, the radio starts and when it already loads the Agama Car Launcher and connects to the wifi and bluetooth it automatically launches PA but 2 seconds right after that it goes back to Agama and it doesn't even give enough time to show anything on the screen (the PA loading process) but it is enough time to make it stay open in the background. So, in a few words, the radio starts playing music about 3-4 seconds after the Agama Car Launcher initially loads. Hope this makes sense but yea, it is exactly how I wanted it! And, since I found this solution I might as well load Waze instead of Agama again and that way the car is 100% ready to go. Plays music and gets Waze ready! SWEET!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...