Jump to content

Current Track Miniature Uncorrect (build 812)


Recommended Posts

First of all, i want to thanks @maxmp for his amazing work. V3 is awesome to use.

Anyway, i have encountered a bug related to the "Current track playing" miniature that it is displayed while navigating through the library. Sometimes, it does not show the actual track that it is being played. I attached some photos to illustrate.

The problem seems to only occur when i open the app (I usually open it with the widget, not sure if that matters) after a couple of hours without using it. The problem persists even if I load a different playlist (I mostly use custom playlists to listen to my local music), and it is only corrected if i close the app and re-open it again.

Something that I have also noticed is that the current track playing seems to reference songs from the "All songs" category in the library, since it has also displayed songs that i don't have in any playlist.




Edit: Forgot to add. Device is LG G6 H870, with Android Oreo 8.0.0. Poweramp build is v3-build-812-play

Link to comment
Share on other sites

Hmmm... It usually happens when I haven't used Poweramp in at least an hour. Sometimes the current track that I left playing is not correctly displayed, sometimes it happens when i change the playlist. When it isn't working, I can change to a different song or playlist, and still the current track miniature is incorrect. But I haven't really found a consistent way to make the bug happen.

What I've found is that closing the app and opening it again solves the problem. If not immediately, in question of a very short time.

Link to comment
Share on other sites

After last post, I've tried to investigate a bit further in regards of the "does it happens for a short time sometimes?" question. This is what I've done.

1. With the player correctly displaying the actual current song in the current track miniature, I closed the app using the "Recent Apps" button and menu.

2. After an actual hour, I open the app using the widget, and the current track playing problem appears again.

3. I select a new playlist, and start playing music. I let it play for about 20 minutes (8 different tracks). The current track playing problem is still present.

4. I close the app, immediately open it again (using the widget), and voila, problem solved. The current track playing miniature shows the actual current track being played.

In regards to step 3, I've noticed that the current track miniature shows tracks from the "All songs category" with the same initial position and shuffle mode. When I select the first song of a playlist, the current track miniature shows the first song of the "All songs" category. And with the shuffle all songs from the same category mode activated, the current track miniature shows shuffled (hope that's how it's written) songs from the "All songs".

If I have to describe it in more programming terms, i would say that the current track miniature pointer seems to have problems loading the playlist being currently played, but it seems to correctly get the positional value and shuffle info.

Hope this is helpful!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...