Jump to content
Sign in to follow this  
pacman10

How do I stop PowerAMP ?

Recommended Posts

I'm using Poweramp on an HTC Desire phone with Android 2.2.

Poweramp starts up on its own without my firing it up. Example: I play some songs with Poweramp then shut it down with the Back button, switch off the phone with the top left button while I go off to do some work, restart the phone to listen to a radio talk show in the Internet, and - whaddyaknow - Poweramp resumes playing where I left off and drowns out the talk show.

I checked with the FAQ on this forum and read:

Q. How do I stop Poweramp?

Q. Where is the exit button?

You can close it the same way you close stock player (back button or home).

Poweramp service doesn't do any job if it's paused. No scan or anything. Scan takes few seconds when new card is mounted.

Poweramp service asks android to stop itself after 30 seconds of idle.

Poweramp has a Stop button (long press the pause/play does that), though that has nothing to do with the process or background running and it's not necessary to press this if you just want to exit Poweramp.

but the Back button doesn't kill it off in my case. Poweramp simply seems to hibernate and wait for me to start the phone again.

Any suggestions ?

Share this post


Link to post
Share on other sites

On android, app can't start by itself, but some services can be started by Android if some event should be processed by app.

In your case, if you mean it starts when you insert headset - you can disable this feature in PowerAMP settings => Headset options => uncheck Resume on headset connection.

PowerAMP services and other code is unloaded either immediately or after a short idle time (30 sec). There is "permanent" headset micro service, though it doesn't do anything, eats around 0 bytes of memory and can be disabled by abovementioned option.

Thanks!

Share this post


Link to post
Share on other sites
........ it starts when you insert headset - you can disable this feature in Poweramp settings => Headset options => uncheck Resume on headset connection.......

Thanks. That seems to have been the cause.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...