Jump to content


Approved Members
  • Content Count

  • Joined

  • Last visited

About rondv

  • Rank
  1. I found the problem! I went to "Settings"-->"Accessibility"-->"Hearing"--> and unchecked "Mono audio". For some reason it was checked by default, never messed with it before. Now I'm totally happy with the sound. My phone is S3 Mini. Thanks for your response.
  2. Poweramp has a very vague L & R channel separation. If I listen to just one channel and move the Balance to either maximum L or R channel there is no difference in what I'm hearing, content- and level-wise. I've also played with either Mono setting, same result. Also, I have a song file with strong panning effects (Aero by Jean Michel Jarre) and the effect is non-existent, meaning I hear it with both my ears at the same time. Am I the only with this problem and how can I solve this? (Sorry for my english, it's not my first language)
  • Create New...